postgres.git / summary / log / commit / refs
commit 128fd0a65ae54d97896cb6409fbc56d5da6319f1
Author: Fujii Masao <fujii@postgresql.org>
Date: Tue Jul 28 02:23:02 2020 +0000
First released in: 13.0
doc: Mention the rename of wal_keep_segments GUC in release note.
Commit f5dff45962 renamed wal_keep_segments to wal_keep_size.
This commit adds the mention to this change in the release note.
Author: Fujii Masao
Reviewed-by: David Steele
Discussion: https://postgr.es/m/dc4768f2-1eff-d2fc-35ba-6b2985b7cb6c@oss.nttdata.com
doc/src/sgml/release-13.sgml | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
diff --git a/doc/src/sgml/release-13.sgml b/doc/src/sgml/release-13.sgml
index 95d6631faab..18e6497a7f2 100644
--- a/doc/src/sgml/release-13.sgml
+++ b/doc/src/sgml/release-13.sgml
@@ -209,6 +209,28 @@ Author: Fujii Masao <fujii@postgresql.org>
<listitem>
<!--
+Author: Fujii Masao <fujii@postgresql.org>
+2020-07-20 [f5dff45962] Rename wal_keep_segments to wal_keep_size.
+-->
+
+ <para>
+ Rename configuration parameter <varname>wal_keep_segments</varname>
+ to <xref linkend="guc-wal-keep-size"/> (Fujii Masao)
+ </para>
+
+ <para>
+ This determines how much WAL to retain for the standby server,
+ specified in megabytes rather than number of files. If you
+ previously used <varname>wal_keep_segments</varname>,
+ the following formula will give you an approximately equivalent setting:
+<programlisting>
+wal_keep_size = wal_keep_segments * wal_segment_size (typically 16MB)
+</programlisting>
+ </para>
+ </listitem>
+
+ <listitem>
+<!--
Author: Tom Lane <tgl@sss.pgh.pa.us>
2020-03-05 [84eca14bc] Remove ancient hacks to ignore certain opclass names in
-->
[parent: cebe10a5f307]