postgres-github.git / summary / log / commit / refs

commit    434dab76ba76fba5dacab2dc695b6b3d5df8315b
Author:   Andres Freund <andres@anarazel.de>
Date:     Sun Apr 05 04:43:54 2026 +0000

    read_stream: Move logic about IO combining & issuing to helpers
    
    The long if statements were hard to read and hard to document. Splitting them
    into inline helpers makes it much easier to explain each part separately.
    
    This is done in preparation for making the logic more complicated...
    
    Reviewed-by: Melanie Plageman <melanieplageman@gmail.com>
    Reviewed-by: Nazir Bilal Yavuz <byavuz81@gmail.com>
    Discussion: https://postgr.es/m/f3xxfrkafjxpyqxywcxricxgyizjirfceychyxsgn7bwjp5eda@kwbduhy7tfmu

[parent: a9ee66881744]