postgres.git / summary / log / commit / refs
commit 81aa0a2fa7c4d35511e68daf1ba47bdfa3ec5474
Author: Peter Eisentraut <peter@eisentraut.org>
Date: Mon Aug 17 14:36:40 2026 +0000
Replace printf format %i by %d
as is PostgreSQL standard
src/backend/postmaster/datachecksum_state.c | 4 ++--
src/test/modules/plsample/plsample.c | 2 +-
src/test/regress/pg_regress.c | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/backend/postmaster/datachecksum_state.c b/src/backend/postmaster/datachecksum_state.c
index 368df23e967..28d2a4379d4 100644
--- a/src/backend/postmaster/datachecksum_state.c
+++ b/src/backend/postmaster/datachecksum_state.c
@@ -492,7 +492,7 @@ AbsorbDataChecksumsBarrier(ProcSignalBarrierType barrier)
target_state = PG_DATA_CHECKSUM_OFF;
break;
default:
- elog(ERROR, "incorrect barrier \"%i\" received", barrier);
+ elog(ERROR, "incorrect barrier \"%d\" received", barrier);
}
/*
@@ -530,7 +530,7 @@ AbsorbDataChecksumsBarrier(ProcSignalBarrierType barrier)
if (!found)
ereport(ERROR,
errcode(ERRCODE_INVALID_PARAMETER_VALUE),
- errmsg("incorrect data checksum state %i for target state %i",
+ errmsg("incorrect data checksum state %d for target state %d",
current, target_state));
SetLocalDataChecksumState(target_state);
diff --git a/src/test/modules/plsample/plsample.c b/src/test/modules/plsample/plsample.c
index f294f5ca4ad..31ef4c96f22 100644
--- a/src/test/modules/plsample/plsample.c
+++ b/src/test/modules/plsample/plsample.c
@@ -337,7 +337,7 @@ plsample_trigger_handler(PG_FUNCTION_ARGS)
*/
for (int i = 0; i < trigdata->tg_trigger->tgnargs; i++)
ereport(NOTICE,
- (errmsg("trigger arg[%i]: %s", i,
+ (errmsg("trigger arg[%d]: %s", i,
trigdata->tg_trigger->tgargs[i])));
}
PG_CATCH();
diff --git a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
index b53821dd10c..83073da0bcf 100644
--- a/src/test/regress/pg_regress.c
+++ b/src/test/regress/pg_regress.c
@@ -161,7 +161,7 @@ static void psql_end_command(StringInfo buf, const char *database);
* Convenience macros for printing TAP output with a more shorthand syntax
* aimed at making the code more readable.
*/
-#define plan(x) emit_tap_output(PLAN, "1..%i", (x))
+#define plan(x) emit_tap_output(PLAN, "1..%d", (x))
#define note(...) emit_tap_output(NOTE, __VA_ARGS__)
#define note_detail(...) emit_tap_output(NOTE_DETAIL, __VA_ARGS__)
#define diag(...) emit_tap_output(DIAG, __VA_ARGS__)
[parent: b6b4f5a6460a]