postgres-github.git / summary / log / commit / refs

commit    93da29736649f8f7ecb0787f233a28a02a9738db
Author:   Tom Lane <tgl@sss.pgh.pa.us>
Date:     Mon May 04 22:33:06 2026 +0000

    Declare load_hosts() as returning HostsFileLoadResult.
    
    This function returns some value of enum HostsFileLoadResult,
    but for reasons lost in the development process was declared to
    return "int".  Fix that, for clarity and so that our typedefs
    collection tooling sees the typedef as used.  Also fix the
    variable that the sole call assigns into.  Move the typedef
    to the header file that declares load_hosts() to avoid creating
    header dependency problems.
    
    Discussion: https://postgr.es/m/359138.1777922557@sss.pgh.pa.us

[parent: f6edd8ed708f]