postgres.git / summary / log / commit / refs
commit ef8863844bb0b0dab7b92c5f278302a42b4bf05a
Author: Andres Freund <andres@anarazel.de>
Date: Wed Oct 01 09:54:05 2014 +0000
Rename CACHE_LINE_SIZE to PG_CACHE_LINE_SIZE.
As noted in http://bugs.debian.org/763098 there is a conflict between
postgres' definition of CACHE_LINE_SIZE and the definition by various
*bsd platforms. It's debatable who has the right to define such a
name, but postgres' use was only introduced in 375d8526f290 (9.4), so
it seems like a good idea to rename it.
Discussion: 20140930195756.GC27407@msg.df7cb.de
Per complaint of Christoph Berg in the above email, although he's not
the original bug reporter.
Backpatch to 9.4 where the define was introduced.
src/backend/access/transam/xlog.c | 4 ++--
src/include/pg_config_manual.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/backend/access/transam/xlog.c b/src/backend/access/transam/xlog.c
index 46eef5f21ba..981d4e55274 100644
--- a/src/backend/access/transam/xlog.c
+++ b/src/backend/access/transam/xlog.c
@@ -409,7 +409,7 @@ typedef struct
typedef union WALInsertLockPadded
{
WALInsertLock l;
- char pad[CACHE_LINE_SIZE];
+ char pad[PG_CACHE_LINE_SIZE];
} WALInsertLockPadded;
/*
@@ -436,7 +436,7 @@ typedef struct XLogCtlInsert
* read on every WAL insertion, but updated rarely, and we don't want
* those reads to steal the cache line containing Curr/PrevBytePos.
*/
- char pad[CACHE_LINE_SIZE];
+ char pad[PG_CACHE_LINE_SIZE];
/*
* fullPageWrites is the master copy used by all backends to determine
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
index 195fb262811..9e25ce0fbb8 100644
--- a/src/include/pg_config_manual.h
+++ b/src/include/pg_config_manual.h
@@ -238,7 +238,7 @@
* bytes of wasted memory. The default is 128, which should be large enough
* for all supported platforms.
*/
-#define CACHE_LINE_SIZE 128
+#define PG_CACHE_LINE_SIZE 128
/*
*------------------------------------------------------------------------
[parent: 8492d8634291]