postgres.git / summary / log / commit / refs
commit f78319fec8eb8aed34d6e1e43ca35fb0a9bfe108
Author: Andres Freund <andres@anarazel.de>
Date: Wed Oct 01 09:54:05 2014 +0000
Rename CACHE_LINE_SIZE to PG_CACHE_LINE_SIZE.
As noted in http://bugs.debian.org/763098 there is a conflict between
postgres' definition of CACHE_LINE_SIZE and the definition by various
*bsd platforms. It's debatable who has the right to define such a
name, but postgres' use was only introduced in 375d8526f290 (9.4), so
it seems like a good idea to rename it.
Discussion: 20140930195756.GC27407@msg.df7cb.de
Per complaint of Christoph Berg in the above email, although he's not
the original bug reporter.
Backpatch to 9.4 where the define was introduced.
src/backend/access/transam/xlog.c | 4 ++--
src/include/pg_config_manual.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/backend/access/transam/xlog.c b/src/backend/access/transam/xlog.c
index 7eea5fabaf5..9b938bda740 100644
--- a/src/backend/access/transam/xlog.c
+++ b/src/backend/access/transam/xlog.c
@@ -408,7 +408,7 @@ typedef struct
typedef union WALInsertLockPadded
{
WALInsertLock l;
- char pad[CACHE_LINE_SIZE];
+ char pad[PG_CACHE_LINE_SIZE];
} WALInsertLockPadded;
/*
@@ -435,7 +435,7 @@ typedef struct XLogCtlInsert
* read on every WAL insertion, but updated rarely, and we don't want
* those reads to steal the cache line containing Curr/PrevBytePos.
*/
- char pad[CACHE_LINE_SIZE];
+ char pad[PG_CACHE_LINE_SIZE];
/*
* fullPageWrites is the master copy used by all backends to determine
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
index d1f99fbafef..ba17c4d1f25 100644
--- a/src/include/pg_config_manual.h
+++ b/src/include/pg_config_manual.h
@@ -216,7 +216,7 @@
* bytes of wasted memory. The default is 128, which should be large enough
* for all supported platforms.
*/
-#define CACHE_LINE_SIZE 128
+#define PG_CACHE_LINE_SIZE 128
/*
*------------------------------------------------------------------------
[parent: 721a8bb54602]