postgres.git / log / commits on 2011-01-01

22:50 6600d5e91c75 Minor wordsmithing.
       Robert Haas <rhaas@postgresql.org>

22:43 d7acf6cc4a1a Fix pg_dump support for security labels on columns.
       Robert Haas <rhaas@postgresql.org>

20:55 92a73d219052 Add #include <time.h> to pg_ctl.c to fix compiler warning.
       Bruce Momjian <bruce@momjian.us>

20:44 6a208aa40438 Allow casting a table's row type to the table's supertype if it's a typed table
       Peter Eisentraut <peter_e@gmx.net>

18:18 5d950e3b0c75 Stamp copyrights for year 2011.
       Bruce Momjian <bruce@momjian.us>

17:28 67c9e4442f25 Furter pg_upgrade optimizations to reduce function call argument count.
       Bruce Momjian <bruce@momjian.us>

17:06 6e6bee987ff4 In pg_upgrade, remove use of whichCluster, and just pass old/new cluster
       Bruce Momjian <bruce@momjian.us>

01:42 f82b3e58f887 In pg_upgrade, rename "CLUSTERNAME" to "CLUSTER_NAME".
       Bruce Momjian <bruce@momjian.us>