postgres.git / log / commits on 2011-06-22
23:30 3b3c2cf18005 In pg_upgrade, fix odd function parameter wrapping.
Bruce Momjian <bruce@momjian.us>
23:28 c6c4177f1084 Update alternative expected file for recent sequence test changes.
Tom Lane <tgl@sss.pgh.pa.us>
23:21 6aab24d7bc82 Revert "Don't select log_cnt in sequence regression tests."
Tom Lane <tgl@sss.pgh.pa.us>
21:50 effbe6ecb484 Rename pg_upgrade directory validation function, for clarity.
Bruce Momjian <bruce@momjian.us>
21:47 c6635bd7ba46 Adjust pg_upgrade check for pg_upgrade_support to happen after the
Bruce Momjian <bruce@momjian.us>
21:47 559b114dd466 Adjust pg_upgrade check for pg_upgrade_support to happen after the
Bruce Momjian <bruce@momjian.us>
18:49 7412f5cd29b8 Fix pg_upgrade status message capitalization mistake.
Bruce Momjian <bruce@momjian.us>
18:49 3ccd16c5a92d Fix pg_upgrade status message capitalization mistake.
Bruce Momjian <bruce@momjian.us>
18:48 b06ad7def836 Fix pg_upgrade status message capitalization mistake.
Bruce Momjian <bruce@momjian.us>
17:20 9cc2c182fc20 Add missing -I switch for VPATH builds.
Tom Lane <tgl@sss.pgh.pa.us>
17:20 979d6c9cad8c Add missing -I switch for VPATH builds.
Tom Lane <tgl@sss.pgh.pa.us>
17:08 0ade8421b5b2 Fix symlink for errcodes.h so it works in VPATH builds from tarballs.
Tom Lane <tgl@sss.pgh.pa.us>
17:08 25db27808814 Fix symlink for errcodes.h so it works in VPATH builds from tarballs.
Tom Lane <tgl@sss.pgh.pa.us>
13:39 addf11f9a264 Don't select log_cnt in sequence regression tests.
Robert Haas <rhaas@postgresql.org>
09:18 5da417f7c4b2 Remove pointless const qualifiers from function arguments in the SSI code.
Heikki Linnakangas <heikki.linnakangas@iki.fi>
09:18 fbaa7a23e4d2 Remove pointless const qualifiers from function arguments in the SSI code.
Heikki Linnakangas <heikki.linnakangas@iki.fi>
03:04 503c7305a1e3 Make the visibility map crash-safe.
Robert Haas <rhaas@postgresql.org>
02:57 431ab0e82819 Add some regression tests for serial pseudotypes.
Robert Haas <rhaas@postgresql.org>
02:52 61307dccc5f2 Add smallserial pseudotype.
Robert Haas <rhaas@postgresql.org>
02:32 7095003cbef6 Make deadlock_timeout PGC_SUSET rather than PGC_SIGHUP.
Robert Haas <rhaas@postgresql.org>
02:15 8f9fe6edce35 Add notion of a "transform function" that can simplify function calls.
Robert Haas <rhaas@postgresql.org>
01:54 771a9f69f70e Performance tuning advice for SSI.
Robert Haas <rhaas@postgresql.org>
01:54 66370f5158f2 Performance tuning advice for SSI.
Robert Haas <rhaas@postgresql.org>