From: Tom Lane <tgl@sss.pgh.pa.us>
To: pgsql-hackers@lists.postgresql.org
Subject: copy_file_range is now a Linux kernel call
Date: Tue, 02 Jan 2018 22:44:04 -0500
Message-ID: <31122.1514951044@sss.pgh.pa.us> (raw)
Buildfarm member caiman just came back online after some time AWOL, and
it's not happy. The problem evidently is that pg_rewind's copy_file_range
function conflicts with a recently added Linux system call:
http://man7.org/linux/man-pages/man2/copy_file_range.2.html
Looks like we'd better rename our function. Anybody have an idea
more creative than "pg_copy_file_range"?
(At some point somebody might want to think about fixing this function
so it can make use of the kernel call when available. But that's more
work than I care to do right now, and certainly more change than I'd want
to back-patch.)
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: tgl@sss.pgh.pa.us, pgsql-hackers@lists.postgresql.org
Subject: Re: copy_file_range is now a Linux kernel call
In-Reply-To: <31122.1514951044@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox