pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Fujii Masao <masao.fujii@oss.nttdata.com>
To: pgsql-hackers@postgresql.org
Subject: max_slot_wal_keep_size and wal_keep_segments
Date: Tue, 30 Jun 2020 23:51:40 +0900
Message-ID: <574b4ea3-e0f9-b175-ead2-ebea7faea855@oss.nttdata.com> (raw)

Hi,

When I talked about max_slot_wal_keep_size as new feature in v13
at the conference, I received the question like "Why are the units of
setting values in max_slot_wal_keep_size and wal_keep_segments different?"
from audience. That difference looks confusing for users and
IMO it's better to use the same unit for them. Thought?

There seem to be several options to do this.

(1) Rename max_slot_wal_keep_size to max_slot_wal_keep_segments,
     and make users specify the number of WAL segments in it instead of
     WAL size.

(2) Rename wal_keep_segments to wal_keep_size, and make users specify
      the WAL size in it instead of the number of WAL segments.

(3) Don't rename the parameters, and allow users to specify not only
     the number of WAL segments but also the WAL size in wal_keep_segments.

Since we have been moving away from measuring in segments, e.g.,
max_wal_size, I don't think (1) is good idea.

For backward compatibility, (3) is better. But which needs more
(maybe a bit complicated) code in guc.c. Also the parameter names
are not consistent yet (i.e., _segments and _size).

So for now I like (2).

Thought?

Regards,

-- 
Fujii Masao
Advanced Computing Technology Center
Research and Development Headquarters
NTT DATA CORPORATION





view thread (24+ messages)  latest in thread

Message-ID: <574b4ea3-e0f9-b175-ead2-ebea7faea855@oss.nttdata.com>
Permalink:  ../574b4ea3-e0f9-b175-ead2-ebea7faea855@oss.nttdata.com/
Also on:    postgresql.org/message-id/574b4ea3-e0f9-b175-ead2-ebea7faea855@oss.nttdata.com

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: masao.fujii@oss.nttdata.com
  Subject: Re: max_slot_wal_keep_size and wal_keep_segments
  In-Reply-To: <574b4ea3-e0f9-b175-ead2-ebea7faea855@oss.nttdata.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox