Subject: postmaster crash

From: [email-masked] (Postgres Administrator)
Date: Tue, 17 Nov 92 22:04:46 -0800

we are using postgres v4.0 in multi-user mode, the number of machines get used at the same
time is 30 maximum.

we experience the following problems, any suggestions will be greatly appreciated.

Our setup is one backend, one postmaster run at a DEC 5000, ultrix 4.2A. Around 30 machines
are connected to the backend via postmaster, the interface being used is monitor as supplied.

1) the postmaster crashes at around every 20 mins.
2) if we run the postmaster at separate machine (machines), it generates a lot of error logs.

Our question is how to set postgres to support 30 different machines reliably.
-----------------------------------------------------------------------------

Thanks in advance.

---

From: <[email-masked]>
Date: Wed, 18 Nov 92 10:08:40 PST

In message <[email-masked]> you write:

> 2) if we run the postmaster at separate machine (machines), it generates a lo
  +t of error logs.
> Our question is how to set postgres to support 30 different machines reliably
  +.

can you be more specific about problems one and two?  you should start up
the postmaster with the -d flag to turn on debugging output.

to support 30 machines, you'll need (at least) to recompile postgres with
a much larger shared buffer pool than is the default.  you can change
NDBUFS in src/lib/H/tmp/miscadmin.h; this value should be ten times the
number of active connections you expect, for reasonable performance.

					mike