Subject: Error installing v3r1

From: <[email-masked]>
Date: Tue, 3 Dec 1991 09:50:55 -0600

Hello,

I ftp'ed the latest version of postgres v3r1 yesterday and tried to install
it on my Sun Sparc 1+. I keep getting the following error:

compiling lib/libpq/fe-pqufs.c
"/home/postgres/src/lib/H/tmp/libpq-fs.h", line 42: redeclaration of stat
*** Error code 1
make: Fatal error: Command failed for target `/home/postgres/obj.sparc/lib/libpq/fe-pqufs.o'

Then I get other related errors, then it dies.

I successfully got v3r0 to compile without this error, so I can't
figure out what I did wrong/differently.

Any Help would be greatly appreciated.

Randy Johnston

Randy Johnston             MN11-1610
Alliant Techsystems Inc.,  Research and Technology Center
600 2nd Street N.E.,  Hopkins, MN  55343
[email-masked]       (612) 931-6084

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 03 Dec 91 08:56:26 PST

you write:
> make: Fatal error: Command failed for target `/home/postgres/obj.sparc/lib/li
 +bpq/fe-pqufs.o'
> figure out what I did wrong/differently.

This can be worked around by removing the definition of the 'stat' structure
in src/lib/H/tmp/libpq-fs.h.  This file is new since the v3r0 release.

--
Case Larsen