Subject: problems compiling on sun3 under sunos 4.1

From: [email-masked]
Date: Sun, 29 Dec 91 07:29:21 -0800

I am having problems getting postgres to compile on a sun3 under sunos 4.1
I have tried the standard C comppiler and gcc both produce errors. The text
of trying to compile using the std sun C compiler for the first error is
included below. I assume i am doing somthing wrong but have no idea what. 
Up to this point the ./Make install worked fine with no errors.

linking headers
compiling plannodes.h
"plannodes.c", line 1039: syntax error at or near variable name "type"
"plannodes.c", line 1039: NodeTag declared as parameter to non-function
"plannodes.c", line 1039: type undefined
"plannodes.c", line 1039: outFunc undefined
"plannodes.c", line 1039: function returns illegal type
"plannodes.c", line 1039: redeclaration of IMakePlan
"plannodes.c", line 1039: redeclaration of cost
"plannodes.c", line 1039: redeclaration of plan_size
"plannodes.c", line 1039: redeclaration of plan_width
"plannodes.c", line 1039: redeclaration of fragment
"plannodes.c", line 1039: redeclaration of parallel
"plannodes.c", line 1039: redeclaration of state
"plannodes.c", line 1039: redeclaration of qptargetlist
"plannodes.c", line 1039: redeclaration of qpqual
"plannodes.c", line 1039: syntax error at or near symbol )
"plannodes.c", line 1040: illegal character: '#'
"plannodes.c", line 1052: syntax error at or near symbol {
"plannodes.c", line 1053: illegal initialization
"plannodes.c", line 1053: cannot recover from earlier errors: goodbye!

The other option is that postgres no longer works on sun3's 

Thanks for any help that someone can give. 

p.s. It was being compiled under the user postgres and the uid = 6

-larry

---

From: postarch (Postgres Mailing Archive)
Date: Fri, 03 Jan 92 10:10:23 PST

> Up to this point the ./Make install worked fine with no errors.

The standard C compiler should have worked.  In order to get postgres to
compile under gcc you have to specify -traditional.

> "plannodes.c", line 1039: outFunc undefined
...
> The other option is that postgres no longer works on sun3's 

Before the 3.1 release went out I installed and ran our entire battery of
tests on our local sun3.  Just to be sure I copied and installed the actual
released distribution yesterday and everything works fine here.  We are
running a much older version of the os, but I don't think that this would
account for the problems you are having.  My guess is that it is related 
to something peculiar about your site.

Jeff Meredith
[email-masked]