Subject: postquel data type

From: "Caroline M. Paxson" <[email-masked]>
Date: Tue, 08 Jun 1993 16:39:29 -0700

Hi,
The problem with the following:

  * create OBJECT (name = char16, source = postquel, object = postquel) \g

  Query sent to backend is "create OBJECT (name = char16, source = postquel, object = postquel) "
  WARN:Jun  8 11:43:36:parser: syntax error at or near "postquel"

is that the type "postquel" is not supported.  Take a look at the 
list of supported types in the Introduction(Built-ins) section of
the Postgres manual.  (I'm assuming you haven't defined your own 
type called postquel.)

I am currently working on implementing Postgres sets in a way which
will allow you to store queries as sets.  In the meantime, you might
try using functions, i.e. instead of having an attribute "source", define
a Postquel function called "source".

Carol Paxson
[email-masked]

---

From: <[email-masked]>
Date: Wed, 9 Jun 93 09:38:23 -0700

> is that the type "postquel" is not supported.

In addition, postquel is a reserved word, which is why you get the error
message you see rather than "type name lookup of postquel failed".  You
will have to use some other name for your type.

avi