Subject: SQL preprocessor

From: [email-masked] (Alvaro Monge)
Date: Mon, 10 May 93 14:44:39 -0700

I am looking for an SQL pre-processor written in C or C++.
This layer of software should be able to take an SQL command
in ascii/text and put it in an internal structure
representing an operator tree.  That is, a tree where the
internal nodes represent join/cross products/sort, etc the
leaves of the tree are the relations of the database with
some possible selections (i.e. where clauses involving that
relation only.)

Does anyone know where I can find the source code for this
layer of software.  I need it for the research that I am
doing.

Thanks,
Al

---

From: "David J. Hughes" <[email-masked]>
Date: Mon, 10 May 93 17:01:39 -0700

> layer of software.  I need it for the research that I am

If you found such a beast and enabled it to sit over Postgres you'd have
many new friends.  I'd love to hear of such an interface to Postgres as
many people who want to use my code use other DBMS's and would like to
stay with what they know.

I don't know of anything that matches exactly what you are after, but I
recall a while ago that an SQL shell was posted to the net (comp.sources.*
I think).  It allowed SQL queries to be used to access flat/binary files. 
It may give you some starting code.

-- time lapse --

After I quick hunt around on our archive box, the stuff is called

		shql - Interactively read and execute SQL commands
		comp.sources.misc
		volume 25

Hope this is of use.

bambi
   ___                                   David J. Hughes    [email-masked]
  /   \                /  /    /        
 /  __/ __   __   ____/  /    / __             Senior Network Programmer
/    \ /  \ /  \ /   /  /    / /  \  /       Comms Development & Operation
\____/ \__//   / \__/   \___/ /   / /    Qld. 4229  AUSTRALIA  (+61 75 951450)