Subject: PLEASE, PLEASE HELP ME

From: Wolf Guddat <[email-masked]>
Date: Wed, 21 Jul 93 21:39:29 MESZ

Hi Everybody,

The last weeks i tried to do postquel queries from
inside of user defined functions.
Someone of the postgressors (mao) told me to take a
look at an undocumented routine call "pg_eval_dest"
which allows me to postquel the backend. 
My problem is that i'm able to do some retrieves 
and get the returned information, but everytime i do
this  there are more and more open portals (not cleaned)
and this forces the backend to crash.

Has someone an idea about this problem/mistake.

If so please answer me. It is really really important for me

Thousand Thanks

Wolf

****************************************************
**                                                **
** Wolf Guddat, [email-masked] **
**                                                **
**     Postgres 4.1, DECstation, ULTRIX 4.3       **
**                                                **
****************************************************

---

From: Marc Teitelbaum <[email-masked]>
Date: Wed, 21 Jul 1993 15:20:44 -0700

The best we can say is that we intend to make PQexec work in the
backend and that it should be cleaned up for the next release.  I'll
start taking a look at it next week and would be happy to let you know
how it goes.  If you have examples where it fails please pass them along
as it might speed up the process.  At this point we can take the remainder 
of this dialogue offline with private email to spare the other people 
on the list.  Send mail directly to me ([email-masked]).