Subject: postgres question

From: Jorge Najenson <[email-masked]>
Date: Mon, 30 May 1994 10:15:25 +0300

Sender: [email-masked]

Hi,

I wonder if you have an idea to solve my problem...

after creating database:
  createdb test1

and running the following shell script:

#!/bin/csh
monitor -c 'create Persons(id=int4,name=char16,address=char16,byear=int2)' $1
monitor -c 'create Books(serial=int4,title=char16,section=char16)' $1
monitor -c 'create Authors(id=int4,title=char16)' $1
monitor -c 'retrieve into tmp (p.name,year=p.byear)\
                from p in Persons,a in Authors,b in Books\
                where p.id=a.id and\
                        a.title=b.title and b.section="AI"' $1
monitor -c 'retrieve into tmp2 (year=int2max{tmp.year})' $1

I get the message :

   WARN:Dec 19 21:47:12:ExecAgg: no initial value given and no valid tuples 
found

which is logical since tmp is empty,but when I try to use the database again 
for let say :

   monitor -c 'retrieve (pg_class.all)' test1

I get :

   WARN:Dec 19 21:49:42:OperatorObjectIdFillScanKeyEntry: unknown operator 609

and it repeat it self for every query I try on that database.

even stranger, I cannot destroy the database with
   destroydb test1

because it hangs the postmaster which I have to kill and run again to 
successfully destroy the database.

I will be glad to get a quick reply since we give here a DataBase course and 
exercises will be given on the postgres system.

p.s. please add me to your mailing list.

Ori.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Sternberg Ori,
C.S. System Group, Hebrew University,
Jerusalem 91904, ISRAEL.
[email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

------- End of Forwarded Message

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Mon, 30 May 94 02:40:14 -0700

>    WARN:Dec 19 21:49:42:OperatorObjectIdFillScanKeyEntry: unknown operator 609

dunno.  i just tried it on 4.2 and didn't get the second message.

(are you really seeing "Dec 19" on queries you're running right now?)

> p.s. please add me to your mailing list.

you're on it.  my last set of bounce messages contain:

451 [email-masked],[email-masked]... reply: read error from pnlg.pnl
.gov.

(which makes me wonder why i'm bothering to mail this.. well, maybe
it's a transient error..)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki