Subject: Regression test failure on alpha+OSF/1 2.0 (inversion filesystem)

From: Aaron Roydhouse <[email-masked]>
Date: Thu, 28 Jul 1994 13:07:29 +1200

I've previously been using Postgres 4.2beta under SUNOS 4.1.3

Today I built 4.2(non-beta) on an alpha under OSF/1 2.0 as per the
install instructions (tar xvfp included). Everything built sweetly,
but unfortunately the regression testing doesn't go through.

Has anyone seen this mode of failure before?

[...]
#
# - relative pmkdir
#
pmkdir relative_dir \
        || exit 1
#
# - relative prmdir
#
prmdir relative_dir \
        || exit 1
p_rmdir: p_errno=1, relative_dir: Error 0

Is there something about alpha installations I forgot to do?
Can't spot anything in the installation guide.

It got so close, I'd like to witness it go all the way, just once :-)

Aaron.

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 28 Jul 94 18:54:21 -0700

> p_rmdir: p_errno=1, relative_dir: Error 0

i've seen this before but i don't remember the circumstances.  (when
you're trying to test on osf/1 1.3, osf/1 2.0, hpux 9.00, hpux 9.03,
aix 3.2.5, solaris 2.3, sunos 4.1.3_u1, ultrix 4.2a, ultrix 4.3a, and
ultrix 4.4, the details start to blur.)  i know it must have passed on
osf/1 2.0 at least once.. :-/
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776