Subject: bug?

From: [email-masked] (Postgres)
Date: Mon, 14 Dec 92 16:15:37 -0800

I seem to be having problems with attribute names that are 16 characters
long.

Here is a short monitor session:

	Welcome to the C POSTGRES terminal monitor
	
	Go
	* create a (abcdefghijklmnop = int4)\g
	
	Query sent to backend is "create a (abcdefghijklmnop = int4)"
	CREATE
	Go
	* retrieve (a.all)\g
	
	Query sent to backend is "retrieve (a.all)"
	Error: Unexpected identfier in dump_data:

At this point I am kicked out to the shell.  Does anyone else have this
problem?

I am running this on a Sun 4/490 with SunOS 4.1.1, and Postgres 4.0.1
(compiled with the 'sparc' config)

Dean Huxley ([email-masked])

---

From: <[email-masked]>
Date: Mon, 14 Dec 92 16:21:19 PST

> I seem to be having problems with attribute names that are 16 characters

this is a known bug in the system; the max length limit is 16 for
storage, but lots of internal routines assume they're passed a
null-terminated string (not true if all sixteen chars are present).
for the time being, you should limit names in postgres to fifteen
chars.
					mike