Subject: Obtaining oid's

From: R Michael McMahon <[email-masked]>
Date: Wed, 20 May 92 02:29:59 -0700

Is there a way to determine the oid which results from a 
(single) "append" command? Having spent some time looking
though the source, I still don't see where and how the oid
is assigned. For use in a persistent C++ environment, it 
is important to know about these things !

Mike McMahon       [email-masked]

---

From: postarch (Postgres Mailing Archive)
Date: Wed, 20 May 92 09:35:07 PDT

you write:

> (single) "append" command?

not in the currently-released system.  version 4 (our pending release)
will return the oid to the caller for single-tuple appends.  until then,
the only thing you can do is

	retrieve (foo.oid) where <some qual that uniquely identifies the
				  new tuple>

					mike olson
					postgres research group
					uc berkeley
					[email-masked]