Subject: postgress and kerberos

From: [email-masked] (Stephen Miano)
Date: Fri, 30 Apr 93 16:18:12 EDT

I am using postgress 4.1 on a sunos running 4.1.3.
The version of kerberos that I am using is 4.

When I start postmaster with the option
	postmaster -a kerberos

I get the error
	be_setauthsvc: invalid name kerberos, ignoring...

The kerberos log file does not record and connection by postgres.

If anyone has any information on kerberos working with postgress
please let me know

Thanks
-- 
-----------------------------------------------------------------------
Stephen Miano                   |  Mail:  [email-masked]
Enterprise Systems Management   |  UUCP:
49 Rockledge Road               | Phone:  (212) 449-8945
Bronxville, NY 10708            |   Fax:  (212) 449-2508

---

From: [email-masked] (Paul M. Aoki)
Date: Fri, 30 Apr 93 15:48:34 -0700

> 	be_setauthsvc: invalid name kerberos, ignoring...

you have to build (recompile) postgres with the kerberos libraries and 
the right src/Makefile.global settings.  (see introduction(unix), aka 
"Section 2", in the postgres 4.1 reference manual for additional info.)

postgres is shipped *without* kerberos compiled-in because:
	1. when it is compiled-in, postgres defaults to using kerberos,
	which is definitely not what *everyone* wants..
	2. it would make postgres subject to the same US export
	restrictions to which kerberos is subject.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki