Subject: Does "built-in type" uint4 exist?

From: Dave Pinkney <[email-masked]>
Date: Wed, 22 Sep 1993 10:14:43 -0400 (EDT)

Is the postgres built-in type uint4 (4 byte unsigned long) supported
 yet?  I get an error from the backend when I try to use it as a base
 type.  
 
 Thanks,
 
 Dave Pinkney
 [email-masked]

 Transcript of session:
 
 Welcome to the C POSTGRES terminal monitor
 
 Go 
 * create test_class(name = text, age = uint4) \g
 
 Query sent to backend is "create test_class(name = text, age = uint4) "
 WARN:Sep 18 18:10:55:type name lookup of uint4 failed
 
 Go 
 * create test_class(name = text, age = uint2) \g
 
 Query sent to backend is "create test_class(name = text, age = uint2) "
 WARN:Sep 18 18:11:06:type name lookup of uint2 failed
 
 Go 
 * create test_class(name = text, age = int4) \g
 
 Query sent to backend is "create test_class(name = text, age = int4) "
 CREATE
 Go 
 * \q
 I live to serve you.

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 22 Sep 93 10:09:50 -0700

Dave Pinkney <[email-masked]> writes:
>  Is the postgres built-in type uint4 (4 byte unsigned long) supported yet?

no.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki