Subject: better programming interface ?

From: [email-masked] (Niranjan Perera)
Date: Wed, 20 Oct 93 12:39:08 EDT

Hi,

I have been using postgres for around 7 months now. I was wondering if anybody has considered
implementing an object oriented  programming interface to postgres. Something  along the lines  of
E, and O2 database programming languages, but which will interface into the backend.

The current libpq interface is nice, but a lot of work needs to be done by the programmer if
one wants to access any of the data.

Kindly direct comments, and suggestions to [email-masked],  and I shall post a summary.

peace,

-- Niranjan

---

From: "David J. Hughes" <[email-masked]>
Date: Thu, 21 Oct 1993 08:14:57 +1000 (EST)

> one wants to access any of the data.

I put together a simple interface (not OO, sorry) for work I'm doing 
under Postgres.  You pass it queries and it returns linked lists of the 
data found.  All the data is returned to the application in the one call 
rather than cycling through it, element by element, with fetch.

That code is included in the relshow package available from :-

	Hostname : kirk.Bond.edu.au
	IP Addr	 : 131.244.1.1
	Path	 : /pub/Bond_Uni/relshow

It's simple and clean and easy to use.  It may help you out.
I have also written a perl package that offers the same interface to 
pgperl users although that's not in the relshow distribution.  (mail me 
if you're interested).

   ___                                  David J. Hughes    [email-masked]
  /   \                /  /    /        
 /  __/ __   __   ____/  /    / __            Senior Network Programmer
/    \ /  \ /  \ /   /  /    / /  \  /     Information Technology Services
\____/ \__//   / \__/   \___/ /   / /   Qld. 4229  AUSTRALIA  (+61 75 951450)