Subject: Unexpected identifier in process_portal

From: R Michael McMahon <[email-masked]>
Date: Tue, 9 Jun 92 12:49:51 -0700

I had email'd a while back about "Unexpected identifier in process_portal" message.
Although this happens in a weird variety of circumstance, I have isolated a simple
test case. Try the following:

create Parent(name=text,long=int4)\g
create Child (short=int2) inherits (Parent) \g
append Child (name="generic",long=666,short=1)\g
replace Child (name="generic",long=667,short=1) where Child.long=666\g

The "replace" command is greeted by: 
   	Error: No response from the backend, exiting...
Upon restarting the monitor, the same "replace" command now gives:
	Error: Unexpected identifier in process_portal:

Oddly, a small change to Parent can solve this problem:
create Parent(long=int4,name=text)\g

I no longer get the error using the same commands from above and the "new" Parent
class. I can send the debugging query plans if you need it, but I hope this is 
enough to repeat the error. BTW, I'm using Sun4 hardware @ SunOS 4.1.0

[email-masked]     R Michael McMahon

---

From: postarch (Postgres Mailing Archive)
Date: Wed, 10 Jun 92 15:00:31 PDT

you write:

> I had email'd a while back about "Unexpected identifier in process_portal" me
 +ssage.
> Although this happens in a weird variety of circumstance, I have isolated a s
 +imple
> create Parent(long=int4,name=text)\g

I thought we had fixed all of these bad alignment bugs, what version of
postgres are you currently running?  I tried both on my 5000 (Ultrix 4.2a)
and my sparc (SunOs 4.1.2) and couldn't reproduce the bug.

Is there a core dump in the $POSTGRESHOME/data/base/dbname directory? If
so can you send a stack trace?

Jeff Meredith
[email-masked]