Subject: deferred trigger

From: [email-masked] (Michael Gertz)
Date: Tue, 7 Apr 92 10:32:02 -0700

I want to model deferred triggers by the use of the PRS2 rule system.
Therefore I need a mechanism that some rules are activated during
a transaction until the command  *end transaction* and then to
activate further rules which also refer to operations done
during the transaction.

Does anybody have any experience with deferred trigger (rules)
in POSTGRES? Are there any investigations to support
such rules?

Thanks for any help and comments!

Michael Gertz
Institut fuer Informatik
3000 Hannover 1, Germany
[email-masked]

---

From: postarch (Postgres Mailing Archive)
Date: Fri, 10 Apr 92 13:18:23 PDT

> in POSTGRES? Are there any investigations to support

I got the following from Spyros (the ex-OFFICIAL POSTGRES RULES EXPERT)...

  Well, in principle it is possible, all you have to do is look at
  ... [ Spryos' PhD thesis ] ...

  Somewhere in the last chapter I describe how the already existing system
  *with minor extensions* can be used to provide deferred triggers.
  The keyword here is *minor extensions*, which means
  
      a) the postgres code HAS to be changed
      b) I *hope* that the changes wouldn't be too many & difficult
         (just the usual 3 lines of code...)
  
  So, the answer is no, you can not use the current postgres rule system for
  deferred triggers. Pitty!... :-(

  -sp

Jeff Meredith
[email-masked]