Subject: double quotes in postgres string

From: [email-masked] (Bernd Froehlich)
Date: Thu, 1 Sep 94 14:03:30 +0200

How do I put double quotes in a postgres string?
I tried to precede them with a backslash but that did not work:
* create test(a=char16)\g

Query sent to backend is "create test(a=char16)"
CREATE
Go 
* append test(a="\"")\g
unknown escape given

Go 
* 
Query sent to backend is "append test(a="")"
APPEND 48924
Go 

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 01 Sep 94 08:44:31 -0700

> I tried to precede them with a backslash but that did not work:

the monitor uses backslash as its escape character.  use two:
 * append test(a="\\"hello world\\"")\g
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776