Subject: probs with pre-installed pg 4.1

From: [email-masked] (Alfredo Sanchez)
Date: Wed, 26 May 93 20:51:15 -0700

Hello,

We just decided  to upgrade to postgres 4.1.
I was trying to skip the process of building the system 
and I opted for the pre-installed system for sparcs.

When I get to the regression tests, one problem seems to
be serious:

2440,2442c2440,2441
< NOTICE:Mar 11 20:17:14:Non-functional update, only first update is performed
< NOTICE:Mar 11 20:17:16:Non-functional update, only first update is performed
< REPLACE
---
> WARN:May 26 21:43:17:Load of file /home2/postgres/src/regress/regress/obj/../obj/regress.o failed: link failed!
> 

Still, I tried creating a database and using monitor and that
seems to work fine. However, when I try to cretate another user,
I get:

/usr/postgres/bin/createuser: postgres cannot create users.

Any help you can provide will be greatly appreciated.

J Alfredo Sanchez H
-------------------
Hypermedia Research Lab
Texas A&M University

---

From: [email-masked]
Date: Thu, 27 May 93 08:50:13 EDT

>Any help you can provide will be greatly appreciated.

I had the same problem. My solution was to re-install the pre-installed
postgres and NOT RUN the regress test. After, postgres worked fine.

                             Cheers,
                             Andrew Francis