Subject: Problem with retrieving data

From: [email-masked]
Date: Wed, 22 Apr 92 06:32:07 -0700

Dear Postgres-Group,

I installed the folloeing relations in postgres :

create AT_status (
	wversion            = text,
	wauthor             = text,
	wtool               = text,
	wdata_origin        = text) \g
create AT_time_stamp (
	wyear               = int4,
	wmonth              = int4,
	wday                = int4,
	whour               = int4,
	wminute             = int4,
	wsecond             = int4) \g
create AT_property (
	wname               = text,
	wprop_type          = text,
	wstringValue        = text,
	wbooleanValue       = int4,
	wintegerValue       = int4,
	wrealValue          = float8) \g
create E_lib (
	wname               = text,
	wproperties         = text,
	wcontains_cell      = oid[])\g
create E_cell (
	wname               = text,
	wviewname           = text,
	wcell_status        = text,
	wcell_list          = int4,
	wbb_lower_left_x    = float8,
	wbb_lower_left_y    = float8,
	wWZS_SHORT0         = float8,
	wWZS_SHORT1         = float8,
	witem_counter       = int4,
	wsim_model          = text,
	wproperties         = text,
	wtime               = text,
	wcontains_net       = oid[],
	wcontains_port      = oid[],
	wcontains_inst      = oid[])\g
create E_inst (
	wname               = text,
	wtest_result        = text,
	wtransform_1_1      = float8,
	wtransform_1_2      = float8,
	wtransform_1_3      = float8,
	wtransform_2_1      = float8,
	wtransform_2_2      = float8,
	wtransform_2_3      = float8,
	wbb_lower_left_x    = float8,
	wbb_lower_left_y    = float8,
	wWZS_SHORT0         = float8,
	wWZS_SHORT1         = float8,
	wproperties         = text,
	wrefers_to_cell     = oid[],
	wWZS_SHORT2         = oid[])\g
create E_net (
	wname               = text,
	wproperties         = text,
	wWZS_SHORT3         = oid[],
	wconnected_port     = oid[])\g
create E_port (
	wname               = text,
	wp_function         = int4,
	wbs_function        = int4,
	wca_lower_left_x    = float8,
	wca_lower_left_y    = float8,
	wWZS_SHORT4         = float8,
	wWZS_SHORT5         = float8,
	wload               = int4,
	wproperties         = text)\g
create E_port_inst (
	wname               = text,
	wp_function         = int4,
	wproperties         = text)\g

Due to the reason of 16 chracters per row, we generate the names wWZS_SHORTxxx.
The creation terminates without any error message.

Retriving data out of some of the tables (E_inst and E_cell) produce the 
following error :

* retrieve (E_cell.all)\g

Query sent to backend is "retrieve (E_cell.all)"
Error: Unexpected identfier in dump_data: w

After this message the monitor terminates. So, what is wrong in the 
table definitions?

Kind regards,

Uwe Jasnoch

+-----------------+-----------------------+-------------------------------+
|                 |                       |                               |
|  U   U   JJJJJ  | Uwe Jasnoch           |  E-Mail : [email-masked]  |
|  U   U       J  | Fraunhofer Institute  |                               |
|  U   U       J  | for Computer Graphics |  Telefon: +49 6151 155 257    |
|  U   U   J   J  |                       |  Telefax: +49 6151 155 299    |
|  UUUUU    JJJJ  | Wilhelminenstr. 7     |                               |
|                 | 6100 Darmstadt        |                               |
+-----------------+-----------------------+-------------------------------+

---

From: postarch (Postgres Mailing Archive)
Date: Thu, 30 Apr 92 00:16:50 PDT

> I installed the folloeing relations in postgres :

...

> Due to the reason of 16 chracters per row, we generate the names wWZS_SHORTxxx

There appears to be a bug with attribute names that are 16 characters long
(in E_cell wbb_lower_left_x and wbb_lower_left_y).

If you shorten those that are 16 to be 15 then the retrieves work.

Jeff Meredith
[email-masked]