Subject: Re: version 4.2 ..?

From: [email-masked] (J.Plewe)
Date: Fri, 1 Jul 94 11:20:15 +0200

> 
> Does any body have a stable version 4.2 running on sun 4.1.3 ??
> 
> I have installed 4.2-beta version , but it didn't even pass its
> own regression tests .. quite a few times I got the error flags
> from the backend & PQexec .. 
> 
> The following is the error I got while doing :
> 
> >  System:  sun os 4.1.3  / postgres 4.2.beta
> >
> > * retrieve (ntable.all) \g
> >
> > Query sent to backend is "retrieve (ntable.all) "
> > FATAL: no response from backend: detected in PQexec
> 

I have it running, but not completely stable at all. I very often
get messages like

  FATAL 1:Jul  1 07:57:17:database template1 does not exist, bailing out...

with any database name (e.g. regression, plewe, ...)

I'm of course sure thta the databases actually exist. I get the 
message from one query to the next.

Restarting the postmaster removes the error.

At home I build postgres for Linux from the same sources with the patches
from Kai Petzke and I don't see this error!

- Joerg

*********************************************************************
Dipl. Phys. Joerg Plewe               [email-masked]
MPI fuer molekulare Physiologie
Rheinlanddamm 201
44139 Dortmund
Germany                               +49 (0)231 1206 384
*********************************************************************

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Fri, 01 Jul 94 07:36:52 -0700

> message from one query to the next.

for some reason, i observe this fairly often whenever i lose my mind
and put a database on an NFS volume.  this may be your problem, or it
may not.  (in any case, don't do that, ever.)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720-1776      |  ...!uunet!ucbvax!aoki

---

From: [email-masked]
Date: Mon, 11 Jul 94 11:43:23 N

Hello Joerg,

> message from one query to the next.

We had the same problem , although we were working with local
databases. (The possibility Paul Aoki mentioned)
One reason was the use of a tcsh.The shell changed at the
runtime the PGDATA-value.(incredible, but true)
We coped with the problem by using the normal csh. Until now is the
system running.
We had seen the mistake by running postmaster with the debug-option.
I hope this will help you. 

> from Kai Petzke and I don't see this error!

-         Marcus