Subject: Help with Linux

From: [email-masked] (Chris Curtis)
Date: Tue, 26 Apr 1994 12:51:24 -0600 (MDT)

I'm trying to get v4.2 compiled under Linux.  I finally got the patch
from marie.physik.tu-berlin.de (after many timeouts) and applied it, but 
it hangs on ylib.c: conflicting definitions in acl.h and builtins.h.

Anyone know what to do with this?

===============================================================================
    To add/remove yourself from the POSTGRES mailing list: send mail with 
    the subject line ADD or DEL to "[email-masked]"

    If this fails, send mail to "[email-masked]" and
    a human will deal with it.  DO NOT post to the "postgres" mailing list.
===============================================================================

---

From: [email-masked] (Kai Petzke)
Date: Wed, 27 Apr 1994 00:41:49 +0200 (MET DST)

> it hangs on ylib.c: conflicting definitions in acl.h and builtins.h.

Sorry for the timeouts.  I did not want to put Postgres on tsx-11
or Sunsite (and thus distribute it to everywhere), before Berkeley
has officially announced it themselves.

> Anyone know what to do with this?

This is a small problem, I have build into it.  Unfortunateley.

I have posted a fix to this mailing list on Apr. 7, but here it
is again:

Kai

--- src/backend/utils/builtins.h.old    Sat Apr  2 00:44:09 1994
+++ src/backend/utils/builtins.h        Thu Apr  7 12:03:52 1994
@@ -612,11 +612,16 @@
 extern void to_basename ARGS((char *fname, char *bname, char *tname));

 /* acl.c */
-/* public interfaces only -- these are fake, the real ones are in tmp/acl.h */
+/*
+ * public interfaces only -- these are fake, the real ones are in tmp/acl.h.
+ * Don't  define these here, if tmp/acl.h has already been included!
+ */
+#ifndef AclHIncluded
 extern struct varlena *aclitemin ARGS((char *s));
 extern char *aclitemout ARGS((struct varlena *s));
 extern struct varlena *aclinsert ARGS((struct varlena *acl, char *aclitem));
 extern struct varlena *aclremove ARGS((struct varlena *acl, char *aclitem));
 extern int aclcontains ARGS((struct varlena *acl, char *aclitem));
+#endif

 #endif !BuiltinsIncluded