Subject: No Effect on defining Indices

From: [email-masked] (Michael Ehrmantraut)
Date: Wed, 11 Jan 95 10:00:34 MEZ

Hello everyone,

I hope there is someone that can help me.
I have installed Postgres 4.2 on AIX. It works well since two or
three month. But now, I get some problems on defining Indices.

When I do this with the command "define index ... using btree ..."
on a normal attribut (int4) by using the default operators "int4_ops"  
I am getting no effect. POSTGRES gives me no errors, but when I 
start a "retrieve"-command the result is not ordered.

When executing the example "chapter13" in ".../src/examples" all works
well, but the last output is not o.k. The operator <<& works well and
don't print the line with "number=-10000". But the output is not ordered.

Are there any hints in the manual I didn't see ?
Did I make a basic mistake ?
Doesn't Version 4.2 support indices anymore ?

Please help me

	Michael Ehrmantraut
	[email-masked]

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 11 Jan 95 07:16:20 -0800

> don't print the line with "number=-10000". But the output is not ordered.

there's this footnote somewhere on that page or the previous page of
the user manual that discusses the cost-based optimizer and why the
actual result may not really look like the example..
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776