Subject: regression test failed

From: "David Alan Nelson" <[email-masked]>
Date: Thu, 7 Apr 1994 14:40:27 +0100 (BST)

> Hi, I got an error in the regression test of postgres v4r1 on
> ss10+4.1.3. Is that bad news?
> 
> Query sent to backend is "replace temp (stringu1 = reverse_c16(o.stringu1))     from o in onek     where o.stringu1 = "JBAAAA" and 	  o.stringu1 = temp.stringu1 "
> WARN:Feb 21 12:04:28:Load of file /sd2g/prj/postgres/src/regress/regress/obj/../obj/regress.o failed: link failed!
> --
> Tatsuo Ishii
> SRA, Inc.
> 
So did I.  Anybody care to explain why this happens.

Dave

-- 

Mail ID : [email-masked]

Computing Science, University of Newcastle upon Tyne, UK.  (091) 222 8789

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 07 Apr 94 10:33:56 -0700

"David Alan Nelson" <[email-masked]> writes:
> > Query sent to backend is "replace temp (stringu1 = reverse_c16(o.stringu1))
     from o in onek     where o.stringu1 = "JBAAAA" and 	  o.stringu1 = 
temp.stringu1 "
> So did I.  Anybody care to explain why this happens.

this can happen for any number of reasons, generally having to
do with your environment.  one is running out of link space in 
/tmp.  the more common one is broken file permissions (the 
postgres user must be able to access that file, meaning you 
should be able to "su postgres" (or whoever the postmaster is 
running as), cd to that directory and (e.g.) "cat" the .o file.

the former problem cannot occur in postgres 4.2 because we no 
longer use "ld -A" style dynamic linking.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki