Subject: rules

From: ilya lybovich <[email-masked]>
Date: Wed, 31 Mar 93 13:19:50 -0800

I'm using postgres 4.0.1 
and have a problem with rule definition : 
*****************************

define rewrite arule  is  
   on append to office 
   do replace office ( total_dolar = office.priceuni_dolar * new.quantity )

********************************

on append this cause to postmaster failure : "can't vfork" and the backend has 
a huge size 

any idea ? 
Thanks , ilya Liubovich 
Hebrew Unversity , Jerusalem 
[email-masked]

P.S. 
the class office has more atributes , than presented in the rule

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 31 Mar 1993 14:02:28 -0800

> and have a problem with rule definition : 

To put it politely, there are some problems with the rewrite rule system.
Carole Goble has also provided us with a rewrite rule that blows up in a 
really evil way (it eats all of the core on my ds5000, preventing any new 
processes from starting, then dumps a 70+mb core when it finally asks
for more and malloc fails..).  For whatever it's worth, it is also of the 
form "on <update> do <update>".

This is definitely on the FIXME list.  More examples are always helpful,
though.  Thanks.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 31 Mar 1993 14:02:28 -0800