Subject: Dynamic Loading

From: [email-masked]
Date: Thu, 14 Oct 93 15:09:50 +0100

Hello !

We've a problem.
When we start the POSTGRES monitor and we want to use (dynamic-)load,
something is going wrong.

See beneath :

================================================
*  load "/usr/local/geo/dynamic/RastShape.o" \g

Query sent to backend is "load "/usr/local/geo/dynamic/RastShape.o" "
WARN:Oct 14 14:03:58:Load of file /usr/local/geo/dynamic/RastShape.o failed: link failed!

Go
*
================================================

Someone can help us ?

Thanks, Guido Witmond & Eric de Jonge

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 14 Oct 93 10:42:55 -0700

> WARN:Oct 14 14:03:58:Load of file /usr/local/geo/dynamic/RastShape.o failed: 
link failed!

most common causes of error:

1. unix protections that do not allow user "postgres" to access something
(either on the .o or some directory above)

2. on ultrix, forgetting to use the "-G 0" flag
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki