Subject: Is there a ``quality'' FreeBSD 1.1.5.1 port?

From: Robert Withrow <[email-masked]>
Date: Fri, 26 Aug 1994 09:32:31 -0400

Is there a ``quality'' port of ``current'' postgres to FreeBSD
1.1.5.1?  For the purposes of this query, ``quality'' means that such
a port would perform all of the functions of and run no worse nor
crash more often than the ``supported'' postgres ports.

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: Thomas Krebs <[email-masked]>
Date: Fri, 26 Aug 94 16:44:13 MESZ

> crash more often than the ``supported'' postgres ports.
The port of Clarence Chu is rather stable, that means "nearly" as the supported
ports. There is only one problem I saw, that seems to deal with the changes
Kai Petzke did initially for the Linux port. It has to do with the changes,
that where neccessary for getting the postquel-parser compiled with flex rather
than the supported lex.
That problem lets the regression test crash somewhere while scanning(?)
a "~" sign, as far as I could see.

Thomas

--
Thomas Krebs
Department for Manufacturing Automation and Production Systems FAPS
University of Erlangen
[email-masked]

---

From: [email-masked]
Date: Sun, 28 Aug 1994 21:51:59 -0400 (EDT)

I am developing an application which needs to:

1.)  connect to a database under the control of the postmaster running
on the same machine,
2.)  disconnect from that database,
3.)  connect to a database under the control of a postmaster running on
a different machine.

The way I attempted to accomplish this behavior was to use putenv() to
change the PGHOST and PGPORT environment variables.  

The problem is that  Postgres appears to ignore the environment
variables once PQhost and PQport are set and neither PQfinish() nor
PQsetdb() (which calls PQreset()) seem to clear these variables.

Any suggestions?

Robert

---

From: [email-masked]
Date: Sun, 28 Aug 1994 21:51:59 -0400 (EDT)

Any suggestions?

Robert