Subject: One letter operators names ?

From: Wojtek Bogusz <[email-masked]>
Date: Thu, 27 Oct 1994 00:47:26 +0100 (MET)

Dear friends in postgres,

 Could some one enlighten me why it is impossible to define operator 
with name > or < or =  ... ?

 Wojtek Bogusz

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 26 Oct 94 17:31:25 -0700

> with name > or < or = ... ?

it isn't impossible.  but you do have to make sure that there isn't
already a <, >, =, ... operator for the types in question (you can
only define one operator with a given name and type signature).
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776