Subject: confusion with copy command

From: John Peter Lee <[email-masked]>
Date: Thu, 10 Jun 1993 15:03:22 -0400 (EDT)

Hi -

	I would like to store an ASCII data file as a Postgres
	database, and would like to use the copy command from
	libpq. I am having trouble understanding the manual.

	I want to copy from an external datafile into a postgres class.
	Is this the proper command:

	copy pg_classname from file.ascii

	- does the 'to' and 'from' arguments apply to the class, or file ?

	Secondly, I do not understand what the format description means
	at the bottom of the man page. Does it apply to all files, or
	only to binary files ??? What does totalength refer to  - the
	number of uint32's in the instance ?

	thanks.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
JP Lee                 Institute for Visualization and Perception Research	
[email-masked]                  University of Massachusetts at Lowell 
(508) 934-3384				1 University Ave. Lowell, MA 01854

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: <[email-masked]>
Date: Thu, 10 Jun 93 12:43:29 -0700

>	copy pg_classname from file.ascii

yes it is.
>	- does the 'to' and 'from' arguments apply to the class, or file ?
it applies to the file

>	only to binary files ??? 
Only to binary files.

>	What does totalength refer to  - the
The total length of the data following it -- includes the length of the null description
and the <data> field.