Subject: Bug: Append with single array value

From: [email-masked] (Steve Davidson)
Date: Fri, 18 Jun 93 09:08:54 -0700

Dear Postgressors,

An append with a single array value fails where multiple values
succeed.  It looks like a bug in the parser.  Here's the code:

In all cases the Query is:
retrieve (e.all) from e in TEST

create TEST (numbers=int4[], strings=text[])
append TEST (numbers="{1, 2, 3, 4}", strings="{aaa, bbb}")
---works
 {1,2,3,4}    {"aaa","bbb"}

append TEST (numbers="{1, 2, 3, 4}", strings="{aaa,}")
---also works but produces
 {1,2,3,4}    {"aaa",""} 

---note the "" (null)

append TEST (numbers="{1, 2, 3, 4}", strings="{aaa}")
---FAILS, output is:
 {1,2,3,4}    {}

---note the "aaa" value was not appended

It looks like a bug.  

              --------======= * =======--------
                       Steven Davidson
                       [email-masked]

---

From: <[email-masked]>
Date: Fri, 18 Jun 93 11:40:14 -0700

This is a known bug. The next postgre release will have a fix for it.