Subject: Resending my query and problem with correction

From: [email-masked]
Date: Thu, 27 Jan 1994 23:25:28 -0600 (CST)

From:	CHARLI::SRIRAMK      27-JAN-1994 22:32:44.12
To:	SMTP%"[email-masked]"
CC:	SRIRAMK
Subj:	Clarification reqd

I am using postgres for my thesis project.

I created a user defined type as follows :

   define type lines (internallength = variable, 
                     input          = array_in , 
		     output         = array_out, 
 		     element        = text);

I then used this user defined type for class creation :

   create BLOCK (id = int4, content = lines);

Now when I try to append to class BLOCK as in :

   append BLOCK (id = 5 , content = "This is a test");

I get the  following error message

 array_in: malformed array constant

I will very much appreciate a clarification to the above problem and help
in understanding what I am doing wrong.

Thanks

Sriram Kal

---

From: Sunita Sarawagi <[email-masked]>
Date: Fri, 28 Jan 1994 10:08:38 -0800

>  array_in: malformed array constant

All array constants need to be enclosed within curly braces. So the
right syntax for your input will be ..

append BLOCK (id = 5 , content = "{"This is a test"}");

For storing multiple lines you need to seperate the elements by a comma.
Example: 
	append BLOCK (content = "{"This is a test", "This is another test"}")

Sunita Sarawagi.