Subject: Defining operators

From: [email-masked] (super dave?)
Date: Thu, 2 Sep 1993 15:16:09 -0500 (EDT)

I am trying to retrieve all the records from a class by doing a comparison,
but postgres doesn't allow an equality comparison on text attributes. The
manual says to define an operator, but is not very clear. Any help would be
appreciated, especially if accompanied by an example.

---

From: [email-masked] (Paul M. Aoki)
Date: Tue, 07 Sep 93 00:05:30 -0700

[email-masked] (super dave?) writes:
> but postgres doesn't allow an equality comparison on text attributes.

sure it does.

if a particular query doesn't work, send mail to post_questions@postgres.
it's probably just a type-casting problem.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki