Subject: libq via adt-function

From: Wolf Guddat <[email-masked]>
Date: Thu, 1 Jul 93 16:15:24 MESZ

Hi everybody,

is there anyone who has attempted to use libpq inside of
his dynamically loaded functions.
I can't find a hint on that in the manuals, all examples
access it from outside of postgres.

Resources: Ultrix4.3, DECstation, PG 4.1

I'm able to compile and link without errors.
Loading via monitor is OK.
But then, calling my function, the monitor stops with:
"unexpected identifier in process portal" (seems to occur
before my first line of code is reached = means at point
of invocation)
Am i doing some mistakes in my cc/ld-commands listed below
I think they are OK.

cc -G 0 $INC1 -c connect.c 
ld -L/usr/kits/postgres/lib -lpq -r -A connect.o -o connect

Even for small hints i would be very happy.

Bye Wolf

*****************************************************
**                                                 **
*  Wolf Guddat, [email-masked]  **
**                                                 **
*****************************************************

---

From: Mike Olson <[email-masked]>
Date: Thu, 01 Jul 1993 10:16:54 -0700

> access it from outside of postgres.

this won't work; the libpq interface is supported for client processes
only, and not for code dynamically loaded into the backend.

					mike