Subject: Re: < ``arrays of arrays'' >

From: mick <[email-masked]>
Date: Fri, 22 Jan 93 01:21:31 -0800

Could someone explain which versions
have the array code bug ?
I re ran the original query on ver 4.0
and got the following .

* create bla (name=char16, telno=text[])  \g

append bla (name="Hans", telno = "{ "110", "112" }") \g
append bla (name="Anna", telno = "{ "1164", "" }"  ) \g
append bla (name="Karl", telno = "{ "1171",  }"    ) \g
append bla (name="Susi", telno = "{ "1191" }"      ) \g
CREATE
* APPEND 35951
* APPEND 35952
* APPEND 35953
* APPEND 35954
* retrieve (bla.all, bla.telno[1]) \g
-------------------------------------------
| name        | telno       | telno       |
-------------------------------------------
| Hans        | {"110","112"}| 110         |
-------------------------------------------
| Anna        | {"1164",""} | 1164        |
-------------------------------------------
| Karl        | {"1171",""} | 1171        |
-------------------------------------------
| Susi        | {"1191"}    | 1191        |
-------------------------------------------

Mick Ridley                    Dept of Computing
                               Phoenix Bldg
[email-masked]      Univ of Bradford
                               Bradford BD7 1DP
0274 383946                    UK

---

From: [email-masked]
Date: Fri, 22 Jan 93 23:28:55 -0800

> I re ran the original query on ver 4.0

Looking back at the RCS log and the date of the 4.0.1 tar file, it 
looks like only 4.0.1 has that particular bug after all.  Sorry to
scare people running old versions.  However, the broken return 
statement (in adt/arrayfunc.c:array_count) has a comment that *it* 
is a fix for a bug in handling *zero*-length arrays, so ...

(BTW, the re-mailing of my last message was due to sendmail reprocessing
some enqueued messages on reboot, not my forgetful nature ..)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki