Subject: Bug in Character Array Type

From: [email-masked] (Postgres Account)
Date: Tue, 18 Feb 92 03:29:17 -0800

When a tuple, which has a field value starting with the character '{', is
appended to a relation, an error message "Unterminated array..." appears.
This kind of value can't be appended in database.

Is that right? Thanks.

--Shengsong Ni

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 18 Feb 92 12:04:42 PST

> This kind of value can't be appended in database.

You have to escape it:

	create bar ( a = char16, b = char[], d = text )
        \g
	append bar ( a = "\\{char16str",
                     b = "\\{ char[] array",
                     d = "\\{ text string")
        \g

Note that since I was typing these queries in to the monitor I needed
2 backslash characters.  If this had been in a libpq program I would
only have needed one.

Jeff Meredith
[email-masked]