Subject: attribute names in "retrieve.."

From: [email-masked] (Bruce Taneja.)
Date: Fri, 24 Jun 1994 20:43:20 -0400 (EDT)

Howdy folks,

I am trying to define a "complex object" .. for simplicity 
assume the circle.c example .. 

*           retrieve (tutorial.all)  \g  

would produce something like :

Query sent to backend is "retrieve (tutorial.all) "
---------------
| a       c   |
---------------
| (1 , 1, 10) |
---------------
| (2 , 2, 5)  |
---------------
| (0 , 1.8, 10)|
---------------

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Now, what I NEED is :

-----------------------------------
|          circle  a              |
-----------------------------------
|center x  |  center y  |  radius |
-----------------------------------
|    1     |     1      |    10   |
-----------------------------------
|    2     |     2      |    5    |
-----------------------------------
|    0     |     1.8    |    10   |
-----------------------------------

I can see how to produce "fancy string" data like:

" |    1     |     1      |    10   | " 

from my "circle_out " function , but how do can force postgres
to create  a  fancy header like I want :

-----------------------------------
|          circle  a              |
-----------------------------------      and not just ----------
|center x  |  center y  |  radius |                   |   a    |
-----------------------------------                   ----------

..... I don't think I can do this from the circle_out function
as then this header would be attached to every tuple retrieved

.. so where do I have to do the hacking ????

thanks a lot !
Bruce!

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Sat, 25 Jun 94 21:41:57 -0700

this header is produced by the terminal monitor, src/bin/monitor/monitor.c,
not by postgres itself.  monitor is just another frontend app, you can hack 
on that all you want..
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720-1776      |  ...!uunet!ucbvax!aoki