Subject: define operator

From: [email-masked] (James Woods 61-89-895257)
Date: Thu, 29 Jul 93 19:40:04 -0700

with the define operator command, arg2 is optional, which I assume allows you
to define a unary operator.  When a unary operator is define how do I then use 
it?  When I have attempted to use an operator I have defined I get the 
following messages:

* define operator @
        (arg1 = str_list,
        procedure = list_depth)
\g
 
Query sent to backend is "define operator @         (arg1 = str_list,         procedure = list_depth) "
DEFINE
Go 
* retrieve unique (depth = @list_table.list) \g
 
Query sent to backend is "retrieve unique (depth = @list_table.list) "
WARN:Jul 30 12:14:49:Can't find left op: @ for type str_list
 
Go 
* retrieve unique (depth = list_table.list@) \g
 
Query sent to backend is "retrieve unique (depth = list_table.list@) "
WARN:Jul 30 12:15:00:Can't find right op: @ for type 454496

James Woods
[email-masked]

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 29 Jul 93 20:14:43 -0700

[email-masked] (James Woods 61-89-895257) writes:
> it?

(correct) definition of unary operators is broken in postgres <= 4.1.
(this has been fixed in the development system.)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki