Subject: Re: correcting my last message (time intervals)

From: [email-masked] (Paul M. Aoki)
Date: Wed, 19 Jan 1994 10:37:39 -0800

[email-masked] (Gatto) writes:
> retrieve (MSG.all) where MSG.time <?> ["Mon Jan 17 10:58:28 1994 WDT",
> 		"Mon Jan 17 10:59:29 1994 WDT"]\g

the syntax for tinterval is actually
	['Mon Jan 17 10:58:28 1994 WDT' 'Mon Jan 17 10:59:29 1994 WDT']
and i would write it
	"['Mon Jan 17 10:58:28 1994 WDT' 'Mon Jan 17 10:59:29 1994 WDT']"::tinterval
if the parser complains that it can't figure out the type.

general advice to people who are bitten by syntax: the regression
tests (in src/regress/regress) contain examples of many different
types of queries.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

---

From: [email-masked] (Gatto)
Date: Wed, 19 Jan 94 16:21:39 EDT

Hi, POSTGRES users.

I'm new to POSTGRES v4.1.

I created a class "MSG (time = abstime, msg = text)" and populated it whith
some instances. Later I tried the following query:

...and POSTGRES returned:

Query sent to backend is "retrieve (MSG.all) where MSG.time <?> ["Mon Jan 17 10:58:28 1994 WDT":"Mon Jan 17 10:59:29 1994 WDT"]"
WARN:Jan 17 11:11:43:Can't find right op: <?> for type 702

What is wrong with my query? Can anyone help me?

Thanks very much!

Rubens C. Gatto