Subject: Floating-point precision in displays

From: [email-masked]
Date: Mon, 13 Jun 1994 16:02:08 -0500 (CDT)

Is there a way to specify the number of decimal places
with which to display floating point numbers?

I'm using a lot of "float4"s in my db, and the postgres monitor
displays them in scientific notation--not pretty.

Is there a built-in that I'm missing, or do I need to write  
a special display function?
-- 
* In Real Life: Billy Chambless * [email-masked]

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Mon, 13 Jun 94 14:37:19 -0700

> a special display function?

no, you're not missing anything.  float4_out just calls sprintf
with %g.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki