Subject: Bool types

From: Quandt Brian <[email-masked]>
Date: Fri, 19 Aug 1994 09:15:29 -0500 (CDT)

Okay I give up what are valid "values " for boolean types?

As in 
	retrieve (XXX.all) where XXX.booltype = true

	or

	retrieve (XXX.all) where XXX.booltype = false

	or

	append XXX (booltype = what)

I know that bools are either true or false but I just don't know
how postgres (4.2) indicates these.  Everytime I try things like
	boolvar = 1 to indicate true in the where clause I get
	illegal op for int4... need to cast it.

Brian Quandt

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Fri, 19 Aug 94 11:26:46 -0700

> Okay I give up what are valid "values " for boolean types?

't' and 'f' (or "t"::bool and "f"::bool).
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776