Subject: createdb problem

From: [email-masked] (Victor Kravets)
Date: Mon, 8 Nov 93 14:17:16 EST

Dear Sir/Madam,
I would like ask if you can help with running postgres.
I have a problem in doing that; 

Here is my environment from .cshrc:
setenv NNTPSERVER king.mcs.drexel.edu
setenv POSTGRESHOME ~postgres
setenv PGHOST queen.mcs.drexel.edu

and path contains /usr/local/postgres/bin  $POSTGRESHOME/bin /usr/sccs

And here is the actual problem:

queen% postmaster &
[1] 13362
queen% createdb foo
FATAL 1:Nov  8 11:04:42:process userid (745) != database owner (8)
/usr/local/postgres/bin/createdb: database creation failed on foo.
queen% 

Thank you very much for your time.
Victor Kravets

---

From: [email-masked] (Paul M. Aoki)
Date: Mon, 08 Nov 93 11:49:17 -0800

> /usr/local/postgres/bin/createdb: database creation failed on foo.

first, if you are still defining POSTGRESHOME, it sounds like
you're running 4.0.1.  4.1 is available.

second, somebody installed postgres such that the files in 
POSTGRESHOME/data/base are owned by the user with uid 8 (probably 
"postgres").  you have to start the postmaster as that user.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki