Subject: OSF/1 port of Postgres

From: Ram Kalkunte - 293-5139 <[email-masked]>
Date: Wed, 24 Mar 93 12:23:58 -0800

I am new to this list, so I have some questions. Please send me mail if this 
has been discussed before. 

Is anyone porting Postgres to OSF ? 
Has anyone looked into the issues of doing this work and care to share 
this info ?

Many thanks.

Ram Kalkunte
Digital Equipment Corp

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 24 Mar 1993 13:01:14 -0800

> Has anyone looked into the issues of doing this work and care to share 

the postgres group at berkeley is in the process of porting postgres
to osf/1 on alphas.  sorry, "alpha axp (tm)" :-)

osf/1 hasn't been the big problem so far.  worse is the fact that we 
make the implicit assumption in a lot of places that 
	sizeof(int) == sizeof(long) == sizeof(void *)
and, less frequently, the explicit assumption that
	sizeof(int) == sizeof(long) == sizeof(void *) == 4
neither of which sits very well with the alpha... :-)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

---

From: Mike Olson <[email-masked]>
Date: Wed, 24 Mar 1993 13:14:22 -0800

> Has anyone looked into the issues of doing this work and care to share 

we're working on a port to alpha osf/1 here at berkeley.  we don't have
a target date for releasing such a port yet.

					mike