Subject: Re: 2-phase locks and deadlocks

From: [email-masked] (Alfredo Sanchez)
Date: Thu, 12 Mar 92 07:56:54 -0800

does postgres really deal differently with read-only
transactions? i mean, does it allow any number of concurrent
transactions to access classes for retrieval-only
operations without locking them exclusively?

thanks again,

J Alfredo Sanchez H
-------------------
Hypertext Research Lab
Department of Computer Science
Texas A&M University

---

From: postarch (Postgres Mailing Archive)
Date: Thu, 12 Mar 92 10:37:27 PST

> operations without locking them exclusively?

read locks do not conflict with each other.  So there can be arbitrarily
many transactions setting read locks on a single relation at the same
time.

Jeff Meredith
[email-masked]