Subject: delete attr

From: [email-masked] (Banco de Dados Ambiental)
Date: Sat, 11 Apr 92 12:34:48 -0700

How should I delete a column from a given table?

---

From: postarch (Postgres Mailing Archive)
Date: Wed, 15 Apr 92 15:12:07 PDT

> How should I delete a column from a given table?

One way to do this is:

	retrieve into temp (oldreln.a, ..., oldreln.z)
	destroy oldreln
	rename temp oldreln

Where the target list for the retrieve into doesn't contain
the attribute you wish to delete.

The only problem is that you lose any indices you had on
oldreln.  I can't think of a better way offhand.

Jeff Meredith
[email-masked]