Subject: problems with memory

From: David Bigagli <[email-masked]>
Date: Sun, 5 Feb 1995 16:54:01 +0100

Hi,
 we install Postgres on alpha axp 3000/500 running osf/1 v2.1.
 Installation was ok. We found problems using copy command with a ascii file
 which dimension is 89373089 bytes. After two houres the copy aborts
 with the message "FATAL 1:Feb  4 22:54:39:palloc failure: memory exhausted".
 Then we use the command vacuum on the same database and also after two
 houres vacuum abborts with the same error message.
 Do you have any idea about?? May be is shared memory problem??
 Does it is normal that these commands take this long time to run?
 Thanks,
	Regards,....David

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: [email-masked] (Paul M. Aoki)
Date: Mon, 06 Feb 95 21:26:02 -0800

>  with the message "FATAL 1:Feb  4 22:54:39:palloc failure: memory exhausted".

you're likely hitting process virtual memory limits (based on
available swap space).  each copy command runs in one transaction and
some types of memory are only freed between transactions.

i would try splitting the file into smaller chunks and loading them
with separate copy commands.
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776