Subject: size of string in APPEND

From: [email-masked] (Bruce Taneja.)
Date: Fri, 1 Jul 1994 17:06:06 -0400 (EDT)

The back end crashes when the size of i/p string for
a defined ADT is approx > 100   ..

i.e APPEND ntable (a="some_string_>_100_char_long"::ADT) \g

causes some problems causing backend to "not respond" ..

_______

I believe the input string (char*) in postgres is posssibly
m(p)alloced  to = 100 (or some thing like that ) ..

Where (& what ) do I have to hack to get over this problem ..??

thanks for help!
Bruce

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: "Andrew K. Yu" <[email-masked]>
Date: Fri, 1 Jul 1994 14:46:31 -0700

> causes some problems causing backend to "not respond" ..
	
this is just postgres' friendly way of informing you the untimely death of
the backend.

> m(p)alloced  to = 100 (or some thing like that ) ..

no, the query buffer is 8KB. Besides, you'll get a message from the parser
(probably telling you about an unterminated string) instead of crashing the
backend.
	
> Where (& what ) do I have to hack to get over this problem ..??

I suspect the bug is in your ADT input function. Look at it again.

-andrew

---

From: [email-masked] (Bruce Taneja.)
Date: Fri, 1 Jul 1994 19:45:52 -0400 (EDT)

> (probably telling you about an unterminated string) instead of crashing the

Can you CONFIRM the 8KB buffer for postgres version 4.1 ??

> I suspect the bug is in your ADT input function. Look at it again.

The reason I suspect postgres is because I have another copy of my

which works like a piece of cake .. for all my various sized input
strings, .. 
however the monitor will APPEND only strings of size <100 , and
starts giving trouble in susequent (not the long stringed append!) appends
and .. once the backend does "not respond", then monitor hangs, ..

Even on exiting from monitor with a ^C and restarting up monitor
(even tried killing postmaster & restarting it), and running
ANY other command (on that particular data base) will cause monitor
to hang ..

help!
Bruce