Subject: Re: pg_relation

From: <[email-masked]>
Date: Tue, 13 Oct 92 12:53:05 PDT

In message <[email-masked]> you write:

> How can i get all relations of a database
> I tried this:
> 
> retrieve (pg_relation.all)\g

try
	retrieve (pg_class.all)\g

---

From: [email-masked] (Klaus Puerzelmayer)
Date: Tue, 13 Oct 92 11:46:38 -0700

retrieve (pg_relation.all)
\g

Query sent to backend is "retrieve (pg_relation.all) "
WARN:Oct 13 19:40:46:heap_openr on pg_relation failed

Go 
* 

But it does not work.
 
When I tried pg_type instead, I have seen that there is no
pg_relation. So, what is wrong ?

Thanks Klaus

----------------------------------------------------------------
Klaus Puerzelmayer		e-mail: [email-masked]
Tool Development		voice:  +431/391621-272
Alcatel-ELIN Forschungszentrum	fax:    +431/391452
Ruthnergasse 1-7, A-1210, Wien
Austria
----------------------------------------------------------------