Subject: define function

From: [email-masked]
Date: Wed, 24 Mar 93 10:19:29 EST

Given the following command:
Define fucntion highpay (language="postquel", returntype=setof S)
as retrieve (S.all) where S.salary>500  

I get an error message" "Syntax error at or near retrieve".  WHY??
I am working on a project that is due soon and have had no luck
with the define function command.  ANy help from anyone would be greatly apreciated.

Vicki Schlierer
State University of New York at Albany
School of Business
Email: [email-masked]

---

From: Mike Olson <[email-masked]>
Date: Wed, 24 Mar 1993 10:12:41 -0800

In message <[email-masked]>you write:

> with the define function command.  ANy help from anyone would be greatly apre
  +ciated.

because the function body must be enclosed in quotation marks.  see the
man page for define function.

reformulate as

define fucntion highpay (language="postquel", returntype=setof S)
    as "retrieve (S.all) where S.salary>500"