Subject: Class ownership

From: David Allan Finch <[email-masked]>
Date: Wed, 25 Aug 93 08:43:00 BST

Hi,

	Well, as some of you will remember, I am tring to
	export my database so I can import it into 4.1,
	as I have over 200 classes and 24Mb of data this
	is not trivial, and I realy nead to automate it.

	My new question is 'how do you change the ownership
	of a class?'. I can dump the class format to rebuild
	the structure and the data to re-load, but all the
	data and classes are now owned by Postgres. Can I just
	change the ownership by modifing the field in pg_class
	for that class?

--
    /		Sarum Wizard
 /\|/\		All Hail Discordia
 | K |		[email-masked]
 \___/		[email-masked]

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 25 Aug 93 10:22:27 -0700

> 	change the ownership by modifing the field in pg_class

that should work, assuming you're only talking about ownership
within the database.  (relowner is just your uid.) if you're having 
a problem with unix permissions, well, postgres doesn't run suid 
root :-)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

---

From: Ranen Goren <[email-masked]>
Date: Sun, 29 Aug 1993 18:25:33 +0300

You wrote:

> ... well, postgres doesn't run suid root :-)

...fortunately :)

	Ranen