Subject: Next version of Postgres

From: Ananth Srinivasan <[email-masked]>
Date: Tue, 9 Jul 91 11:08:01 EDT

I read a note a while ago that the next version will be released
in July. Is it out yet? Will it have the capability to execute
set functions? What will some of the differences between the
new version and v2.3 be? Thanks.

--Ananth

---

From: [email-masked] (Greg Kemnitz)
Date: Tue, 9 Jul 91 10:27:25 -0700

Postgres 3.0 will be released in early August.  3.0 will have the following
features:

1.  Large objects
2.  Functional and array indices
3.  Aggragates
4.  A command-line query interface usable from shell scripts

The biggest area of change is in upgrades and bug fixes:

1.  Postgres 3.0 will be about five times faster than 2.3 (and for some
    operations, an order of magnitude faster).
2.  Postgres 3.0 has been extensively cleaned up as far as memory use is
    concerned, and has successfully been tested on 800K (100MB of disk space)
    object databases.
    2.3 will not work for anything but rather small db's due to memory leaks.
3.  Big joins (4 way or larger) work in 3.0 (they don't work in 2.3). 
4.  Multi-user performance will be extensively improved.
5.  The Query Rewrite rule system (and all its dependent features such as
    views and versions) has been extensively upgraded.
6.  Object headers and indices are substantially smaller in 3.0 than they were
    in 2.3.

    Greg Kemnitz
    [email-masked]