Subject: Installation problem?

From: [email-masked] (Nabil Hachem)
Date: Thu, 16 Jul 92 12:07:24 -0700

we just installed version 4 and had the following problem:

Upon hitting the statement with "getopt" in genbki.sh, we got the following error message:
...

linking pg_uid
creating local.bki
/usr/users/postgres/postsparc/src/lib/Gen/genbki.sh: getopt: not found
*** Error code 1
make: Fatal error: Command failed for target `/usr/users/postgres/postsparc/obj.sparc/support/local.bki'
Current working directory /usr/users/postgres/postsparc
done
...
(more error messages that seem related)

We checked libc.a for getopt.o with
% ar t libc.a|grep getopt
getopt.o

We commented out the portion that checks for options in genbki.h and
got the system to compile this time. It seems to run as well?!
Could you explain what we are/were doing wrong? 
Platform: Sparc IPC with Sun OS 4.1

Thanks,
Nabil Hachem
P.S: is data compatible between versions 3.1 and 4
 (i.e do we need to copy over or just move in the data? )

---

From: [email-masked]
Date: Thu, 16 Jul 92 14:58:13 -0700

In message <[email-masked]> you write:

> Upon hitting the statement with "getopt" in genbki.sh, we got the following e
 +rror message:
> make: Fatal error: Command failed for target `/usr/users/postgres/postsparc/o
 +bj.sparc/support/local.bki'
> Platform: Sparc IPC with Sun OS 4.1

You should be just fine ignoring the options (I don't think there are any
in the system we ship).

getopt is a shell command:

gaia 753 % man getopt

                                                                    getopt(1)

   Name
     getopt - parse command options

   Description
     The getopt command breaks up options in command lines for easy parsing
     by Shell procedures and checks for legal options....