Subject: Expanding pg_time table

From: PostGres <[email-masked]>
Date: Thu, 28 Oct 1993 01:46:54 +1000 (EST)

To The More Knowledgable,

I have a few of questions for you :

1st :  how do I reduce the size of the pg_time table
       in the ~/data directory .. this file is now
       approaching 2megs and since I dont really know
       what its used for I thought it best to ask. This
       also goes for the pg_log file.

2nd :  The system occasionally produces temp files in
       the ~/data/base/user database directories. What
       are these files for and is it ok to delete them.

3rd :  My system does not allow me to purge any of the
       classes. It also falls over with the error 
       mentioned in the man entry. Has this been fixed
       or is it something Im doing wrong.

To close .. a few words of praise. I am currently 
developing a system for keeping track of all the allocated
IP numbers across our distributed campuses. I needed a
relatively small, (no cost :) product that could run on
both the dec and the sun environments. Even with the locking
problems with postgres I have found the product to be most
useful in this application. To ensure data integrity it
was necessary to use a dummy lock table .. but that aside
it was worth the effort to create this postgres based
application. My thanx to the authors.

Glen Darby
-- 
--------------------------------------------------------
| University Of Western Sydney                         |
| Postgres Database Aministration                      |
|                                                      |
| Administrator :  Glen Darby                          |
|                                                      |
|                                                      |
| Return Mail : [email-masked]          |
========================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Sat, 30 Oct 93 23:52:00 PDT

>        also goes for the pg_log file.

currently there's no way to do this.

>        are these files for and is it ok to delete them.

if there aren't any transactions running (ie, they're really
old files) it should be fine to nuke them.

>        or is it something Im doing wrong.

purge broke in 4.1.  it's on the bug list but you'd have to ask
marc (@postgres) if it will be fixed in 4.2.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki