Subject: Re: Installation / Linux

From: [email-masked] (Karl Eichwalder )
Date: Thu, 25 Nov 93 9:28:38 MET

hi !

now i'm using linux v0.99p13r.

> The problem is the macro MAXFILES, which is defined as:

thx for the explanation!

> Quick and dirty recovery: include

seems to work :-)

a new Error in /usr/include/regex.h occurs (sorry for annoying you again!):

$ compiling utils/adt/regexp.c
$ In file included from regexp.c:23:
$ /usr/include/regex.h:300: parse error before `size_t'
$ /usr/include/regex.h:300: warning: no semicolon at end of struct or union
$ /usr/include/regex.h:307: parse error before `:'
$ /usr/include/regex.h:316: parse error before `:'
$ /usr/include/regex.h:320: parse error before `:'
$ /usr/include/regex.h:324: parse error before `:'
$ /usr/include/regex.h:328: parse error before `:'
$ /usr/include/regex.h:331: parse error before `:'
$ /usr/include/regex.h:334: parse error before `:'
$ /usr/include/regex.h:460: parse error before `size_t'
$ /usr/include/regex.h:462: parse error before `regerror'
$ /usr/include/regex.h:464: parse error before `size_t'
$ /usr/include/regex.h:464: warning: data definition has no type or storage cla\
ss
$ regexp.c: In function `char16regexeq':
$ regexp.c:45: storage size of `rpb' isn't known
$ regexp.c: In function `textregexeq':
$ regexp.c:112: storage size of `rpb' isn't known
$ make[1]: *** [/mnt/data/pub/postgres/obj.linux/utils/adt/regexp.o] Error 1

is there a simular `quick and dirty' possibility? ;-)

BTW trying to continue compilation i allways receive the message:

$ File /mnt/data/pub/postgres/obj.linux/support/postgres does not exist.

which is the target you have to invoke, whenever i intend to continue
the compilation?

last question this time: where may i find archives of the postgres
mailing-list?

-karl-
-- 
|Karl Eichwalder			|kleio-Projekt
[email-masked]			|MPI fuer Geschichte Goettingen
|					|
|GWDG					|Gesellschaft fuer wissenschaftliche
|					|Datenverarbeitung - Goettingen

---

From: [email-masked] (Kai Petzke)
Date: Thu, 25 Nov 93 16:29:25 MET

Hi,

> ...

Yet another excerpt from the file postgres.README (there is an old
and a new version of this file, in this case, only the new version
contains the following.  It is a problem, which occured later due
to changes in /usr/include/regex.h):

    Your /usr/include/regex.h might or might have the line:
    "#include <sys/types.h>. If it does not, be sure to put it either
    in /usr/include/regex.h or ~postgres/src/utils/adt/regexp.c.

> which is the target you have to invoke, whenever i intend to continue

Try to continue using:

	Make everything

If that finally succeeds (I hope so, you have run into all well-known
errors by now), try:

	Make install

> last question this time: where may i find archives of the postgres

I do not know, either.

Kai