Subject: Errors while running Postgres

From: [email-masked] (Raj Vadakkencherry)
Date: Thu, 11 Aug 1994 14:01:43 -0700 (PDT)

Hi,

 We are trying to run postgres queries on a very large database and are
 beset with problems. The postgres backend process dies in the middle of
 the execution of some queries, reporting error messages like:

 1. Fatal: No response from backend in PQExec
 2. SearchSysCache: Called while cache disabled
 3. Functions not present in .so file

 etc.
 
 (Some background: The queries are from the Sequoia 2000 benchmark tests.
  The software and the data on which the queries operate were provided to us
  by Paul Brown and Claire at Berkeley. If you are familiar with the above,
  the name of the particular program we are referring to is "run_complete"
 -- it loads the database with points, polygons and islands data, and
 executes queries using LIBPQ calls)

 The programs were compiled in the SUN Solaris environment. The version 
 of Postgres is 4.2.  The database is large - approx. 80 MBytes. 

 Here is a sample of some queries and error messages:

 Query sent to backend is "retrieve (polygons.location) where (size(polygons.loca
tion) > "1014420.0"::float8) and (make_circle("(-1704753, -581511)"::point, "317
0.0"::float8) <|> polygons.location) "^M
WARN:Aug 10 17:40:19:pg_procnameind: cannot extend^M
^M
Query sent to backend is "retrieve (polygons.landuse, polygons.location) where (
polygons.location && make_box(gpoints.location,"5000.0"::float8)) and (gpoints.n
ame = "Zaca Ridge") "^M
WARN:Aug 10 17:40:19:SearchSysCache: Called while cache disabled^M
^M
Query sent to backend is "retrieve into Query10 (gpoints.name, gpoints.location)
 where (gpoints.location @ polygons.location) and (polygons.landuse = 91) "^M
WARN:Aug 10 17:40:19:SearchSysCache: Called while cache disabled^M

 Any help or suggestions to correct the problems will be greatly appreciated.

Thanks,
Raj.

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 11 Aug 94 14:14:29 -0700

>  3. Functions not present in .so file

this suggests that the shared libs aren't being generated right..
i doubt the makefile was set up for solaris, given that the s2k
benchmark has never been run on solaris.

>   by Paul Brown and Claire at Berkeley.

people have gotten this to work on alphas and sunos4, but with respect to..

>  The programs were compiled in the SUN Solaris environment.

.. this, you're pretty much on your own.  (paul brown has been hijacked 
to SDSC for a month, our sole solaris machine wandered off a few weeks 
ago and has not been seen since..)

> WARN:Aug 10 17:40:19:pg_procnameind: cannot extend^M

can't be sure, but this suggests that it ran out of disk space.
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776