Subject: index on datetime types

From: [email-masked] (Banco de Dados Ambiental)
Date: Wed, 24 Jul 91 12:25:30 -0700

Is there a way of using indexes on attributes of type "datetime"
other than associating operators in the pg_amop system catalogs class?
        Thanks for any hints.

---

From: [email-masked] (Mike Olson)
Date: Wed, 24 Jul 91 13:09:14 PDT

you can define an index on data of type 'abstime' by using

	define index xyzzy on mytable using btree (myattribute abstime_ops)

there's no distinguished type in postgres called 'datetime', so i assume
that 'abstime' is what you want.
					mike olson
					postgres research group
					uc berkeley
					[email-masked]