Subject: buffer leak detected in BufferPoolCheckLeak()

From: Wojtek Bogusz <[email-masked]>
Date: Mon, 1 Aug 1994 13:19:09 +0200 (MET DST)

Hello,

 I am defining new types for PG. First I define IO and types and then 
relation functions and on the end operators. While defining operators I 
get strange NOTICE messages:
...
Query sent to backend is "define operator << (  arg1 = nlschar,         arg2 = nlschar,         procedure = nlschar_lt,         associativity = left,         restrict = intltsel,    join = intltjoinsel) "
DEFINE
Query sent to backend is "define operator >> (  arg1 = nlschar,         arg2 = nlschar,         procedure = nlschar_gt,         associativity = left,         commutator = <<,        restrict = intltsel,    join = intltjoinsel) "
NOTICE:Aug  1 12:58:26:buffer leak detected in BufferPoolCheckLeak()
NOTICE:Aug  1 12:58:26:[00] (freeNext=18, freePrev=19, relname=pg_operator, blockNum=2, flags=0x14, refcount=0 0)
NOTICE:Aug  1 12:58:26:[01] (freeNext=47, freePrev=7, relname=pg_log, blockNum=0, flags=0x14, refcount=0 0)
... much more NOTICE:
NOTICE:Aug  1 12:58:27:[63] (freeNext=15, freePrev=54, relname=pg_procnameind, blockNum=3, flags=0x14, refcount=0 0)
DEFINE

 This happens on definition each second operator. What does it mean ? 
Does I am making any thing wrong ?

 Thank You 
 Wojtek

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Kai Petzke)
Date: Wed, 3 Aug 1994 19:28:10 +0100 (MET DST)

Hi,

The "buffer leak" notices seem to be caused by an internal problem of
postgres, not by the user.  I have gotton a bunch of these notices once,
when I ran the regression test, but could not reproduce the problem.

The problem was not reproducable, though.  If anybody has a set of
queries, which reproducably produce a buffer leak, I would appreciate,
if you send me them.

Kai

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 04 Aug 94 12:23:26 -0700

[email-masked] (Kai Petzke) writes:
> postgres, not by the user.

yes.  a piece of code is pinning a buffer somewhere and then neglecting
to unpin it again.  the scary notices were added to facilitate debugging.

i thought the define operator one had been fixed.  maybe not.  there is a 
new one lurking in the btree code somewhere..
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776