Subject: v3.1 installation prob

From: [email-masked] (Alfredo Sanchez)
Date: Tue, 21 Apr 92 11:05:42 -0700

Dear PG developers,

We decided to move from 3.0 to 3.1 to see if we could
have some of our concurrency woes solved.

I think I followed the installation instructions, but
I'm getting an error when compiling, almost at the end
of the inst process. The output looks like:

---------------------------------
output slots(%o)
sed'ing lex.yy.c
compiling bootstrap/socket.c
compiling bootstrap/bootstrap.c
Module BOOTSTRAP done
Module INH done
linking postgres
Undefined
_sparc_bug_set_outerjoincost
*** Error code 2
make: Fatal error: Command failed for target `POSTGRES.o'
Current working directory /home/postgres
done
creating dbdb.bki
creating local.bki
compiling lib/libpq/fe-dumpdata.c
compiling lib/libpq/fe-pqstubs.c
compiling lib/libpq/fe-pqexec.c
compiling lib/libpq/fe-pqufs.c
ar rvu libpq.a ...
----------------------------------

no other errors occurred neither before nor
after this.

I assumeed that I didn't need the available
patch, since I ftp'ed v3.1 last week.

I also did'nt make any changes to the OS
kernel, since the installation instructions
looked the same as v3.0.

I will appreciate any help you can provide.

____________________
J Alfredo Sanchez
Hypermedia Research Lab
Texas A&M University

---

From: postarch (Postgres Mailing Archive)
Date: Mon, 27 Apr 92 11:04:48 PDT

> no other errors occurred neither before nor

It sounds like you didn't select the sparc port.  This function is
defined as a hack workaround to an old sparc compiler bug.  It should
be in the file $POSTGRESHOME/src/port/sparc/port.c (I'm not sure it
is even needed anymore... I'll look into it).

> patch, since I ftp'ed v3.1 last week.

No one should need the patch anymore. I have gone so far as to remove
it from postgres.berkeley.edu.

Jeff Meredith
[email-masked]