Subject: Indexing Views

From: "Schenkelaars.V.F" <[email-masked]>
Date: Thu, 14 May 92 9:35:19 MET DST

I've got a question, Does Postgres support View indexing? How do
I use these, just index the view or do I have to do something
magic?

Greetings
     ____________________
 \  / . _   _  _   _  |
  \/ ( ( \ (_ (-' ( \ |

--------------------------------------------------------------------------------
Vincent F. Schenkelaars				|
Company: FEL-TNO                                | Private:
Email  : [email-masked]	|
address: Oude Waalsdorperweg 63			| Groenhovenstraat 12
         Postbus 96864				|
         2509 JG  Den Haag			| 2311 BT  Leiden
         The Netherlands			| The Netherlands
Phone  : Holland 070-3264221			| Holland 071-125576
Fax    : Holland 070-3280961			|
--------------------------------------------------------------------------------
We apologize for the inconvenience.

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 19 May 92 09:05:37 PDT

>I use these, just index the view or do I have to do something

Views in postgres are implemented via rewrite rules.  To get indexing
you have to define indices on the base relation yourself.  The rewrite system
isn't smart enough to translate a 'define index' on the view into a 'define
index' on the base relation.

Jeff Meredith
[email-masked]