Subject: User Defined Types, Oper, and Prog Lang.

From: Ravi Lingam <[email-masked]>
Date: Tue, 29 Jun 93 17:12:53 EDT

I am using Postgres 4.0.1. 

when I tried to compile the tutorial example 
on User Defined Types, Operators, and Programming 
Language Functions - "circle" given in the 
User manual pages 12-17.

I got the following errors: 
	ld: Undefined symbol 
   		_point_dt 
   		_palloc 

Could someone tell how to correct this error.

Thanks 

Rav Lingam 
email [email-masked]

---

From: "Andrew K. Yu" <[email-masked]>
Date: Tue, 29 Jun 93 23:19:20 -0700

> I got the following errors: 
	
you need to compile the source into an object file, not an executable. To
do so, you need the -c flag.

eg.	cc $(OTHER_CFLAGS) -c the_object.c

and you will get a the_object.o

- Andrew