Subject: Field Names

From: "David Alan Nelson" <[email-masked]>
Date: Thu, 5 May 1994 12:23:57 +0100 (BST)

Can somebody tell me what the problem with this is.  For some
reason, Postgres 4.1 seems to dislike attribute names of 16
characters, when I try to retrieve.

* create kk(abcdefghijklmnop = int2)
\g

Query sent to backend is "create kk(abcdefghijklmnop = int2) "
CREATE
Go
* append kk(abcdefghijklmnop = 30)
\g

Query sent to backend is "append kk(abcdefghijklmnop = 30) "
APPEND 39196
Go
* retrieve (kk.all)
\g

Query sent to backend is "retrieve (kk.all) "
Error: Unexpected identfier in dump_data:

It then crashes out from the monitor.

Any suggestions would be gratefully appreciated.

Cheers

Dave Nelson
-- 

Mail ID : [email-masked]

Computing Science, University of Newcastle upon Tyne, UK.  (091) 222 8789

===============================================================================
    To add/remove yourself from the POSTGRES mailing list: send mail with 
    the subject line ADD or DEL to "[email-masked]"

    If this fails, send mail to "[email-masked]" and
    a human will deal with it.  DO NOT post to the "postgres" mailing list.
===============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Mon, 09 May 94 17:02:58 -0700

"David Alan Nelson" <[email-masked]> writes:
[16 character names]
> It then crashes out from the monitor.

there were tons of places where the server did not correctly
handle 16-character names.  marc teitelbaum made an attempt 
to fix as many of these as possible for 4.2.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki