Subject: views-rules

From: Munib A Qutaishat <[email-masked]>
Date: Tue, 16 Jul 91 04:05:59 -0700

We have version 2.01 of POSTGRES and would like to know if there is any way to
define views and rules as a hirarchical structure. For example, STUDENT and
GRADUATE_STUDENT can be defined as in the following:

i)      STUDENT-View 				ii)       STUDENT-Rule
	    |							|
	    |							|
	    | (inherits)					| (inherits)
     GRADUATE_STUDENT-View				GRADUATE_STUDENT-Rule

OR if this can be done in version 3.0.

					M.Qutaishat
				   [email-masked]

---

From: [email-masked] (Mike Olson)
Date: Tue, 16 Jul 91 08:13:27 PDT

> define views and rules as a hirarchical structure.

no, this isn't possible.  it's a sensible extension to make, but not one
we're likely to get to in the short term.

					mike olson
					postgres research group
					uc berkeley
					[email-masked]