Subject: Functions on arrays ?

From: [email-masked] (Wolf-D. Ihlenfeldt)
Date: Wed, 24 Mar 93 01:26:34 -0800

I tried to define a set of private functions which operate
on arrays, not single array elements:

define function formula_eq ( language = "c", returntype = bool) 
 arg is (int2[], int2[]) as "/home2/wolf/WB/PG/pg_formula.p.o"

and I get

WARN:Mar 24 18:26:02:parser: syntax error at or near "["

Is it possible to define functions on arrays ? 
If yes, what is the correct syntax ?

Thank you for your help.

WDI

System: v4r1 on sparc

The array is variable-length.

---

From: Mike Olson <[email-masked]>
Date: Wed, 24 Mar 1993 10:05:39 -0800

> WARN:Mar 24 18:26:02:parser: syntax error at or near "["

you could try

	arg is (_int2, _int2)

and see if it works.  the system creates magic _<typname> types to represent
"array of <typname>".
					mike