Subject: Installing pgperl

From: Eric P Dean <[email-masked]>
Date: Tue, 30 Aug 1994 15:34:42 CDT

I have POSTGRES v4.2 and PERL 4.036 running on a DEC 5000/133 in an MIT
Athena-like environment.  I tried bmake on pgperl and received the
following error messages.  I've read Paul Aoki's comments in the
Makefile and would like to know how to have the memcpy and memset return
void.  I'm not much of a computer whiz, so please make it as understandable
as possible.

Thank you!  And thanks to all who answered my question regarding
searching on seperate words in an attribute. Your answers were very helpful!

Eric Dean
Curator, Visual Resources Collection
College of Design, Iowa State University

[email-masked]> /local/postgres/xxbmake/bmake
/local/perl-4.036/usub/mus pg-libpq.mus > pg-libpq.c
cc -g -I/local/postgres/include -I/local/perl-4.036  -c pg-libpq.c
cfe: Warning: /usr/include/sys/param.h:389: Macro MIN redefined
cfe: Warning: /usr/include/sys/param.h:390: Macro MAX redefined
cfe: Error: /local/perl-4.036/perl.h, line 159: redeclaration of 'memcpy'; previous declaration at line 121 in file '/usr/include/string.h'
        extern char * memcpy();
        --------------^
cfe: Error: /local/perl-4.036/perl.h, line 159: Incompatible function
return type for this function 
        extern char * memcpy();
        --------------------^
cfe: Error: /local/perl-4.036/perl.h, line 175: redeclaration of
'memset'; previous declaration at line 123 in file
'/usr/include/string.h' 
        extern char *memset();
        -------------^
cfe: Error: /local/perl-4.036/perl.h, line 175: Incompatible function
return type for this function 
        extern char *memset();
        -------------------^
cfe: Error: pg-libpq.c, line 589: missing size for array 'portalnames'
            char portalnames[MAXPORTALS][32];
        ---------^
cfe: Error: pg-libpq.c, line 589: storage size for 'portalnames' isn't known
            char portalnames[MAXPORTALS][32];
        ---------^
cfe: Error: pg-libpq.c, line 589: 'MAXPORTALS' undefined, reoccurrences
will not be reported 
            char portalnames[MAXPORTALS][32];
        ---------------------^
cfe: Error: pg-libpq.c, line 590: missing size for array 'pnames'
            char *pnames[MAXPORTALS];
        ----------^
cfe: Error: pg-libpq.c, line 590: storage size for 'pnames' isn't known
            char *pnames[MAXPORTALS];
        ----------^
*** Error code 1

Stop.

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Tue, 30 Aug 94 14:04:10 -0700

Eric P Dean <[email-masked]> writes:
> following error messages.

that's odd.  this shouldn't happen anymore, the pgperl that comes
with 4.2 (in src/contrib/pgperl) no longer uses MAXPORTALS.

faerie:aoki (366)> pwd
/usr/local/devel/postgres-v4r2/src/contrib/pgperl
faerie:aoki (367)> egrep MAXPORT pg-libpq.mus
faerie:aoki (368)> egrep ,v pg-libpq.mus 
 * /usr/local/devel/postgres-v4r2/src/contrib/pgperl/RCS/pg-libpq.mus,v 1.7 1994/06/16 11:37:21 aoki Exp
faerie:aoki (369)> 

the same checkin also obviated the need to dink your perl.h on ultrix
(i defined some perl-internal defines..)

however, one or more versions of the prerelease code were broken.  i
am guessing you have the alpha or beta code..?
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776