Subject: notify turned off in 4.1??

From: [email-masked]
Date: Wed, 30 Mar 1994 08:54:35 -0500 (EST)

We have Postgres 4.1 installed.
There is a capability of Postgres that I could really use, notify, 
which seems to be turned off.

There is a sample program that claims to set itself asynchronously
so that when a rule is triggered in postgres, it will be 'notified'
and can proceed on its execution.  
However, when I define the rule to trigger it, it gives the output below.

Welcome to the C POSTGRES terminal monitor

Go 
* define rule r1 is on append to test1 do
[append test1a (i = new.i)
notify test1a] \g

Query sent to backend is "define rule r1 is on append to test1 do [append test1a (i = new.i) notify test1a] "
WARN:Mar 29 23:02:01:notify is turned off for 4.0.1 - see the release notes

*

So notify is turned off in version 4.0.1.  BUT the documentation
says this is version 4.1. 

Is this a mistake by the person installing the program?
I believe he used the pre-compiled binaries.
Is there a fix for it? Or is notify turned off in 4.1 also?

Thanks for any assistance,
Debby Keen
[email-masked]

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 30 Mar 94 12:17:01 -0800

> which seems to be turned off.

this has been turned back on in 4.2.

the previous implementation had what mike olson euphemistically
termed "a flaw in the implementation".  jiang wu (who works on
the tioga project) rolled up his sleeves and fixed it.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki