Subject: How to retrieve only rows with null-values?

From: Rainer Staringer <[email-masked]>
Date: Thu, 23 Jul 92 05:20:01 -0700

I have a very simple question which I could not solve using the docs:

What is the correct Postquel syntax for retrieving only rows which
have a null-value for a certain attribute?

I tried the obvious 'retrieve (test.all) where test.attr = NULL'
but this only crashed the backend...

Thanks in advance for any clues.

	Rainer
---
Rainer Staringer                   | [email-masked]
Financial Markets Lab, TU Vienna   | +43 (1) 58801/8138

---

From: postarch (Postgres Mailing Archive)
Date: Fri, 24 Jul 92 15:30:59 PDT

> but this only crashed the backend...

In version 4 you can say:

	retrieve (test.all) where test.attr ISNULL

In previous versions you could not test for null attributes.

Jeff Meredith
[email-masked]