Subject: Problem with pgbrowse

From: "Steve Martin" <[email-masked]>
Date: Thu, 26 Jan 1995 13:41:08 -0500

Hi I was wondering if anyone could help me with a problem I'm having with
pgbrowse. I select a class and the Class: window comes up with the fields
listed in reverse order from how they are ordered in the database. If i select
query, the query window comes up with the fields reversed as well. If I use the
query window to append a new record into the database, the fields are used in
the proper order.

For example, suppose the I created a table with fields name, address and
phone in that order. The query window looks something like:

phone   = [           ]
address = [           ]
name    = [           ]

which is the reverse order. Now if I fill in some values as shown below:

phone   = [555-1234   ]
address = [hooterville]
name    = [Steve      ]

the append command that is form looks like:

append person (
	name="555-1234",
	address="hooterville",
	phone="Steve")

Can you suggest what might be wrong? I'm using v3.1b on a sun under sunos 4.1.3
and postgres 4.2.

						Thanks
						   Steve

-- 
Stephen Martin
[email-masked]
e-Commerce, Inc., 1030 Kamato Road, Suite 201 
Mississauga, Ontario, Canada   L4W 4B6        

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: Raymond Toy <[email-masked]>
Date: Fri, 27 Jan 1995 10:14:28 -0500

>>>>> "Steve" == Steve Martin <[email-masked]> writes:

    Steve> Hi I was wondering if anyone could help me with a problem
    Steve> I'm having with pgbrowse. I select a class and the Class:
    Steve> window comes up with the fields listed in reverse order
    Steve> from how they are ordered in the database. If i select
    Steve> query, the query window comes up with the fields reversed
    Steve> as well. If I use the query window to append a new record
    Steve> into the database, the fields are used in the proper order.

You can find the some patches that fix this problem.  There are at the
same ftp site as pgbrowse.

Ray
Ray -----> [email-masked]
Toy -----> Ericsson-GE RTP x7480