Subject: building Postgres-v4r2

From: [email-masked] (Leland Ellis)
Date: Sat, 7 May 1994 12:31:32 +0600

Hello, on a Sun SS10GX+ w/ SunOs 4.1.3, using /usr/ucb/cc and /uqsr/ucb/ld,
during 'bmake install all', the following Error results:

cc -o postgres *.o -ln -ldl -lm

ld: Undefined symbol
    _compile
    _step

where *.o are the several .o files.  The build is done as user 'postgres'.

The libln, libdl and libm are all in /usr/lib, and /lib and /usr/ucblib are
links to /usr/lib.  compile is there too.

Where is it looking for compile and step?

Thanks in advance,

Leland

Leland Ellis, Ph.D.
Professor of Biochemistry and Biophysics
Director, W.M. Keck Center for Genome Informatics
Institute of Biosciences and Technology
Texas A&M University
2121 Holcombe
Houston, Texas  77030
email: [email-masked]
URL:   http://keck.tamu.edu/ibt.html

P.S.:  Good to see the ftp server back up.  Thanks to all responsible.

===============================================================================
    To add/remove yourself from the POSTGRES mailing list: send mail with 
    the subject line ADD or DEL to "[email-masked]"

    If this fails, send mail to "[email-masked]" and
    a human will deal with it.  DO NOT post to the "postgres" mailing list.
===============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Sat, 07 May 94 11:26:41 -0700

> Where is it looking for compile and step?

/usr/include/regexp.h which, oddly, contains c functions.

does it work when you just use /bin/{cc,ld}?
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki