Subject: Re: Estimate of Solaris port date?

From: [email-masked] (Leif Neve)
Date: Wed, 22 Jun 1994 10:21:54 +0500

> From [email-masked] Tue Jun 21 18:06 EDT 1994

> > [email-masked] (Leif Neve) writes:
> > Are we seeing any light at the end of the tunnel on the
> > "official" Solaris  2.3 port? Would anyone care to offer
> > a rough estimate (using a granularity of, say, months) as
> > to when it will be complete?

> i finally got a single codebase passing regression on
> 	hpux 9.03
> 	osf/1 2.0
> 	solaris 2.3 (with frank delahoyde's hacked gcc)
                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

We are stuck with gcc at our site. So will we need this hacked version 
of gcc:

	(a) To do local build-from-source installations of Postgres?
	(b) To define C functions?

If either (a) or (b) produces a yes, then can you advise as to how
we can get these hacks. Does FSF know about them?

Thanks,
Leif Neve

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Wed, 22 Jun 94 11:19:11 -0700

> 	(b) To define C functions?

yes.

> we can get these hacks. Does FSF know about them?

it's a one-line change to sparc.c; it's included in frank's patchfile
on our ftp server.  yeah, the cygnus guys sent it to fsf but who knows
when the next release of gcc will come out.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki