Subject: PQendcopy problem

From: "David Alan Nelson" <[email-masked]>
Date: Mon, 23 May 1994 13:31:00 +0100 (BST)

When using the PQlib system with Postgres 4.1, execution of the
PQendcopy() function causes the program executing PQendcopy()
to hang, rather than allowing us to perform a second operation.

Has anybody else came across this problem, or can provide a 
solution.

Cheers

Dave Nelson
-- 

Mail ID : [email-masked]

Computing Science, University of Newcastle upon Tyne, UK.  (091) 222 8789

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Mon, 23 May 94 05:59:21 -0700

> to hang, rather than allowing us to perform a second operation.

one thing that isn't terribly clear (ha, understatement) in the 
documentation is the fact that PQendcopy should only be used if 
you are doing copy with the stdin/stdout keywords.  copy to/from 
a file works just like any other query; if you call PQendcopy in
that case, the first thing libpq does is read from the connection,
and i would expect that that would hang.  (if that's not the
problem, then i have no idea.  both kinds of copy are exercised 
in the regression tests.)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki