Subject: Announcing Postgres Version 4

From: [email-masked]
Date: Wed, 15 Jul 92 11:14:06 -0700

Let me try this again...  replace all references to v3r1 in
the faq I sent out last night with v4r0.

Jeff

     Version 4.0 of the POSTGRES DBMS is now available for
distribution.  Version 4.0 provides significant advances in
functionality over 3.1.  General improvements in the code and some
key multi-user bug fixes have resulted in a much more reliable system
than we have ever previously released.

Major new features include:

 o  Complete support for language (POSTQUEL) functions.

 o  Handling of nested dot expressions.

 o  Optimization of predicates with expensive functions.

 o  Binary portals

 o  Initial support of sets

 o  Indices on system catalogs.

Postgres runs on Sparc I, Sparc II, Sun 4 running SunOs, and DECstations
running ULTRIX >= 4.0, as well as Sequent Symmetry machines.  Postgres
consists of about 250,000 lines of C.

If you would like to get Postgres 4.0, you can get it in one of two ways:

(1)  Anonymous FTP from postgres.berkeley.edu

To FTP postgres to your site, type the following bracketed text without
brackets.  You should see similar output.

% ftp 128.32.149.1 

- or -

% ftp postgres.berkeley.edu
Connected to 128.32.149.1.
220 postgres FTP server (Version 4.4 Sun Feb 5 07:58:07 PST 1989) ready.
Name (128.32.149.1:): [ anonymous ]
331 Guest login ok, send ident as password.
Password:[ mylogin@myhost ]
230 Guest login ok, access restrictions apply.
ftp> [ cd pub ]
250 CWD command successful.
ftp> [ get postgres-setup.me ]
200 PORT command successful.
150 Opening ASCII mode data connection for postgres-setup.me (NNNNNNN bytes).
ftp> [ binary ]
200 Type set to I.
ftp> [ get postgres-v4r0.tar.Z ]
200 PORT command successful.
150 Opening BINARY mode data connection for postgres-v4r0.tar.Z (NNNNNNN bytes).
226 Transfer complete.
local: postgres-v4r0.tar.Z remote: postgres-v4r0.tar.Z
NNNNNNN bytes received in MMM.MM seconds (KK Kbytes/s)
ftp> [ quit ]
221 Goodbye.
%

Or, if you do not have net.access, you can order a Postgres distribution
tape by sending a check payable to

the Regents of the University of California

for $150.00 to:

         Postgres Project
         521 Evans Hall
         University of California
         Berkeley, CA 94720.

     Indicate in your accompanying letter whether  you  want
     the  system on a 9-track tape at 1600 BPI, at 6250 BPI,
     on a cartridge tape for SUN shoeboxes (QIC 24  format),
     or on a TK50 DEC cartridge tape.

-----------------------------------------------------------------------
Jeff Meredith
Postgres Chief Programmer
[email-masked]

---

From: <[email-masked]>
Date: Sat, 18 Jul 92 11:00:35 -0700

Address should by 557 Evans Hall.
/claire