Subject: attribute names of a class

From: [email-masked] (Gregor Schnieder)
Date: Sat, 15 Jan 1994 18:53:53 +0100

Hallo everyboddy,

I'am new in postgress. Who can help me? I try to get the attribute
names in a class, e.g. my own class adress. There are attributes like post_name,
pre_name, zip_code, town, street, etc. ... 

I do the retrieve command in the followeing way. 

	retrieve (c.relname, c.relnatts, c.reltuples, a.attname)
		from c in pg_class, a in pg_attribute
		where c.relname = "adress"

The list I get back is very long, because there are many attributes like tmin,
tmax, vtype, etc. in it. Also the attribute names of the class I created,
are included. But how can I get back a short list? (post_name, pre_name, ... )

cu Gregor

#include <standarddisclaimer.h>
 never touch a running program!

#  e-mail: [email-masked]
#  voice : +49 521 883599
#
#  adress: Gregor Schnieder
#	   Im Bergsiek 29
#	   D-33739 Bielefeld

---

From: [email-masked] (Paul M. Aoki)
Date: Sat, 15 Jan 1994 20:55:01 -0800

> 		where c.relname = "adress"
		and a.attnum > 0
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki