Subject: Postmaster

From: [email-masked] (GB Jazbutis)
Date: Fri, 4 Sep 92 07:11:49 -0700

Greetings,

We're trying to put something in the boot file to run postmaster
whenever our machine boots (in the etc/rc.local file), but
it doesn't work.  It looks like the statement gets executed
but it doesn't hang around, and there are no diagnostics.  

Does anyone have any ideas on how to do this?  Must there
be some things "up and running" that we don't have when we
try to run postmaster?

Thanks.
	Gintas    [email-masked]

---

From: Dan Ehrlich <[email-masked]>
Date: Fri, 4 Sep 1992 11:05:23 -0400

>	Gintas    [email-masked]

Here is what I use.  Work just great.

	echo -n ' postgres'
	su - postgres -c /usr/postgres/bin/postmaster &

-- Dan Ehrlich

---

From: <[email-masked]>
Date: Fri, 04 Sep 92 09:43:28 PDT

> be some things "up and running" that we don't have when we

the disk on which POSTGRESHOME/data lives must be mounted.  postmaster
should be suid postgres.  other than this, there are no special
requirements.

if your rc.local file entry is of the form

	postmaster -d					>/tmp/pmlog 2>&1

debugging output from the postmaster (including the reason for its
failure) should be logged to /tmp/pmlog.

					mike