Subject: prob defining type

From: [email-masked] (Alfredo Sanchez)
Date: Wed, 8 Jan 92 13:43:50 -0800

hello,
i'm exploring the large object facilities
provided by postgres-v3r0, starting with 
the examples in the reference manual. i 
have a problem though when i try to define 
a type with variable length, since -1 is not
allowed as internallength:

% monitor hb1
Welcome to the C POSTGRES terminal monitor

Go 
*  define type humongous
(input = lo_filein, output=lo_fileout, internallength = -1) \g

Query sent to backend is "define type humongous (input = lo_filein, output=lo_fileout, internallength = -1) "
WARN:Jan  8 14:01:28:Define: non-positive lengths disallowed

was this supposed to work?

thanx in advance,

J Alfredo Sanchez H
-------------------
Hypertext Research Lab
Department of Computer Science
Texas A&M University

---

From: postarch (Postgres Mailing Archive)
Date: Wed, 08 Jan 92 15:06:44 PST

you write:
> Query sent to backend is "define type humongous (input = lo_filein, output=lo
 +_fileout, internallength = -1) "
> was this supposed to work?

If you say internallength = 64, it should work for pathnames up to 60 or 56
characters long.  The type is actually variable length.  A 
unix-file-system-like interface to large objects will hopefully be in the 
next release.

	--Case Larsen