Subject: problems with initial createdb

From: [email-masked]
Date: Thu, 1 Aug 91 23:59:43 -0700

I'm having the same problem that Bob Wedlich asked about, i.e. the sequence

setenv POSTGRESHOME ~postgres
~postgres/bin/postmaster &
~postgres/bin/createdb postgres

fails with "FATAL1: InitStdio!ValidPgVersion"

Can anyone offer any help?

Thanks in advance...

Jim Ehrman
Math & Computer Science
Mount Allison University
Sackville, NB  E0A 3C0  Canada
[email-masked]

---

From: [email-masked] (Mike Olson)
Date: Fri, 02 Aug 91 08:40:40 PDT

did initdb run successfully?  if so, the directory

	$POSTGRESHOME/data/base/template1

should exist.  if this doesn't exist, you need to kill the postmaster you
have running, then do

	% rm -rf $POSTGRESHOME/data
	% setenv POSTGRESHOME <whatever>
	% $POSTGRESHOME/bin/initdb

and restart the postmaster.  createdb should then work.  the trick is that
POSTGRESHOME needs to be set before initdb is run (which means before you
type Make install); the documentation doesn't say this.

					mike olson
					postgres research group
					uc berkeley
					[email-masked]