Subject: missing includes

From: [email-masked] (Ullrich Schoenbeck)
Date: Wed, 22 Jul 92 11:52:49 MET DST

Hi !

I want to use the built-in POSTGRES types in a C program. Therefore 
the manual says to insert the following line:

  #include <utils/builtins.h> 

After using the gcc i get the following message:

In file included from /usr/local/postgres/src/lib/H/storage/itemptr.h:21, from /usr/local/postgres/src/lib/H/access/htup.h:20, from /usr/local/postgres/src/lib/H/access/heapam.h:20, from /usr/local/postgres/src/lib/H/rules/prs2.h:20, from /usr/local/postgres/src/lib/H/rules/prs2stub.h:52, from /usr/local/postgres/src/lib/H/utils/builtins.h:20, from test.c:1:
/usr/local/postgres/src/lib/H/storage/off.h:19: machine.h: No such file or directory
In file included from /usr/local/postgres/src/lib/H/nodes/pg_lisp.h:26, from /usr/local/postgres/src/lib/H/rules/prs2.h:22, from /usr/local/postgres/src/lib/H/rules/prs2stub.h:52, from /usr/local/postgres/src/lib/H/utils/builtins.h:20, from test.c:1:
/usr/local/postgres/src/lib/H/nodes/nodes.h:24: tags.h: No such file or directory

Now my question: Where are the includes 'machine.h' and 'tags.h' ?
Are they build at installation time ?

Thanks.

Ullrich Schoenbeck
[email-masked]

---

From: postarch (Postgres Mailing Archive)
Date: Wed, 22 Jul 92 08:58:08 PDT

> Are they build at installation time ?

$POSTGRESHOME/src/port/<portname>/machine.h
$POSTGRESHOME/<objdir>/lib/H/tags.h

tags.h is built at installation time, machine.h is not.

Jeff

---

From: [email-masked]
Date: Thu, 13 Aug 92 09:14:13 -0700

Don't forget to use the following compiler flags (as documented in the
man page for define function):

 -I$POSTGRESHOME/src/lib/H
 -I$POSTGRESHOME/src/port/$PORTNAME
 -I$POSTGRESHOME/O/lib/H

Joe Hellerstein