Subject: testlibpq.pl

From: Eric P Dean <[email-masked]>
Date: Wed, 22 Feb 1995 18:26:12 CST

I am having trouble running testlibpq.pl

This is the response I get back from the program:

Destroying database pgperltest
Creating database pgperltest
Undefined subroutine "main'PQsetdb" called at /local/postgres/src/contrib/pgperl/testlibpq.pl line 27.

Here are the contents of the /local/postgres/lib directory.
->ls
libpq.a         libpq_p.a

I am sure I have missed something basic and simple.  I am using a DEC
5000/133 with Ultrix 4.3a.  Any help would be greatly appreciated.

Thank you

Eric Dean
Curator, Visual Resources Collection
College of Design, Iowa State University

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: Mike Doughney <[email-masked]>
Date: Wed, 22 Feb 1995 23:12:59 -0500

>Undefined subroutine "main'PQsetdb" called at /local/postgres/src/contrib/pgperl/testlibpq.pl line 27.
 
Are your sure testlibpq.pl is running the correct copy of perl?  This
error usually indicates that you're running plain-vanilla perl and not
pgperl. PQsetdb is the first sub call in testlibpq.pl that requires
the postgres extensions.