Subject: Problem with regular expression search on text

From: [email-masked]
Date: Thu, 09 Mar 95 17:24:34 +0100

Hi everyone,

I have some trouble with the operator '~' in usage with the built-in type 'text'.
Have a look at the following classes:

* retrieve (c1.all) \g

Query sent to backend is "retrieve (c1.all) "
-----------------------------
| id          | phone       |
-----------------------------
| 1           | 1111        |
-----------------------------
| 2           | 2222        |
-----------------------------
| 3           | 3333        |
-----------------------------

Go 
* retrieve (c2.all) \g

Query sent to backend is "retrieve (c2.all) "
-----------------------------
| id          | name        |
-----------------------------
| 1           | Tim         |
-----------------------------
| 2           | Jeff        |
-----------------------------
| 3           | Joe         |
-----------------------------

where c1.id, c1.phone and c2.id are of type int4 and c2.name is of type text.

Then the query

* retrieve (c1.all) where c1.id = c2.id and c2.name ~ "J" and c2.id = 3 \g

Query sent to backend is "retrieve (c1.all) where c1.id = c2.id and c2.name ~ "J" and 
c2.id = 3 "

returns:

FATAL: no response from backend: detected in PQexec

This error occurs on Postgres 4r2 on a DEC 3000 AXP 300LX under OSF/1 V3.0.
I also tried the above query on Postgres 4r1 on a DECstation 3100 under ULTRIX 4.3a
where everything worked fine.

Any idea what could be wrong?

Many thanks in advance,

St. Golder
[email-masked]

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: "Andrew K. Yu" <[email-masked]>
Date: Thu, 9 Mar 1995 11:50:18 -0800

> FATAL: no response from backend: detected in PQexec

there is a bug in the optimizer. start the postmaster as follow:
	postmaster -o "-x off"
and the query should run.

-andrew

---

From: [email-masked] (King Rhoton)
Date: Thu, 9 Mar 1995 16:57:19 -0500

>where everything worked fine.

Me too on multiple Suns running Solaris 2.3 and 2.4 with Postgres 4r2.  I
get this at random times doing inserts (which do include text
columns--coincidence?).  Looks like the postmaster is aborting.  In my
case, I'm using pgperl to do data loads, and I get this error usually
700-2000 inserts into the load (which contains about 4200 records).  The
data that does make it in looks fine.  Any idea what's up?  Anyone using
text columns without incident?

Thanks,

King Rhoton                                      [email-masked]