Subject: arrays of arrays

From: Dave Scott <[email-masked]>
Date: Tue, 29 Mar 1994 16:27:24 GMT

Dear Postgresers,
		  I seem to remember seeing this query before but have lost the relevant mail file.

I'm attempting to create an application which is best modelled using arrays of
arrays. I proceeded along the same lines as the example on p20 of the reference
manual but when I attempt a query similar to:

	retrieve (stuff.a[2][2])\g

I receive:	syntax error at or near "["

I'm now attempting to create an array type from scratch and would be grateful
for a brief explanation of how the "interesting stuff" is loaded into arrayp[0]
.....arrayp[array_size] (example p21)

Any help, pointers would be greatly appreciated,

Thanks in advance,

Dave.

---

From: [email-masked] (Paul M. Aoki)
Date: Tue, 29 Mar 94 11:21:58 -0800

Dave Scott <[email-masked]> writes:
> arrays.

the best answer, i think, is to get 4.2 which has real multidimensional
arrays.

up side: you get N-dim arrays that you can access through the query 
language instead of a programming language.  you also get syntax for 
array slicing and other cool stuff.

down side: no one ever documented the internal format of the new arrays,
which makes it tough to manipulate them in the backend.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki