Subject: make bug

From: [email-masked] (Hein Veenhof)
Date: Fri, 17 Jul 92 03:06:00 -0700

A simple question for the Postgres group.

I'am trying to install the new version of Postgres but ran into
some errors. My problem occurs in step 4 at page 7 of the
installation manual (postgres-setup.ps). The command "./Make
install" gives some errors. The first error is from the file 
"/var/local/postgres/src/lib/Gen/inherits.sh". In this file the
directory "/usr/postgres/tmp/" should be accessed. However
it was not created yet. 
So I made the directory by hand and ran the installation again.
Now everything seems to be ok.

My question to you is:
 Should this directory be created by me or is it an error
 in a makefile or in the tarfile. What did I do wrong ?

Hein

==============================================================
*** utils/mmgr
linking aset.c
linking mcxt.c
linking palloc.c
linking pg_malloc.c
linking portalmem.c
*** utils/sort
linking lselect.c
linking psort.c
*** utils/time
linking tqual.c
Installing in /var/local/postgres

Executing 'Make pg_id'...
compiling support/pg_id.c
linking pg_id
done
Executing 'Make everything'...
linking headers
creating inh.c
/var/local/postgres/src/lib/Gen/inherits.sh: /usr/postgres/tmp/inh.19132: No such file or directory
awk: can't open /usr/postgres/tmp/inh.19132
awk: can't open /usr/postgres/tmp/inh.19132
compiling lib/Gen/inh.c
"inh.c", line 44: warning: zero or negative array dimension
"inh.c", line 65: T_Node undefined
*** Error code 1
make: Fatal error: Command failed for target `/var/local/postgres/obj.sparc/lib/Gen/inh.o'
Current working directory /var/local/postgres
done
compiling access/common/heaptuple.c
compiling access/common/heapvalid.c
compiling access/common/indextuple.c
compiling access/common/indexvalid.c
compiling access/common/printtup.c
compiling access/common/scankey.c
compiling access/common/tupdesc.c
"tupdesc.c", line 343: T_LispList undefined
*** Error code 1
make: Fatal error: Command failed for target `/var/local/postgres/obj.sparc/access/common/tupdesc.o'
Current working directory /var/local/postgres
done
compiling support/pg_uid.c
linking pg_uid
creating dbdb.bki
creating local.bki
Removing any old bki files
compiling lib/libpq/fe-dumpdata.c
compiling lib/libpq/fe-pqstubs.c
compiling lib/libpq/fe-pqexec.c
compiling lib/libpq/portal.c
compiling lib/libpq/portalbuf.c
compiling lib/libpq/pqcomm.c
compiling lib/libpq/pqpacket.c
compiling lib/libpq/fe-pqufs.c
compiling lib/C/simplelists.c
ar rvu libpq.a ...
a - /var/local/postgres/obj.sparc/lib/libpq/fe-dumpdata.o
a - /var/local/postgres/obj.sparc/lib/libpq/fe-pqstubs.o
a - /var/local/postgres/obj.sparc/lib/libpq/fe-pqexec.o
a - /var/local/postgres/obj.sparc/lib/libpq/portal.o
a - /var/local/postgres/obj.sparc/lib/libpq/portalbuf.o
a - /var/local/postgres/obj.sparc/lib/libpq/pqcomm.o
a - /var/local/postgres/obj.sparc/lib/libpq/pqpacket.o
a - /var/local/postgres/obj.sparc/lib/libpq/fe-pqufs.o
a - /var/local/postgres/obj.sparc/lib/C/simplelists.o
ar: creating /var/local/postgres/obj.sparc/libpq.a
ranlib /var/local/postgres/obj.sparc/libpq.a
compiling support/monitor.c
linking monitor
compiling support/pg_version.c
compiling utils/init/magic.c
linking pg_version
done
checking symbolic links ....
make: Fatal error: Don't know how to make target `/var/local/postgres/obj.sparc/LIB.o'
Current working directory /var/local/postgres
done
done
File /var/local/postgres/obj.sparc/support/postgres does not exist.
Your build may have failed
or have not been run yet.
*** Error code 1
make: Fatal error: Command failed for target `install'
done
[postgres_(/usr/postgres/newconf)]:

===================================================================
Ir. Hein M. Veenhof                   email: [email-masked]
University of Twente                  phone: ++31 (0)53 894232
Information Systems                   fax  : ++31 (0)53 339605 
                                      mail : P.O. Box 217
                                             7500 AE Enschede
                                             The Netherlands               
===================================================================

---

From: [email-masked]
Date: Mon, 20 Jul 92 10:40:20 -0700

> awk: can't open /usr/postgres/tmp/inh.19132

The inherits.sh shell script has the following two lines:

	TMPDIR=${TMPDIR-/tmp}
	INHFILE=$TMPDIR/inh.$$

Normally the temporary file will be /tmp/inh.<pid> unless you already
have TMPDIR set in your environment to point someplace else...

There really isn't any reason to have the temp file be setable in the
environment, and I will update the script for future releases.

Jeff Meredith
[email-masked]