Subject: Re: A question about multi-retrieve in append

From: [email-masked] (Paul M. Aoki)
Date: Mon, 05 Dec 94 20:26:21 -0800

Biao Cheng (Sam) <[email-masked]> writes:
>  WARN:Dec  5 22:52:04:ProcedureDefine: procedure zyxset already exists with same arguments
>  What is procedure zyxset? I have no clue about that.

based on about two seconds of poking around, it looks like there's a
problem inserting two set-valued attributes in the same query.  i'm
not sure what happens if you do an append followed by a replace (for
the second set-valued attribute).
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: Biao Cheng (Sam) <[email-masked]>
Date: Mon, 5 Dec 1994 23:07:51 -0500 (EST)

Hi,
 
 I recently installed the latest/final version of postgres on
 our SUN systems running Solaris 2.3, I have no problem to run
 over all the tests.
 
 Now a class of students has been assigned a project using 
 postgres. One of the students did the following and got 
 the warning (Here, FACULTY and DEPARTMENT already defined 
 as classes beforehand):
 
 * create BELONGS ( Faculty = FACULTY, Department = DEPARTMENT ) \g
 Query sent to backend is "create BELONGS ( Faculty = FACULTY, Department = DEPARTMENT ) "
 CREATE
 
 * append BELONGS ( Faculty = "retrieve ( FACULTY.all ) 
 			where FACULTY.SSN = 123456789",
 	 Department = "retrieve ( DEPARTMENT.all ) 
 		where DEPARTMENT.DName = \\"Computer Science\\" ") \g
 Query sent to backend is "append BELONGS ( Faculty = "retrieve ( FACULTY.all )  			where FACULTY.Ssn = 123456789", 		 Department = "retrieve ( DEPARTMENT.all )  			where DEPARTMENT.DName = \"Computer Science\" ") "
 WARN:Dec  5 22:52:04:ProcedureDefine: procedure zyxset already exists with same arguments
 
 What is procedure zyxset? I have no clue about that.
 Any help is highly appreciated.
 
 Thanks,
 Biao Cheng