Subject: portal renaming?

From: Ranen Goren <[email-masked]>
Date: Mon, 9 Aug 93 14:55:22 -0700

I am developing an X/Motif interface to Postgres (will be released
in two weeks). I would like any help on this question:
Retrieve commands, which have no 'into', 'portal' or 'iportal'
keywords, go all to the 'blank' portal. When such a command
is entered, I want to open a window to view the query result.
Naturally, I would like the user to be able to open as many
windows as he/she likes, but this is impossible if all queries
go to the blank portal... What I need is some mechanism to either
rename the portal's name from 'blank' to something else, or to
copy the entire portal contents into a new portal. Or maybe
something I didn't think about?

	Thanks for your time, (you'll get a nice tool in return :)
	Ranen

---

From: [email-masked] (James Woods 61-89-895257)
Date: Mon, 9 Aug 93 21:38:02 -0700

> keywords, go all to the 'blank' portal.

I have been thinking on this also, one idea I had was to parse the query
and if there is a retrieve, insert a portal name after in.  This will have
to be refined for more complex queries, and is a bit of a hack.  But if noone
has a better idea it is probably worth a try.

James Woods
[email-masked]

---

From: [email-masked] (Jean Anderson)
Date: Thu, 12 Aug 93 14:18:53 -0700

Ranen Goren <[email-masked]> writes:
> [email-masked] (Jean Anderson) wrote:
> 
> ...
> > Does anybody know of a way to snag current transaction state from Postgres?
> ...
>         Sure... Just PQexec("begin") and parse the output message
>         to see if Postgres claims it is already in transaction mode :)
>         If you really want to make it bulletproof, I guess
>         you are inviting trouble. I have started to think about
>         pressing the user's Help button ;)

That wouldn't be bad if I could suppress the warnings that are output to
the screen. I guess my users are more nervous than yours.

 -jean