Subject: Re: vacuum

From: [email-masked] (Sibel Clark)
Date: Thu, 2 Feb 95 13:52:47 EST

Hi,

Everytime we decide to use "vacuum" command on our database, we get the following fail message.  We can't find another vacuum cleaner running anywhere.
What can be the cause of this?

Here is the message:

% vacuum dles
WARN:Feb  2 13:12:06:can't create lock file -- another vacuum cleaner running?
vacuum: database vacuum failed on dles.

Thanks,

Sibel Clark 

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: Jolly Chen <[email-masked]>
Date: Thu, 02 Feb 95 11:14:01 -0800

> vacuum: database vacuum failed on dles.

Check to see if you have a file named pg_vlock in your database
directory.  The vacuum cleaner creates it and deletes it when finished,
but perhaps you have one left over from a vacuum cleaner process that
died prematurely due to some failure.

- Jolly Chen

---

From: [email-masked]
Date: Mon, 6 Feb 1995 16:34:02 -0500 (EST)

I have a similar problem; every time I run vacuum, I get the following error:

FATAL: no response from backend: detected in PQexec

Removing the pg_vlock allows me to run the command again but I still get
the error.

The thing is that I can here the command working (i.e., the disk grinds
for 15-20 seconds even though the database is small).  It seems to me
that the problem is being caused by the vacuum command itself.

Robert

---

From: [email-masked]
Date: Mon, 6 Feb 1995 16:34:02 -0500 (EST)

Robert