Subject: delete and replace behavior

From: [email-masked] (Alfredo Sanchez)
Date: Tue, 14 Jan 92 16:02:42 -0800

hello,

when using delete and replace operations on tuples
that have been deleted or never existed, both from
the terminal monitor and C programs, i'm not
getting the expected error return code. e.g.

Go 
* replace e(name="x") from e in OBJECTS where e.oid = "9999" \g

Query sent to backend is "replace e(name="x") from e in OBJECTS where e.oid = "9999" "
REPLACE
Go 
* replace e(name="x") from e in OBJECTS where e.oid ="x" \g

Query sent to backend is "replace e(name="x") from e in OBJECTS where e.oid ="x" "
REPLACE
Go 
* 

should i do a retrieve before any of these opns to 
make sure the tuples exist?

thanx a lot,

J Alfredo Sanchez H
-------------------
Hypertext Research Lab
Department of Computer Science
Texas A&M University

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 14 Jan 92 18:29:14 PST

> make sure the tuples exist?

Because no tuples qualify in a replace or delete query isn't grounds
for returning an error status code.  If it's important to know one way
or the other then yes, do a retrieve or implement some other means
to determine this (postgres is a very versatile system).

Jeff Meredith
[email-masked]