Subject: new to postgres

From: [email-masked] (Egan F. Ford)
Date: Tue, 3 May 94 15:05:50 MDT

I've just installed postgres 4.2 on my linux box, it works great.  However I
have data that my be secure.  Can anyone on the internet with a postgres
client (e.g. monitor) access my database through post 4321?

Thanks.
-- 
Egan F. Ford
[email-masked]

===============================================================================
    To add/remove yourself from the POSTGRES mailing list: send mail with 
    the subject line ADD or DEL to "[email-masked]"

    If this fails, send mail to "[email-masked]" and
    a human will deal with it.  DO NOT post to the "postgres" mailing list.
===============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Tue, 03 May 94 16:58:12 -0700

> client (e.g. monitor) access my database through post 4321?

correct.  this is documented in various places in the reference and
user manuals; if you want network authentication we do provide code 
to support either kerberos v4 or v5beta2 (it has not been tested with
v5beta3).

you can always do the reserved port thing.  this gives you as much
protection as rlogin/rsh, which is to say, very little (since any
moron can be superuser on their own machine).

it would not be rocket science to hack in a password scheme but in 
this new, unfriendly era of widespread network sniffing, password 
schemes are questionable security at best.

general note:
i know i'm behind on message traffic.  sorry.  things are in sort of
tizzy at berkeley right now.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki