Subject: locking provisions?

From: [email-masked] (Alfredo Sanchez)
Date: Mon, 18 Nov 91 12:33:27 -0800

Are there any locking provisions in the current postgres release?
If so, what's the granularity? 

Thanks in advance,

J Alfredo Sanchez H
-------------------
Hypertext Research Lab
Department of Computer Science
Texas A&M University

---

From: postarch (Postgres Mailing Archive)
Date: Mon, 18 Nov 91 13:33:18 PST

> If so, what's the granularity? 

Yes, POSTGRES keeps a multi-level lock table for its databases and
provides two-phase locking on all user classes and non-two-phase
locking on system catalogs.  The granularity depends on what
you are doing.  Index creation and scans set page level locks while 
sequential scans (this currently includes catalog accesses) set only
relation level locks.  We currently do no tuple level locking at all.

Jeff Meredith
[email-masked]