Subject: problems with GDEP

From: [email-masked] (Peter Fuetterer)
Date: Mon, 5 Dec 1994 19:46:44 +0100

Hello,

trying to 'make' GDEP (Graphical Development Environment for Postgres)
I get:
pluto:/usr/local/GDEP 60 > make

cc -I. -I/usr/local/postgres/include -I/usr/openwin3.0/share/include -I/usr/local/motif/include -g -DXINCLUDE  -target sun4 -c  mainfile.c
"/usr/local/motif/include/Xm/VirtKeys.h", line 145: syntax error at or near variable name "shell"
"/usr/local/motif/include/Xm/VirtKeys.h", line 145: Widget declared as parameter to non-function
[[in line 145:
extern void _XmVirtKeysInitialize (Widget shell);
]]
"/usr/local/motif/include/Xm/VendorE.h", line 209: syntax error at or near variable name "shell"
"/usr/local/motif/include/Xm/VendorE.h", line 209: Widget declared as parameter to non-function
[[in line 209:
extern Boolean XmIsMotifWMRunning(Widget shell);
]]
"/usr/local/motif/include/Xm/Xm.h", line 1758: syntax error at or near type word "XColor"
"/usr/local/motif/include/Xm/Xm.h", line 1758: unknown size
...
[and so on, and so on]
...
"/usr/local/motif/include/Xm/Xm.h", line 1791: fatal error: too many errors
*** Error code 1
make: Fatal error: Command failed for target `mainfile.o'

All other trials (whith acc, CC) are fruitless.
Has anyone successful compiled this package and would be so kindly to give
me some help?

System:
SPARCstation IPX, SunOS 4.1.2, OW 3.0.

Peter

--

Peter Fuetterer					Triberg +49-7722-4749
[email-masked]

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: Stewart Allen <[email-masked]>
Date: Mon, 5 Dec 1994 20:04:25 -0500 (EST)

> make: Fatal error: Command failed for target `mainfile.o'

 I just got Motif for Linux, so...

 a) is there a working version for Linux
 b) where can I get it

 Thanks.

 -- -  Stewart Allen * [email-masked] * 617.562.5826 * FAX 617.562.0038  - -- 
         M.I.S. Manager * Open Environment Corporation * 617.562.0900          
                       25 Travis St * Boston, Ma * 02134                       
 -- - -- - -- - -- "That's my story and I'm stickin' to it"  -- - -- - -- - --