Subject: error message - HELP!

From: [email-masked] (Christine Cullen)
Date: Thu, 5 May 94 10:30:27 MDT

Please forgive me if this is an idiotic question.
My system administrator is gone and I can not get 
postmaster to run and I do not understand
this error that I am getting.  HELP!
(I am running on a SPARC2)

Error:

snake% postmaster&
[1] 566
snake% IpcMemoryAttach: shmat() failed: Permission denied

The machine was recently rebooted, could that be the problem?
Thanks in advance!!!

Chris           
________________________________________________________________                                                
Christine A. Cullen          
Visualization and Imaging
INEL                         "To sin by silence when we should             
P.O. Box 1625                 protest, makes cowards out of men."          
Idaho Falls, ID 83415                          
phone (208) 526-8346                        Ella Wheeler Wilcox
email [email-masked] 
________________________________________________________________                                                

===============================================================================
    To add/remove yourself from the POSTGRES mailing list: send mail with 
    the subject line ADD or DEL to "[email-masked]"

    If this fails, send mail to "[email-masked]" and
    a human will deal with it.  DO NOT post to the "postgres" mailing list.
===============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 05 May 94 09:53:54 -0700

> snake% IpcMemoryAttach: shmat() failed: Permission denied

most of the time, this means that someone started postmaster 
as one user, then did
	kill -9
of the postmaster (leaving shared memory segments lying around),
then tried to start postmaster as a different user.

running ipcclean as the first user usually clears this up.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki