Subject: Re: ?

From: [email-masked] (Paul M. Aoki)
Date: Mon, 17 Jan 1994 09:04:56 -0800

Marina Ignatieva <[email-masked]> writes:
> retrieve into mar (test.all,test1.all) \g
> This gives:                      I think it must give:
> ---------------------------     ------------------------
> a       b       c       d        a      b       c       d
> ---------------------------      -------------------------
> 1       2       3       4        1      2       3       4
> ---------------------------     --------------------------
> 10      20      3       4  ?      10    20      30      40
> ----------------------------    ----------------------------
> 1       2       30      40 ?
> ---------------------------
> 10      20      30      40
> ---------------------------

mar should contain the relational cross product of test and test1
(each item in test joined to each item in test1), so the answer is 
correct if you're actually retrieving the contents of mar.

> retrieve mar (test.all,test1.all)\g

this query shouldn't even parse, but "retrieve (mar.all)" or
"retrieve (test.all,test1.all)" should both give the answer above.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

---

From: Marina Ignatieva <[email-masked]>
Date: Mon, 17 Jan 94 17:03:10 -0300

Dear Gurus!
I'm using on Postgres 4.1 on SunSparc running Soloris 4.1.
I can't undestand the one moment in the "retrieve" statetment.
I create some relations:

create test(a=int4,b=int4)\g
create test1(c=int4,d=int4)\g
append test(a=1,b=2)\g
append test1(c=3,d=4)\g
append test (a=10,b=20)\g
append test1 (c=30,d=40)\g
retrieve into mar (test.all,test1.all) \g
retrieve mar (test.all,test1.all)\g

Can somebody tell me what is wrong?

Best regards, Marina Ignatieva ([email-masked])