Subject: A better way ?

From: Niranjan Perera <[email-masked]>
Date: Sun, 15 May 1994 22:36:45 -0400 (EDT)

Hi:

I have a class that keeps a list of classes. What I would like to know
is there an efficent way for me to find out if any new classes  have been
created since I last accessed the database, by comparing against my class ?

I currently use..

retrieve ( pg_class.relname )
where pg_class.relname !~ "pg_" and pg_class.relname !~ "myclass"

store the results and then run each result against "myclass"

-- Niranjan

-- 
+----------------------------------------------------------------?------+
| Niranjan Perera, 415 GSRC Bldg,CS Dept,  [email-masked]    ~~~     |
| University Of Georgia, Athens GA30602.   (706)-548-5826     ( . . )   |
+-----------------------------------------------------------ooO-(_)-Ooo-+

===============================================================================
    To add/remove yourself from the POSTGRES mailing list: send mail with 
    the subject line ADD or DEL to "[email-masked]"

    If this fails, send mail to "[email-masked]" and
    a human will deal with it.  DO NOT post to the "postgres" mailing list.
===============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Sun, 15 May 94 20:34:13 -0700

if your actual goal is *this* part:

> created since I last accessed the database

then here's a gross hack to do that:

retrieve (c.relname)
from c in pg_class, a in pg_attribute
where a.tmin > "May 10 1994"::abstime	/* your last access time goes here. */
and a.attname = "oid"			/* just because oid always exists. */
and c.oid = a.attrelid
\g

aren't time-domain addressable databases fun?  if someone comes along
and modifies your oid attribute this doesn't work quite right, but if
they do that you probably have bigger problems.. (that's why i didn't
use pg_class.tmin -- pg_class tuples are modified every time you
vacuum.)

you might have to add some typecasts to make this work right with 4.1,
i don't know.

if you need "myclass" for other reasons, this probably does want you
want, too.  this is probably what you're doing already:

retrieve into difftable (pg_class.relname)
where pg_class.relname !~ "pg_"
and pg_class.relname != "myclass"
\g
delete difftable
where difftable.relname = myclass.relname
\g
retrieve (difftable.relname)
\g

it's a pain but it should be efficient enough if you index
myclass.relname.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki