Subject: UID problem

From: [email-masked] (Thomas Kwong)
Date: Wed, 23 Nov 1994 11:44:19 -0800 (PST)

Hello!  I just installed the Postgres 4.0.1a binary for 
Linux.  It doesn't include a README file, so I am guessing
there is something wrong with my installation.

First, I got an error message "UID: Read Only" when I do
initdb.  Then I ignore this error, and do createuser.
I add a user tomkwong whose postgres uid is same as its
unix account uid.  No error.  Then I login as tomkwong,
and try to do createdb.

Then I got this message:

	tomkwong@sun$ createdb phone
	FATAL 1:Nov 23 11:25:25:User hb is not in pg_user
	/usr/postgres/bin/createdb: database creation failed on phone.

I am new to the postgres system and have no idea about what's 
going on.  Please help if you know the answer.

My installation procedure goes as follows:
	1. create user postgres (uid = 502)
	2. unpack the postgres binary tar file
	3. sh moveme.bin
	4. initdb	<-- which gave me a waring about UID
	5. postmaster &
	6. createuser tomkwong
	7. etc.

Thanks for any help, and I wish you all have a happy 
Thanksgiving!

-Tom

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: [email-masked] (Paul M. Aoki)
Date: Tue, 29 Nov 94 02:17:43 -0800

> there is something wrong with my installation.

rather than wrestling with this, i would suggest grabbing kai petzke's
port of postgres 4.2, available from (among other places):
	ftp://ftp.lysator.liu.se/pub/linux/postgres
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776