Subject: Renaming Attributes Doesn't Work

From: [email-masked] (Leif Neve)
Date: Mon, 14 Sep 92 15:09:26 -0700

The postquel RENAME command doesn't seem to work completely:

---------------------------------------------------------------
% monitor db < test.pq

Welcome to the C POSTGRES terminal monitor
 
Go 
* 
Query sent to backend is "create foobar (foo=int2) "
CREATE
Go 
* 
Query sent to backend is "append foobar (foo=3) "
APPEND 23787
Go 
* 
Query sent to backend is "retrieve (foobar.all) "
---------------
| foo         |
---------------
| 3           |
---------------
 
Go 
* 
Query sent to backend is "rename foo in foobar to newfoo "
RENAME
Go 
* 
Query sent to backend is "retrieve (foobar.all) "
---------------
| newfoo      |
---------------
| 3           |
---------------
 
Go 
* 
Query sent to backend is "retrieve (foobar.newfoo) "
WARN:Sep 14 18:02:16:no such attribute or function newfoo
-----------------------------------------------------------------

What am I doing wrong?

Leif Neve

---

From: Lance Gatrell (303) 977-2052 <[email-masked]>
Date: Tue, 15 Sep 92 07:46:23 -0700

I have also found this problem, and would add that when you do
an append to an empty class (we deleted all instances and vacuum'ed), 
the error message is:
WARN ..date.. typeid_get_relid : Invalid type - oid = 0

We down loaded 4.01/4.1 (can't remember which is the latest),
hoping that it was fixed in the newest release, but it wasn't.

Lance Gatrell