Subject: PostGres and C++

From: Mike Krus <[email-masked]>
Date: Sat, 23 Jan 93 15:22:43 -0500

Has anybody tried calling libpq functions from C++?
I haven't actually tried it yet, but it seems like creating new header files
with 'extern "C"' instead of just 'extern' should do it. Or do you have to
hide the function calls inside another C function and call that one from C++?
Or can't it be done at all?

--------
Michael Krus.					 Email : [email-masked]

Concordia University				Universite d'Orsay - Paris XI
Montreal, Canada					        Paris, France

Man is the only animal that blushes...or needs to.

---

From: [email-masked] (Tom Vijlbrief)
Date: Mon, 25 Jan 93 01:52:13 -0800

>Message  3:
>From [email-masked] Sat Jan 23 21:44:13 1993
>Return-Path: <[email-masked]>
>Received: from izfcs.izf.tno.nl by tnosoes.izf.tno.nl (4.1/SMI-4.1)
>	id AA17840; Sat, 23 Jan 93 21:44:11 +0100
>Received: from postgres.Berkeley.EDU by izfcs.izf.tno.nl (4.1/SMI-4.1)
>	id AA16944; Sat, 23 Jan 93 21:44:58 +0100
>Received: by postgres.Berkeley.EDU (5.61/1.29)
>	id AA10580; Sat, 23 Jan 93 12:26:32 -0800
>From: Mike Krus <[email-masked]>
>Subject: PostGres and C++
>To: [email-masked]
>Sender: [email-masked]
>Date: Sat, 23 Jan 93 15:22:43 -0500
>From: Mike Krus <[email-masked]>
>Message-Id:  <[email-masked]>
>Status: RO
>
>

The geo.*.tar.Z distribution of our GEO++ Postgres GIS system
(which is fully written in C++ (g++)) contains a C++
interface to Postgres. (See the files Quel.c and Quel.h)

It is available from postgres.berkeley.edu and in /pubread on
ftp.izf.tno.nl