Subject: Re: some postgres questions

From: [email-masked] (Mike Olson)
Date: Thu, 30 Jan 92 15:38:32 PST

In message <[email-masked]> you write:

> > (3) I discovered a program "xexemon", but I did not understand its
> >     relation with postgres?
> 
> It was added to the source in 1990 and never modified.  I have a feeling
> it is a relic of a forgotten age in our system.  It was not intended for
> general use.

this was added by cimarron taylor as a debugging aid during some major
hacking on the executor.  it used to dynamically display executor state
during query processing, but is no longer used (and probably couldn't
be made to work without some four-star wizardry).  we keep it around as
an example of cim's programming style.

					mike olson
					postgres research group
					uc berkeley
					[email-masked]

---

From: [email-masked]
Date: Thu, 30 Jan 92 23:01:56 PST

> an example of cim's programming style.

	Glad to know my stuff is being put to use :-).  Seriously,
	xexemon was an experiment.  I believe the way it worked was
	that postgres would popen() a connection to whatever you
	specified in the environment variable PGXEXEMONPATH and then
	feed it a simple string of characters representing the
	execution plan.   
	
	xexemon would then a little picture of the execution plan 
	using doug young's tree widget and then, while the plan executed,
	the different nodes of the tree would flash.  The program always 
	ran too fast to be useful and I never found the time to put in some
	code to control the speed of the playback.
	
	I think all you needed to do (in 1990) was set the env variable 
	to the path to xexemon.  Look at the file containing the x-hook
	functions.  It used to be in src/executor/x-debug.c or similar.

	Q: Has anyone ever made any use of my merge-join simulator
	written in awk?  Check it out if you ever find the need to
	understand the merge join code, or feel terribly bored, or both.

	Cim