Subject: Is this a bug?

From: [email-masked]
Date: Wed, 18 Nov 92 05:55:53 -0800

Hi all, 

I have been running postgres 4.0.1 for a couple of weeks 
without any problems until now. I loaded a mediumm size file 
of 132,000 records here is the create statement

create usgs_cities (name = text, state = text, elev = float4, pop = float4, loc = point)\g

then I loaded using a copy command 

copy usgs_cities from "/h/rod/postgres/usgs_cities.data"\g

So far no problems. Now I tried to build an index on the point 
by doing this 

define index usgs_cities_ind on usgs_cities using btree (loc float8_ops)\g

Well this one ran for 10 minutes and the exited with the message 

Error: No response from the backend, exiting...

I tried also to define the index first and then copy, same thing 
happened after 20 minutes. 

I have a SPARC 330 running SUNOS 4.1.1. 

Is this a bug or am I doing something wrong here?

Thanks for your help.

[email-masked]

---

From: <[email-masked]>
Date: Wed, 18 Nov 92 10:16:47 PST

In message <[email-masked]> you write:

> create usgs_cities (name = text, state = text, elev = float4, pop = float4, l
  +oc = point)\g
> Error: No response from the backend, exiting...

loc is of type point, and you're trying to index it as if it were of
type float8.  this won't work.  the naming convention for operator classes
is that <type>_ops are used to index values of type <type>.

there's no operator class that will index point values in btrees in the
distributed system.
					mike