Subject: no subject (file transmission)

From: Kent Archie <[email-masked]>
Date: Mon, 9 Mar 92 16:53:29 CST

I am building Postgres 3.1 on an NCR 486 box using SVR4 and the 
MetaWare C compiler. I get a number of problems, a couple of which
are shown below. It appears the a shell program called 'insert'
uses sed to convert the 'class' notation in the .c files
to something that standard C can understand. In this case,
it appears to be incomprehensible to the C compiler. I tried using
gcc 1.40 and got further but with different error messages. I
didn't try this very hard so I don't remember the messages.
Any ideas? Has anybody done this?

$ Make install
hostname: Command not found.
ports available are:  dec decsprite seq sparc sun sunos4 svr4 ultrix4
please choose a port: svr4

Object directory name (obj.svr4) ? 
[ Assorted mkdirs and links removed ]

creating inh.c
compiling lib/Gen/inh.c
MetaWare High C Compiler R2.3x  Serial 1-NCR-799999.
(c) Copyright 1987-91, MetaWare Incorporated
E "/usr2/postgres/src/lib/H/nodes/primnodes.h",L176/C2: inherits: Type "int(Node)" is not valid for a struct member.

[ Similar messages deleted]

E "/usr2/postgres/src/lib/H/storage/part.h",L36/C21:    (syntactic)  unexpected symbol:'<IDENTIFIER>':PageSize
REPAIR:   '_Class' was inserted before '<IDENTIFIER>':PageSize@"/usr2/postgres/src/lib/H/storage/part.h",L36/C21

[Also many more similar messages deleted]
**kent
Kent Archie
[email-masked]

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 10 Mar 92 14:31:35 PST

> Any ideas? Has anybody done this?

You might try using gcc with -traditional (the only way postgres will
compile under gcc).

Jeff Meredith
[email-masked]