Subject: Question about attributes of CLASS

From: [email-masked] (Final Year Project)
Date: Mon, 7 Mar 94 11:39:37 +0800

Dear Sir/Madam,
What are the restrictions on the name of the attributes of Class ?
I just found the syntax error if the name of the attributes was not
started with alphabet. Are there any restrictions ? e.g. length of
the name , etc. Thanks.
Rgds,
Martha

---

From: [email-masked] (Paul M. Aoki)
Date: Sun, 06 Mar 94 21:12:08 -0800

> started with alphabet. Are there any restrictions ? e.g. length of

the lex syntax for identifiers (per the code -- always the most reliable 
source of info :-) is:

digit           [0-9]
letter          [_A-Za-z]
letter_or_digit [_A-Za-z0-9]

identifier      {letter}{letter_or_digit}*

this is true for all identifiers, including user names (which, as
"t-ishii" has discovered, is a botch on my part :-/)
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki