Subject: X interface to postgres

From: Ranen Goren <[email-masked]>
Date: Wed, 9 Dec 92 09:02:14 -0800

Hello,
	The Hebrew University of Jersulsem (CS dep.) is interested
	in developing an X interface to postgres. The planned
	interface is based on Motif. I would like to know if there
	had been any step in that direction, so I don't work for
	nothing. I'd appreciate it very much if you sent me info
	about such projects.

	Thanks in advance,
	Ranen

--
Ranen Goren ([email-masked])

CS department

---

From: [email-masked] (Krys Kochut)
Date: Thu, 10 Dec 92 10:29:24 -0800

> From @pollux.cs.uga.edu:[email-masked] Wed Dec  9 12:14:01 1992
> Date: Wed, 9 Dec 92 09:02:14 -0800
> From: Ranen Goren <[email-masked]>
> Subject: X interface to postgres
> To: [email-masked]
> Sender: [email-masked]
> Content-Length: 401
> 
> Hello,

Hi,

one of my graduate students, Ruben Robles, implemented an interface to
Postgres which works under OpenLook.  It is a "drag and drop"
interface providing queries (based on graphic expression tree
construction), schema modification, and database updates, with schema
browsing at any point in time during querying, updating, etc.  Also, all
of the functions of the Postgres Monitor are preserved (but with "paste-
and-cut goodies").  The whole thing is written in C, Xview, Slingshot
Xview extensions, and some use of DevGuide (in all approx. 17-18k
lines of code).

Over the Holidays I will try to check if the whole thing works with
OpenLook 3.0 and the newest release of Postgres (it was developed
under OpenLook 2.0 and Postgres 3.1) and if it looks ok then I will
put it for anonymous ftp pickup.  Also, currently there is no user
manual other than Ruben's MS thesis.

Krys J. Kochut

Assistant Professor
Computer Science
University of Geogria

[email-masked]
706-542-3441

---

From: Ranen Goren <[email-masked]>
Date: Fri, 11 Dec 92 15:30:01 +0200

> manual other than Ruben's MS thesis.

Hi,
	The description you've provided sounds promising enough
	so I almost cannot wait to see the implementation itself...
	Thank you very much for your reply, and I am looking forward
	to the package announcment!

	Ranen