Subject: temp-XXXXX files

From: [email-masked] (Banco de Dados Ambiental)
Date: Tue, 7 Apr 92 11:00:33 -0700

How are the temp-xxxx files created under a database directory managed by postgr
   es? when my application crashes many of it is left on /data/base/<database> d
   irectory. I am getting messages like this:

...
WARN:Apr  3 10:58:31:cannot open       temp_40065

Postgres Returns An Error - Aborting Program

XView warning: Notifier error: Unknown client
XView warning: Notifier error: Unknown client
XView warning: Notifier error: Unknown client
XView warning: Notifier error: Unknown client
XView warning: Notifier error: Unknown client
XView warning: Notifier error: Unknown client
...

Also many ".nfsXXXX" files are generated and left there.

---

From: postarch (Postgres Mailing Archive)
Date: Fri, 10 Apr 92 09:06:51 PDT

you write:
>How are the temp-xxxx files created under a database directory managed by pos
 tgres? when my application crashes many of it is left on /data/base/<database

> Postgres Returns An Error - Aborting Program

If the backend creates a temporary relation and crashes before the current
xact can commit then the temporary relation must be removed by hand.  The
reason is that we don't assume we can overwrite existing files under the
data directory.

> Also many ".nfsXXXX" files are generated and left there.

I don't know what these are.

Jeff Meredith
[email-masked]