Subject: counting combinations (2)

From: Peter van Oosterom <[email-masked]>
Date: Thu, 18 Mar 93 10:51:52 MET

Dear Postgres-group,

A couple of days ago, I posed the following question:

> I want to count combinations of attribute values.
> For example in relation X:
>    a    b
>    3    6
>    2    4
>    3    8
> I would like to obtain the following result Y:
>    a    number_of_b
>    3    2
>    2    1
> Is this possible in Postquel?

Until now I got one reply for solving this problem in SQL:
     select a, count(distinct b)
     from X
     group by a

Is something like this also possible in Postquel

Kind regards, Peter van Oosterom.

---

From: <[email-masked]>
Date: Thu, 18 Mar 93 08:59:46 PST

> > Is this possible in Postquel?

hi peter,

what you want to do isn't supported in postquel; we don't support
group by or correlated subqueries.
					mike