Subject: A strange Postgres Story

From: [email-masked] (Djamar Bennouar)
Date: Tue, 15 Oct 91 19:49:06 -0700

I would like to Know what is the  exact story between Postgres and
the name DesDbCL
This morning all seem to work  in a good maner. But this night
arised a strange problem. In the following many query will show what
happened:

----This is the begining of the Postgres-DesDbCl Story -------
BENNOUAR[32]monitor
Welcome to the C POSTGRES terminal monitor

Go
* create DesDbCl(name=char16)\g

Query sent to backend is "create DesDbCl(name=char16)"
WARN:Oct 15 22:41:43:cannot open          DesDbCl

Go
* destroy DesDbCl \g

Query sent to backend is "destroy DesDbCl "
NOTICE:Oct 15 22:42:04:RelationBuildDesc: (relation name DesDbCl) nonexistent

WARN:Oct 15 22:42:04:Relation DesDbCl Does Not Exist!

Go
* create DesDb(name = char16)\g

Query sent to backend is "create DesDb(name = char16)"
WARN:Oct 15 22:42:19:amcreate: DesDb relation already exists

Go
* destroy DesDb
\g

Query sent to backend is "destroy DesDb "
DESTROY
Go
* create DesDb(name=char16)\g

Query sent to backend is "create DesDb(name=char16)"
CREATE
Go
* create DesDbCl(name=char16) \g

Query sent to backend is "create DesDbCl(name=char16) "
WARN:Oct 15 22:43:33:cannot open          DesDbCl

Go
* create DesDbClass(name = char16)\g

Query sent to backend is "create DesDbClass(name = char16)"
CREATE
Go
*
------------- The End ------
I would appreciate any help to find the source of this problem.

Djamal BENNOUAR
Ecole Polytechnique at Montreal

---

From: [email-masked] (Surendar Chandra)
Date: Wed, 16 Oct 91 0:18:17 EDT

In your last mail, Djamar Bennouar, you write...
> I would like to Know what is the  exact story between Postgres and

The same is happening to us here. The name of our offending database is
surendar . We tried to destroy all databases and recreate them and still it
will not accept the name surendar. It will accept any other name.I looked for 
any file or directory named surendar anywhere in the system and could find 
none. Strange..

Thnx,
surendar

---

From: Rod Rebello -- CAD Development <rrebello@titan>
Date: Tue, 15 Oct 1991 22:21:36 -0700

..
> ----This is the begining of the Postgres-DesDbCl Story -------

Shouldn't you give the name of the database that you want to
work with, e.g., "monitor mydatabase"?

> WARN:Oct 15 22:41:43:cannot open          DesDbCl

Again, this is probably because there is no existing database in
which to create the relation.  You should use the "createdb" unix
command first (unless you just forgot to give an existing DB name
on the monitor command line).  

I suspect the rest of your problems are related to the missing 
DB.

-------------
Rod Rebello
[email-masked]
Microchip Technology Inc., Chandler, AZ

---

From: [email-masked]
Date: Thu, 17 Oct 91 15:46:27 PDT

The following is a known bug in 3.0:

begin                 /* start a transaction */
create foo (a = int4)
abort                 /* abort a transaction - file _should_ go away */
create foo (a = int4) /* Postgres will complain and abort the xact */

If you start a transaction during which you created a class, and you abort
it or Postgres crashes before that xact commits, you should delete the class
file in

~postgres/data/base/<dbname>/<classname>

by hand with rm.  (Note that if you are not the "postgres" user, you cannot
do this.)

	Greg Kemnitz
	[email-masked]