Subject: Truncation

From: [email-masked] (Suresh Srinivasan)
Date: Mon, 28 Feb 94 09:05:17 EST

Hello,

My newbie question should be an easy one to answer.
Does POSTGRES support trucation, i.e., can I do "foo*"
(or foo:) and match all index entries prefixed
by the string "foo"?

In other words, given:

  create word_class (word=text, ui=int4) \g
  define index word_index on word_class using btree (word text_ops) \g

and appropriate data, can I do:

  retrieve (w.ui) from w in word_class where w.word = "foo*" \g

Thanks,

--Suresh ([email-masked])

---

From: Marcel Kornacker <[email-masked]>
Date: Mon, 28 Feb 1994 11:12:41 -0800 (PST)

Try 
	retrieve (w.ui) from w in word_class where w.word >= "foo"