Subject: multiple types of instances from a retrieve command

From: Chris Bunting <[email-masked]>
Date: Wed, 4 Mar 92 15:59:31 -0800

In the version 3 reference manual page 87. It is written
	"A single retrieve command can return multiple types of instances.
	 This can happen if a POSTGRES function is executed in the evaluation
	 of a query or if the query returns multiple instance types from an
	 inheritance heirachy."

Given the following

	create C1 ( a1 = int4, a2 = int4 ) 
	
	create C2 ( a3 = int4 ) inherits (C1) 

then I would expect the the quote above implies that the query

	retrieve (C.all) from C in C1* \g

would retrieve all of the instance in C1 and all of the instances in C2, which are of different types.

However I am getting all of the instnaces in C1 and only the C1 part of all the instance in C2.

Therefore the instance types are all the same.

My question is therefore.

In what situations will a "query returns multiple instance types from an
inheritance heirachy?"

Why does my example not return multiple instance types?

Any help would be appreciated.

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 10 Mar 92 14:27:22 PST

>In what situations will a "query returns multiple instance types from an

There isn't one.  You always get what you ask for in the target list.
The manual is wrong.  You can get multiple instance types when your
queries cause rules to fire, but these will be returned in an asynchronous
portal (coming soon to a dbms near you).

Jeff Meredith
[email-masked]