Subject: postgres data directories

From: [email-masked] (James Woods 61-89-895257)
Date: Sun, 8 Aug 93 16:42:07 -0700

I was browsing through the postgres data directories and have noticed that a couple of the directories have a whole stack of temp_* files in it.  From general experience any file with temp in it is usually something that is deleted when it has been used.  But these files are 1 - 2 months old.  In one of my databases these files are taking up about 2.5 meg of disk space so I would be interested in knowing if these files should be there.

Oh and while I'm here in the same databases, at about the same age there are
a whole load of empty pg_psort* files, If this is of any significance (being
empty they don't really bother me).

James Woods
[email-masked]

---

From: [email-masked] (Paul M. Aoki)
Date: Sun, 08 Aug 93 19:15:03 -0700

[email-masked] (James Woods 61-89-895257) writes:
> I was browsing through the postgres data directories and have noticed that a 
couple of the directories have a whole stack of temp_* files in it.  From gener
al experience any file with temp in it is usually something that is deleted whe
n it has been used.  But these files are 1 - 2 months old.  In one of my databa
ses these files are taking up about 2.5 meg of disk space so I would be interes
ted in knowing if these files should be there.
> empty they don't really bother me).

the sortmerge routine evidently has a bug in it such that it *sometimes*
dumps core halfway through a largish join.  (this is the problem that 
bart maessen reported.)

if they're >1 month old, i doubt you have any servers running that
would have them open :-)  nuke 'em.
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki