Subject: problem in installation

From: [email-masked] (rakesh chandra)
Date: Thu, 5 Dec 91 22:38:28 -0800

We have problems in installing postgress; every thing seems to compile
properly, but then the initial database is not created and postmaster will
not work. Enclosed below is the script.

% Make install
ports available are:  dec decsprite seq sparc sun sunos4 ultrix4
please choose a port: sparc

Object directory name (obj.sparc) ? 
creating object directory obj.sparc
creating obj.sparc/access
creating obj.sparc/bootstrap
creating obj.sparc/main
creating obj.sparc/parser

.........

compiling utils/adt/geo-selfuncs.c
compiling utils/adt/int.c
compiling utils/adt/name.c
compiling utils/adt/numutils.c
compiling utils/adt/oid.c
compiling utils/adt/misc.c
linking postgres
linking postgres completed
done
creating dbdb.bki
creating local.bki
compiling lib/libpq/fe-dumpdata.c
compiling lib/libpq/fe-pqstubs.c
compiling lib/libpq/fe-pqexec.c
ar rvu libpq.a ...
a - /home/postgres/obj.sparc/lib/libpq/fe-dumpdata.o
a - /home/postgres/obj.sparc/lib/libpq/fe-pqstubs.o
a - /home/postgres/obj.sparc/lib/libpq/fe-pqexec.o
a - /home/postgres/obj.sparc/lib/libpq/portal.o
a - /home/postgres/obj.sparc/lib/libpq/portalbuf.o
a - /home/postgres/obj.sparc/lib/libpq/pqcomm.o
a - /home/postgres/obj.sparc/lib/libpq/pqpacket.o
ar: creating /home/postgres/obj.sparc/libpq.a
ranlib /home/postgres/obj.sparc/libpq.a
compiling support/monitor.c
linking monitor
sed'ing vacuum
compiling support/pg_version.c
linking pg_version
done
checking symbolic links ....
compiling support/stubs.c
compiling support/postmaster.c
linking postmaster
done
done
creating /home/postgres/bin
moving file /home/postgres/obj.sparc/support/postgres
moving file /home/postgres/obj.sparc/support/postmaster
moving file /home/postgres/obj.sparc/support/pg_version
moving file /home/postgres/obj.sparc/support/monitor
moving file /home/postgres/obj.sparc/support/pg_id
moving file /home/postgres/src/scripts/createdb
moving file /home/postgres/src/scripts/createdb.sh
moving file /home/postgres/src/scripts/destroydb
moving file /home/postgres/src/scripts/initdb
moving file /home/postgres/src/scripts/vacuum
moving file /home/postgres/src/scripts/createuser
moving file /home/postgres/src/scripts/destroyuser
creating file /home/postgres/bin/ipcclean
creating /home/postgres/files
Moving /home/postgres/obj.sparc/support/local.bki to /home/postgres/files/local1_template1.bki
Moving /home/postgres/obj.sparc/support/dbdb.bki to /home/postgres/files/global1.bki
Compiling demo files...
cc   -I../src/lib/H -c circle.c
cc   -I../src/lib/H -c boxarea.c
cc   -I../src/lib/H -c overpaid.c
producing the setup script set-up-1.pq
producing the setup script wisc.setup.pq
Creating video demo objects...
done

Initializing template database...
semget: Invalid argument
initdb: could not create template database
initdb: cleaning up.
Installation complete.
done

/rakesh
[email-masked]

---

From: postarch (Postgres Mailing Archive)
Date: Fri, 06 Dec 91 12:42:22 PST

> not work. Enclosed below is the script.

...stuff deleted...

> initdb: could not create template database

I think that your kernel may not be configured correctly.
When running on a sparc (which has a TAS instruction) there is exactly
one semphore created for each backend process.  Normally this is not very 
much to ask of your os.  What error does the postmaster fail with?  
Is it failing to allocate the required shared memory?

Jeff Meredith
[email-masked]