Subject: arrays

From: [email-masked] (super dave?)
Date: Thu, 19 Aug 1993 10:49:18 -0500 (EDT)

I need to create an array of structures, but the doc I have doesn't have a lot
of clear-cut examples. Basically, I need something like:

structure: (x = int4, y = text, etc)

and then I need an array of that structure. Any help would be appreciated. 
Also, is it possible to create an array of classes?

---

From: [email-masked] (Paul M. Aoki)
Date: Fri, 20 Aug 93 19:57:17 -0700

> structure: (x = int4, y = text, etc)

define an adt (base type) containing the fields you want.
then define an array of them.  unfortunately you will have
to write routines to extract the structure fields.  the 
reason for this is that the answer to this question...

> Also, is it possible to create an array of classes?

...is no.  arrays can only be on adts (base types).
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki