Subject: learners request

From: Ingo Jessel <[email-masked]>
Date: 17 Nov 94 14:14:32+0100

Please Help,

I just installed postgres on a sparcstation. The installation itself worked
without problems.
Then I created a user with permission to create a new database.

The problem:
I can create a new database as super-user postgres.
When I try the same thing as the created user, I get following message -

--------------------------
 command% createdb foo
 Creating database 'foo' . . .

 E_DU3190_BAD_LKINIT
   Couldn't initialize the locking system for this process.
        Status returned was,   0x00000001.
        Please insure that the process is properly installed and that
             you have sufficient privilege and system resources to invoke it.
 Creation of database 'foo' abnormally terminated.
--------------------------

what is wrong?
where can I find explanations about error messages like 'E_DU3190_BAD_LKINIT' ?
where can I find infos about the locking system?

Any note would be great.

regards, Ingo

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 17 Nov 94 16:56:03 -0800

>  Creation of database 'foo' abnormally terminated.

i am willing to bet that you have RTI/ASK/CA-INGRES installed
somewhere and have that location ahead of the POSTGRES binaries in
your path.. commercial INGRES also has a command called "createdb"
(perhaps even more importantly, they also have a command called
"destroydb" ;-)
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776