Subject: Re: restrict the no. of record retrieved

From: <[email-masked]>
Date: Thu, 18 Mar 93 09:01:29 PST

In message <[email-masked]> you write:

> I am using the postgres 4.0.1 on Sun Sparc. I wonder if there is a way
> to restrict the no. of record retrieved from a table. If the no. of
> record retrieved is huge, we will encounter the buffer overflow problem.

see the manual for information on portals.  you can do

	retrieve portal p (foo.all)
	fetch 10 in p
	...

					mike

---

From: [email-masked]
Date: Thu, 18 Mar 93 19:00:24 -0800

I will very appreciate it if you can show me the solution.

Thank.

Alan S. H. Lam
Department of Information Engineering, CUHK, Hong Kong
E-mail: [email-masked] 
Tel: (852) 609 7975 Fax: (852) 603 5032