Subject: key in postgres

From: Biao Cheng (Sam) <[email-masked]>
Date: Sun, 11 Dec 1994 23:12:17 -0500 (EST)

hi
 	i got such error msg in create a class with key
 for example:
 
 Go
 * create test (a=int4) key (a) \g

 Query sent to backend is "create test (a=int4) key (a) "
 WARN:Dec  9 23:04:36:RelationCreate: KEY not yet supported
  
 Do you have any idea about why the key is not supported?

 Thanks,
 Biao Cheng

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: Biao Cheng (Sam) <[email-masked]>
Date: Mon, 12 Dec 1994 09:28:33 -0500 (EST)

>  Do you have any idea about why the key is not supported?

I just read the man page of create, in the BUG section, it said,
"The key clause is not implemented in the version 4.2". So I can
answer my own question above. Now my question is: Has anyone
done any extension work on this?

Thanks,
Biao Cheng