Subject: Re: remove operator error

From: [email-masked] (Paul M. Aoki)
Date: Thu, 25 Mar 1993 21:06:03 -0800

[email-masked] (James Woods 61-89-895256) writes:
> There is an error in the backend of postgres 4.1 if you attempt to remove an
> operator that doesn't exist.  Following is a copy of a monitor session after
> all the other requirements for the circle object have been defined.

oopsie.  trying to avoid the dreaded "walking off the end of the char16"
bug, i made a typo and introduced another one.  blech.

thanks for the bug report.

apply the following diff and recompile:
95c95
< 			elog(WARN, "RemoveOperator: operator \"%-*s\" taking \"-*%s\" and \"%-*s\" does not exist",
---
> 			elog(WARN, "RemoveOperator: operator \"%-*s\" taking \"%-*s\" and \"%-*s\" does not exist",
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 25 Mar 1993 21:30:49 -0800

[email-masked] (James Woods 61-89-895256) writes:
> Could you please give me more information here, including which file this is
> supposed to be in and whether we have to make any changes to it.  Sorry to
> bother you again but none of us here could work out what you meant here.

whoops, cut off the filename from the diff output.  this isn't my day.
it's src/backend/commands/remove.c

"apply the diff" means edit line 95 of remove.c and, where it says
	-*%s
change it to read
	%-*s
--
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki