Subject: DEFINE INDEX BUG?

From: [email-masked] (paul friberg)
Date: Tue, 1 Dec 92 07:37:36 -0800

Under BUGS in the man page for DEFINE INDEX is the 
following statement:

"Indices may only be defined on a single key"

What is implied here? I understand that keys are 
not implemented in the current version of postgres(4.0.1).
Anybody have any ideas what is meant by this
bug listing?

Cheers,

Paul Friberg (Lamont-Doherty Geological Observatory of CU)

---

From: <[email-masked]>
Date: Tue, 01 Dec 92 09:59:01 PST

> Anybody have any ideas what is meant by this

primary keys are not supported.  'index key' refers to the attribute that's
used to control ordering in the index.  the bug is that you can define
an index on (emp.salary), but not on (emp.salary, emp.age), which would order
employees by salary, and within a single salary by age.

					mike