Subject: Classes belonging to a given Database

From: [email-masked] (Fernando Manuel Vasconcelos)
Date: Tue, 31 Mar 92 13:28:18 -0800

Is it possible to know the name of all classes belonging to a given database ?

My problem is that I can't distinguish the classes I create from the 
"administration" ones .

Fernando

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 31 Mar 92 18:07:50 PST

you write:

> Is it possible to know the name of all classes belonging to a given database?

> My problem is that I can't distinguish the classes I create from the 

To get all user defined class names try:

	retrieve (pg_class.relname)
	where pg_class.relname !~ "pg_.*"

query-able system catalogs will begin with "pg_"

Jeff Meredith
[email-masked]

---

From: postarch (Postgres Mailing Archive)
Date: Tue, 31 Mar 92 18:07:50 PST

Jeff Meredith