Subject: README.FIRST .. PROBLEM FOUND!!

From: [email-masked] (Bruce Taneja.)
Date: Sat, 2 Jul 1994 15:04:26 -0400 (EDT)

Hi,
About my last email concerning postgres not being able to accept 
strings of > 100 chars ................

OK, I think I got a more narrow view on the problem ::

It has either some thing to do with the system buffer or with 
postgres buffer ..

OBSERVATION 1:

----------------------------
tamarack%  monitor ndb

... /* did a lot of appends */

* append ntable(emp="(2,JF,((k1,1,(c1,c2)),(k2,2,(c3,c4)),(k3,3,(c5,c6,c7))),(),
())"::emp_DT) \g

Query sent to backend is "append ntable(emp="(2,JF,((k1,1,(c1,c2)),(k2,2,(c3,c4)
),(k3,3,(c5,c6,c7))),(),())"::emp_DT) "
Error: No response from the backend, exiting...

tamarack% !!
monitor ndb
Welcome to the C POSTGRES terminal monitor

Go
* append ntable(emp="(2,JF,((k1,1,(c1,c2)),(k2,2,(c3,c4)),(k3,3,(c5,c6,c7))),(),
())"::emp_DT) \g

Query sent to backend is "append ntable(emp="(2,JF,((k1,1,(c1,c2)),(k2,2,(c3,c4)
),(k3,3,(c5,c6,c7))),(),())"::emp_DT) "
APPEND 155776
Go
++++++++++++++++++++++++++++++++++++++++

So even though postgres threw me out on my last append, it happily
accepted the same append right away on restarting the monitor .. 

++++++++++++++++++++++++++++++++++

OBSERVATION 2:

On a really long append , the monitor (or is it the system) accepts slightly
over a 100 chars and then stops accepting the input .. & starts beeping at
you on any key stroke .. 

this happending on a number of occassions when I tried to input the string

* append ntable (emp="(2343,Kids Lover,((kid1 Lover,1,(c1,c2,c3)),(kid2 Lover,5,()),(kid3 Lover,7,(segaVideo,MegaVideo,C++)),(kid4 Lover,6,(c4,c5)),(kid5 Lover,15,(C,Math,Phy,Geomech.,Bio))),((C++,56),(Pascal,6),(LaTeX,7),(Cobol,5)),(345-4344,23LOVER,234532234))"::emp_DT) \g

I was unable to even enter the whole string !

-----------------------------------------------------

Can you see whats going on ??

thanks ..
Bruce

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: "Andrew K. Yu" <[email-masked]>
Date: Sat, 2 Jul 1994 13:37:03 -0700

Bruce asked me to forward this to you. Here it is:

> From: [email-masked] (Bruce Taneja.)
> Subject: OK, I got it ..
> To: [email-masked]
> Date: Sat, 2 Jul 1994 15:26:19 -0400 (EDT)
> 
> Alright folks, 
> 
> ignore my last mail .. I just figured out
> the solution for my second observation .. it was the system
> buffer (sparc 10, sun os 4.3.1) which was the root of problem .. 
> 
> As soon as I broke up my append statement with a couple of '\n's
> the system stopped wailing and postgres took it happily .. 
> 
> 
> My first observation however is still unsolved , why does
> a series of appends in a single session cause monitor to crash ??
> 
> Bruce
>