Subject: IpcMemoryAttach

From: [email-masked] (Bernd Froehlich)
Date: Thu, 4 Aug 94 12:07:53 +0200

I got some strange behavior from Postgres.
Last week I tried to start the postmaster and got the following error message:

edvs6% postmaster &
[1] 3284
edvs6% IpcMemoryAttach: shmat() failed: Permission denied

The funny thing is: when I was logged in under my own name I could start the postmaster, only as postgres user it was not possible to get it running.
Even installing postgres again did not help.
Now I experimented a little and found out that when I run newbki and specify my own login then I can start the postmaster as user postgres and get the error when I try to start it under my login.
Since the manuel states that you always should use newbki with the postgres login I am not sure what to do. How can I get things straight???
P.S. I am working on a SUN Sparc station

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: [email-masked] (Paul M. Aoki)
Date: Thu, 04 Aug 94 12:09:58 -0700

> edvs6% IpcMemoryAttach: shmat() failed: Permission denied

this usually means you have a shared memory segment allocated as
the "wrong" user (meaning a different user than the user you now
want to start postgres as).  this is generally a symptom of killing
off postmasters with "kill -9" and is the main reason why the manual 
says not to use "kill -9".

use "ipcs" to see what segments are there and use "ipcclean" (as
the user who owns the segments).
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776