Subject: Aggregates don't work with "postmaster -d"

From: [email-masked] (Leif Neve)
Date: Tue, 2 Feb 93 08:42:43 -0800

Folks,

When I run the postmaster with the "-d" flag, aggregates
no longer work. Queries involving aggregates just hang.

The debug output from the postmaster says:

  started '/usr/local/postgres/bin/postgres' for 'neve' on 'srw' (4) pid (16933)
  In reaper
  In CleanUpProc - Backend with pid 16933 exited with status 11

When I run the same query after starting up the postmaster without
the -d flag, everything works fine. I've tried a number of aggregate
functions (e.g. int2max, int4max, int2ave, int4ave) and they all fail.

Anyone seen this problem?

Leif Neve

---

From: [email-masked]
Date: Tue, 02 Feb 93 09:22:48 -0800

------- Blind-Carbon-Copy

To: [email-masked] (Leif Neve)
Subject: Re: Aggregates don't work with "postmaster -d" 
In-reply-to: Your message of Tue, 2 Feb 93 08:42:43 -0800 
	     <[email-masked]> 
Date: Tue, 02 Feb 93 09:22:48 -0800
From: aoki
X-Mts: smtp

i've cleaned up the agg code somewhat.  i've run aggs with "postmaster -d"
in our development tree, so i think it's safe to say that this will be 
solved when you install 4.1.
- --
  Paul M. Aoki  |  CS Div., Dept. of EECS, UCB  |  [email-masked]
                |  Berkeley, CA 94720           |  ...!uunet!ucbvax!aoki

------- End of Blind-Carbon-Copy