Subject: postquel function definition

From: [email-masked] (Banco de Dados Ambiental)
Date: Thu, 25 Jul 91 11:14:38 -0700

What's wrong with my first postquel function:
Go
* define postquel function ILExist (int2, abstime, abstime, abstime, float4, flo
   at4, float4, float4, int2, float4, float4) returns InfoLayer is retrieve port
   al dbportal(InfoLayer.id, InfoLayer.contents) where
        InfoLayer.category=$1   and
        InfoLayer.inittime=$2   and
        InfoLayer.time=$3       and
        InfoLayer.reftime=$4    and
        InfoLayer.geoareax1=$5  and
        InfoLayer.geoareay1=$6  and
        InfoLayer.geoareax2=$7  and
        InfoLayer.geoareay2=$8  and
        InfoLayer.projection=$9 and
        InfoLayer.resx=$10      and
        InfoLayer.resy=$11\g

Query sent to backend is "define postquel function ILExist (int2, abstime, absti
   me, abstime, float4, float4, float4, float4, int2, float4, float4) returns In
   foLayer is retrieve portal dbportal(InfoLayer.id, InfoLayer.contents) where
         InfoLayer.category=$1   and     InfoLayer.inittime=$2   and     InfoLay
   er.time=$3       and     InfoLayer.reftime=$4    and     InfoLayer.geoareax1=
   $5  and     InfoLayer.geoareay1=$6  and     InfoLayer.geoareax2=$7  and     I
   nfoLayer.geoareay2=$8  and     InfoLayer.projection=$9 and     InfoLayer.resx
   =$10      and     InfoLayer.resy=$11"
WARN:Jul 25 14:59:21:parser: syntax error at or near ","

        Thanks in advance for any help!!!

---

From: [email-masked] (Mike Olson)
Date: Thu, 25 Jul 91 11:25:27 PDT

> * define postquel function ILExist (int2, abstime, ...
> 	...

postquel functions take exactly one parameter of type RELATION, and the
$x notation for parameters is entirely unsupported.  we have high hopes
of making these two restrictions vanish in the near future.  stay close
to your computer for details as they become available.

					mike olson
					postgres research group
					uc berkeley
					[email-masked]