Subject: Access via OID

From: [email-masked] (J.Plewe)
Date: Wed, 29 Jun 94 15:37:31 +0200

I have a question where I think to know the answer, but I 
want to make sure:

Is the access with an explicit oid, e.g.

  retrieve (circles.all) where circles.oid = 123456::oid

faster than a selection with any other attribute??

I think no, but e.g. for Oracle I know that having a rowid
lets you access the tuple VERY fast, because file,block,... 
are encoded in the rowid, so Oracle does not have to search.

Is there a similar mechanism for Postgres?

- Joerg

*********************************************************************
Dipl. Phys. Joerg Plewe               [email-masked]
MPI fuer molekulare Physiologie
Rheinlanddamm 201
44139 Dortmund
Germany                               +49 (0)231 1206 384
*********************************************************************

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: "Andrew K. Yu" <[email-masked]>
Date: Wed, 29 Jun 1994 11:22:33 -0700

> Is there a similar mechanism for Postgres?
	
The oid in postgres has no encoding at all.

-andrew