Subject: arrays, database security

From: [email-masked] (Gregory Klein)
Date: Tue, 21 Apr 92 14:54:54 -0700

Does Postgres vers. 3.1 support fixed and variable length arrays? I try to
use the following:

create testrec (ival=int4, fval1 = float4[10], fval2=float4[]) \g

and get the following message when I try to append:

append testrec (ival=5, fval1[0]=3.2) \g
WARN: parser: syntax error at or near "["

append testrec (ival=6, fval2[0]=1.1) \g
WARN: parser: syntax error at or near "["

Does anyone know what I might be doing wrong?

One other question, is Postgres able to grant specific users read or write
access to a given database?  I can't seem to find a way to do this.

Thanks for any help,

Greg Klein

---

From: postarch (Postgres Mailing Archive)
Date: Wed, 29 Apr 92 16:25:21 PDT

> Does Postgres vers. 3.1 support fixed and variable length arrays? I try to

Yes, although there are some bugs.

> Does anyone know what I might be doing wrong?

try:

	append testrec (ival=5, fval1 = "{3.2}")
	append testrec (ival=6, fval2 = "{1.1}")

You have to specify the entire array as a constant.

> access to a given database?  I can't seem to find a way to do this.

No, security in postgres is more or less non-existent.

Jeff Meredith
[email-masked]