Subject: Installation Problem..

From: "Manoj K. Jain" <[email-masked]>
Date: Mon, 5 Oct 92 15:16:48 EST

We are trying to install Postgres Release 4.0.1 and are 
having some problems while doing:
	./Make install
in Step 4 (Compiling and Installing POSTGRES) of Postgres Installation
Instructions.

It is compiling ok, but we get syntax errors when it starts initializing
the database. Below is the relevant portion of the make.log file.
Can someone please tell us what is the porblem? 
Thanks!!
-- Manoj

--------------------------------------------------------
ports available are:  dec decsprite seq sparc sun sunos4 ultrix4
please choose a port: 
Object directory name (obj.sparc) ? creating object directory obj.sparc
creating obj.sparc/access
creating obj.sparc/bootstrap
creating obj.sparc/commands
		.....
		.....
		.....
WARN:Oct  5 14:15:47:must OPEN RELATION before INSERT
WARN:Oct  5 14:15:47:Warning: no opened relation to close.
WARN:Oct  5 14:15:47:cannot open          pg_type
WARN:Oct  5 14:15:47:cannot open          pg_proc
	syntax error 454 : syntax error	syntax error 454 : syntax error	syntax error 454 : syntax error	syntax error 454 : syntax error	syntax error 454 : syntax errorWARN:Oct  5 14:15:47:cannot open          pg_proc
	syntax error 455 : syntax error	syntax error 455 : syntax error	syntax error 455 : syntax error	syntax error 455 : syntax error	syntax error 455 : syntax errorWARN:Oct  5 14:15:47:cannot open          pg_proc
	syntax error 456 : syntax error	syntax error 456 : syntax error	syntax error 456 : syntax error	syntax error 456 : syntax error	syntax error 456 : syntax errorWARN:Oct  5 14:15:47:cannot open          pg_proc
		.....
		.....
		.....
WARN:Oct  5 14:16:29:cannot open         pg_class
WARN:Oct  5 14:16:29:cannot open          pg_type
WARN:Oct  5 14:16:29:Warning: no opened relation to close.
WARN:Oct  5 14:16:29:cannot open         pg_class
WARN:Oct  5 14:16:29:cannot open         pg_class
WARN:Oct  5 14:16:29:cannot open         pg_class
WARN:Oct  5 14:16:29:cannot open         pg_class
WARN:Oct  5 14:16:29:cannot open         pg_class
WARN:Oct  5 14:16:29:cannot open         pg_class
initdb: could not create template database
initdb: cleaning up.

Cleaning up...
Installation complete.
done

---------------------------------------------------------------

---

From: [email-masked] (Alfredo Sanchez)
Date: Mon, 5 Oct 92 16:21:03 -0700

"Manoj K. Jain" <[email-masked]> writes

> WARN:Oct  5 14:15:47:cannot open          pg_proc

I remember I was having the same problem when installing
v3.1, and what I was not doing right was to login as user
postgres. I was installing it as root instead and, as 
documented in the installation instructions, it would
never work.
Hope this helps,

J Alfredo Sanchez H
-------------------
Hypermedia Research Lab
Texas A&M University