Subject: arrays of arrays

From: Drunkard Terry <[email-masked]>
Date: Sat, 11 Feb 1995 09:50:13 +0900

When I create the attribute and append some value below...
 
* create manager (name = char16, employees = text[] ) \g

* append manager (name = "mike",
		  employees = "{"wei", "greg", "jeff", "terry"}" ) \g
* append manager (name = "alice",
		  employees = "{"bill", "joe", "terry"}" ) \g	

So, I tried query below..

* retrieve ( manager.name ) where manager.employees="{"greg","jeff","terry"}" \g

return the message below..
------------------------
WARN:Feb 11 09:44:15:OperatorDef: no operator =
------------------------

I missed the syntax?

---------------- Terry [G'Job !]

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]".
   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================
              URL: http://s2k-ftp.CS.Berkeley.EDU:8000/postgres/

---

From: [email-masked]
Date: Sat, 11 Feb 1995 20:35:21 -0500 (EST)

Excerpts from internet.postgres: 11-Feb-95 arrays of arrays Drunkard
[email-masked] (1109*)

> * retrieve ( manager.name ) where
> manager.employees="{"greg","jeff","terry"}" \g

> I missed the syntax?

That's funny, 

 rasam.ndim.edrc.cmu.edu> monitor test
Welcome to the POSTGRES terminal monitor

Go 
* create manager(name=char16, employees=text[])\g

Query sent to backend is "create manager(name=char16, employees=text[])"
CREATE
Go 
* append manager(name="mike",
                employees="{"wei", "greg", "jeff", "terry"}")\g

Query sent to backend is "append manager(name="mike",          
employees="{"wei", "greg", "jeff", "terry"}")"
APPEND 36606
Go 
* append manager (name="alice",
                employees="{"bill","joe","terry"}")\g

Query sent to backend is "append manager (name="alice",                
employees="{"bill","joe","terry"}")"
APPEND 36607
Go 
* retrieve (manager.name) where
        manager.employees="{"greg","jeff","terry"}"\g

Query sent to backend is "retrieve (manager.name) where        
manager.employees="{"greg","jeff","terry"}""
---------------
| name        |
---------------

Go 
* \q
 rasam.ndim.edrc.cmu.edu>

Cheers,
Robert

---

From: [email-masked]
Date: Sat, 11 Feb 1995 20:35:21 -0500 (EST)

That's funny, 

Go 

Go 
* \q
 rasam.ndim.edrc.cmu.edu>

Cheers,
Robert