Subject: hanging createdb

From: [email-masked]
Date: Thu, 18 Jul 91 18:08:03 -0700

I saw the same question from other user a few days ago. But I didn't see the answer.
Can I ask it again?

I installed Postgres on my machine (Sun 4/370, SunOs 4.1.1), but when I run
createdb dbname, it hangs.

What am I doing wrong?

Park

---

From: [email-masked] (Mike Olson)
Date: Thu, 18 Jul 91 18:36:36 PDT

> createdb dbname, it hangs.

this appears to happen when you're running createdb, but there's no entry
for you in the pg_user relation.  to fix this, run the following sequence
of commands as user postgres:

	% grep mao /etc/passwd
	mao:*:1806:6:Mike Olson,608-3E,6428072,:/u/mao:/bin/csh
	% monitor template1
	[ ... ]
	Go
	* append pg_user (usename = "mao", usesysid = 1806,
			  usecreatedb = "t"::bool, usetrace = "t"::bool,
			  usesuper = "f"::bool, usecatupd = "t"::bool)
	\g
	APPEND
	* \q
	[ ... ]

replace "mao" with your user name, and 1806 with your uid from /etc/passwd.

let me know if this fixes your problem.  sorry to those of you who have been
hanging on this -- we had a hard time reproducing the problem here, since all
of us are in pg_user all the time.
					mike olson
					postgres research group
					uc berkeley
					[email-masked]