Subject: [de.comp.databases,comp.databases,comp.databases.ingres,alt.sources: Onyx a copylefted 4gl version 2.29 is out]

From: [email-masked] (Paul M. Aoki)
Date: Wed, 27 Jul 94 22:55:24 -0700

------- Forwarded Message

 Newsgroups:  de.comp.databases,comp.databases,comp.databases.ingres,alt.source
s
 From:  Michael Kraehe <[email-masked]>
 Subject:  Onyx a copylefted 4gl version 2.29 is out
 Date:  Wed, 27 Jul 1994 17:10:06 GMT

 	Welcome to Onyx 2.29			 a copylefted sql/4gl
 
 				  Abstract
 
 	* Onyx is my private sql/4gl game, donated to all folks
 	  freaks, and gurus who like the idea of copyleft ;-)
 
 	  I've started to write it because the department of enviroment
 	  state Bremen had several dos boxes with informix, chrashing
 	  frequently, so we decided to use linux as clients as ip
 	  becomes stable with 99p6.
 
 	* Onyx has a own transaction manager, which is build
 	  by a object oriented predicative parser generator. Just
 	  an other game but very usefull as this funny thing also
 	  produces header files and manual pages. 
 
 	  Its so posible to parse what I call it "crippled sql" and
 	  produce commands for other engines like university ingres
 	  or even gnu awk.
 
 	  If Y use a real sql engine, Y'll get their "real" sql of
 	  course and not my crippled one ;-) 
 
 	* Main goal of the transactionmanager is to implement a protocol
 	  for connecting applications to a database in a vendor independent
 	  way. Informix, Ingres, Postgres, Yard, GAWK, Shql are now supported,
 	  and others are planned.
 
 	  So any application capable to telnet to port is able to use
 	  my protocol which is documented in a rfc-like style.
 
 	* Onyx has a 4gl which is more a shell, but unlike other shells
 	  knows about tables, transactions, masks and menus.
 
 	  Onyx is designed by the Model-View-Controller paradigma,
 	  so tables are the model, masks are the views and transactions
 	  are the controllers which can be bound to a input field,
 	  a menu, function keys or the change of the current record
 	  in a cursor.
 
 	* Unlike other 4gl's Onyx dosnt hide the system, so its easy
 	  to export or inport from pipe and use the bunch of tools
 	  *nix have. E.g. I'm using a pipe to "gawk | groff | lpr"
 	  to print my bills, or a pipe from "tar | gawk" to manage
 	  my tapes.
 
 	* Copyleft is a chance that good programmers dont need to
 	  work for a big company, or become a slave of their distribution
 	  chanels.
 
 	  Linux and Onyx is a chance for database application programmers
 	  to sell their solutions and support to the customers without the
 	  need to pay a lot to the big companys for using their tools, and
 	  listen hours to "please hold the line" if they need support.
 
 				News in 2.29
 
 	* dynasel as a new import statement to make selecting much more
 	  user friendly, see manual page for transaction grammar.
 
 	* fixed bug in SqlGawk when deleting everything.
 
 	* the example application/fakt now looks realy nice.
 
 				News in 2.28
 
 	* Directory structur and configuration redesigned.
 
 	  Make config gives a editor (vi) to edit configuration
 	  which will be parsed by awk to produce the files.
 	  Trouble with old .C files and missing .h files solved
 
 	  (i hope ;-)
 
 	* A lot of work arounds, for C++ related bugs in GCC > 2.4
 	  Should now compile with gcc 2.5.8 and i hope above.
 
 	* Yard now seams stable, lot of trouble with permissions
 	  in sharded memory (I hate SysPfeifDrauf, but I dont want
 	  to translate this german joke ;-)

 				News in 2.27
 
 	* First binary relase just for test at wowbagger.
 
 	* Now supporting Yard as a comercial database engine availabe
 	  for linux.
 
 	* Some hacks for multiple cursors in one mask. See app/fakt
 	  as a example. Needs more hacking for displaying them as
 	  row's and columns, and mixed in a mask.
 
 				How to get it
 
 	V32bis: bakunin.north.de 		 +49 421 870523
 	ftp:    wowbagger.pc-labor.uni-bremen.de pub/unix/databases
 
 				------------
 
 	For further information take a look into the doc directory,
 	be warned some docs are produced while compiling.
 
 	If Y realy want to use it send mail to
 
 		<[email-masked]>
 
 	If Y like to donate beer or postcards, send them to :
 
 		Kraehe
 		Karl Toma Allee 4
 
 		28215 Free Republic Weidedamm III
 		      Bremen/Germany
 
 	If Y like to donate money, send it to :
 
 		Michael Koehne
 		Sparkasse Bremen
 		Bankleitzahl : 290 501 01
 		Konto        : 3189 3019
 
 --
 " ceterum censeo MSDOS delendam esse " sagt der Guru und krault seinen Bart
 
 	[email-masked] 

------- End of Forwarded Message
--
  Paul M. Aoki          |  University of California at Berkeley
  [email-masked]  |  Dept. of EECS, Computer Science Division (#1776) 
                        |  Berkeley, CA 94720-1776

==============================================================================
   To add/remove yourself to/from the POSTGRES mailing list: send mail with 
   the subject line ADD or DEL to "[email-masked]"

   If this fails, send mail to "[email-masked]" and
   a human will deal with it.  DO NOT post to the "postgres" mailing list.
==============================================================================

---

From: Jon Forrest <[email-masked]>
Date: Mon, 01 Aug 94 17:13:03 -0700

> Where can one find postgres 4.2 . 
> Apparently s2k... is no longer on line.

The whole computer science department at UCB has moved into
a new building and it will take a little while before things are
back in order again. Stay tuned.

Jon

---

From: "John S. Robinson" <[email-masked]>
Date: Mon, 1 Aug 1994 19:58:50 -0400

---

From: "John S. Robinson" <[email-masked]>
Date: Tue, 2 Aug 1994 19:48:46 -0400

Is there any place in the U.S. that mirrors the postgres directories
	of s2k-ftp.CS.Berkeley.EDU.