Subject: Re:

From: Álvaro Herrera <[email-masked]>
Date: Fri, 7 Mar 2025 10:15:35 +0100

Bcc:
Subject: Re: please update description of grison
Reply-To:
In-Reply-To: <[email-masked]>

On 2025-Mar-07, Mikael Kjellström wrote:

> Hi
> 
> Sorry should be:
> 
> ./update_personality.pl --os-version="12" --compiler-version="12.2.0"
> 
> as the os is:
> 
> Raspbian GNU/Linux 12 (bookworm)
> 
> and compiler is:
> 
> $ gcc --version
> 
> gcc (Raspbian 12.2.0-14+rpi1) 12.2.0
> 
> right?

Sounds correct to me.  You could also say --compiler-version=12.2.0-14+rpi1
but the extra detail probably adds little.

Adding Filipe Rosset to CC, because his animal versions could also do
with some retouching.

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/
"Computing is too important to be left to men." (Karen Spärck Jones)

---

From: Mikael Kjellström <[email-masked]>
Date: Fri, 7 Mar 2025 10:28:22 +0100

> but the extra detail probably adds little.

OK. I've updated it now but skipped the extra compiler details.  I guess 
it goes onto some approve queue somewhere or takes a while before it 
updates the information?

I will go through my other animals and change them also so they are correct.

/Mikael

---

From: Tom Lane <[email-masked]>
Date: Fri, 07 Mar 2025 14:56:38 -0500

> it goes onto some approve queue somewhere or takes a while before it 

I believe it shows up immediately on the members page:

https://buildfarm.postgresql.org/cgi-bin/show_members.pl

Individual build runs capture the current setting, so you won't
see a change in existing run logs; the next run on a branch
will update that.

			regards, tom lane

---

From: Mikael Kjellström <[email-masked]>
Date: Fri, 7 Mar 2025 22:14:06 +0100

On 2025-03-07 20:56, Tom Lane wrote:
> =?UTF-8?Q?Mikael_Kjellstr=C3=B6m?=<[email-masked]> writes:

Yes, my animals has started to report in with the updated info. I've 
updated all my animals so they are reflecting the reality.

/Mikael

---

From: Andrew Dunstan <[email-masked]>
Date: Sat, 8 Mar 2025 07:18:59 -0500

> see a change in existing run logs; the next run on a branch

Yes, pretty much. There's a table called personality that captures the 
changes with a timestamp, and the status pages show the personality with 
the latest timestamp earlier than the the run.

cheers

andrew

--
Andrew Dunstan
EDB: https://www.enterprisedb.com