Subject: Announcing Release 15 of the PostgreSQL Buildfarm client

From: Andrew Dunstan <[email-masked]>
Date: Sat, 31 Dec 2022 10:02:32 -0500

Changes

  * add a new script |manage_alerts.pl| that lets the user enable or
    disable alerts for an animal
    This is especially useful in the case of animals that have stopped
    running for some reason.
  * check if a branch is up to date before trying to run it
    This only applies if the |branches_to_build| setting is a keyword
    rather than a list of branches. It reduces the number of useless
    calls to |git pull| to almost zero.
  * require Perl version 5.14 or later
    This should not be a problem, as it's more than 10 years old.
  * add |--avoid-ts-collisions| command line parameter
    This is for specialized uses, and imposes a penalty of a few seconds
    per run. |run_branches.pl| already does this, so it's not required for
    normal operations.
  * run TAP tests for |src/interfaces| subdirectories
  * add amcheck and extension upgrade tests to cross version upgrade testing
  * adjust to changes in postgres code, file locations, etc.
  * assorted minor bug fixes and tweaks

The release can be downloaded from

<https://github.com/PGBuildFarm/client-code/releases/tag/REL_15> or
<https://buildfarm.postgresql.org/downloads>

Upgrading is highly recommended.

cheers

andrew

--
Andrew Dunstan
EDB: https://www.enterprisedb.com

---

From: Noah Misch <[email-masked]>
Date: Sat, 31 Dec 2022 17:55:51 -0800

>     calls to |git pull| to almost zero.

This new reliance on buildfarm.postgresql.org/branches_of_interest.json is
trouble for non-SSL buildfarm animals.
http://buildfarm.postgresql.org/branches_of_interest.txt has an exemption to
allow serving over plain http, but the json URL just redirects the client to
https.  Can the json file get the same exemption-from-redirect that the txt
file has?

---

From: Andrew Dunstan <[email-masked]>
Date: Sat, 31 Dec 2022 21:11:04 -0500

> https.  Can the json file get the same exemption-from-redirect that the txt

I didn't realize there were animals left other than mine which had this
issue. I asked the admins some weeks ago to fix this (I don't have
privilege to do so), but have not had a response yet. The temporary
workaround is to use a list of named branches, e.g. instead of 'ALL' use
[qw(REL_11_STABLE REL_12_STABLE REL_13_STABLE REL_14_STABLE
REL_15_STABLE HEAD)]

cheers

andrew

---

From: Andrew Dunstan <[email-masked]>
Date: Sun, 1 Jan 2023 18:34:13 -0500

> [qw(REL_11_STABLE REL_12_STABLE REL_13_STABLE REL_14_STABLE

Looks like this is fixed now (Thanks Magnus!), the workaround should no
longer be necessary.

cheers

andrew

---

From: Andrew Dunstan <[email-masked]>
Date: Tue, 10 Jan 2023 10:17:58 -0500

>     calls to |git pull| to almost zero.

Occasionally things go wrong. It turns out this code was a bit too eager
and ignored the force_every settings in the config file.

There's a hot fix at
<https://github.com/PGBuildFarm/client-code/commit/c9693f86d9bd07b470bb2a106055b5801cd613ec>
and I will push out a new release shortly.

cheers

andrew

---

From: Andrew Dunstan <[email-masked]>
Date: Tue, 10 Jan 2023 10:21:50 -0500

There's a hot fix at

Systems that might well be affect include:

alabio
calliphoridae
culicidae
desmoxytes
dragonet
flaviventris
francolin
gerenuk
grassquit
guaibasaurus
hamerkop
idiacanthus
kestrel
komodoensis
massasauga
mylodon
olingo
petalura
phycodurus
piculet
pogona
rorqual
serinus
skink
snakefly
tamandua
xenodermus

Please check if your animals are affected. If you don't have any
force_every settings you won't be.

cheers

andrew