Subject: data_checksums coverage

From: Justin Pryzby <[email-masked]>
Date: Thu, 13 Jan 2022 10:18:11 -0600

Is there any coverage with data_checksums=on (initdb -k) ?

-- 
Justin

---

From: Julien Rouhaud <[email-masked]>
Date: Fri, 14 Jan 2022 13:50:42 +0800

Hi,

> Is there any coverage with data_checksums=on (initdb -k) ?

The build farm client doesn't support that as far as I can see after a quick
look at run_build.pl.

There's some coverage in the pg_checksums tool TAP tests, although not a lot.

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 13 Jan 2022 23:53:12 -0600

> There's some coverage in the pg_checksums tool TAP tests, although not a lot.

That's what I thought.  I also raised the question on -hackers, so I suspect
we'll address that somehow.

https://www.postgresql.org/message-id/20220113193238.xkzsnigg5gri5lwl%40alap3.anarazel.de

Thanks,
-- 
Justin