Subject: Announcing Release 18 of the PostgreSQL Buildfarm client

From: Andrew Dunstan <[email-masked]>
Date: Sat, 2 Nov 2024 16:44:27 +1030

I have pushed  Release 18 of the PostgreSQL Buildfarm client

In addition to numerous minor tweaks and bug fixes, the following changes
are made:

   - many improvements in the collection of log files
   - accommodate change in data checksum default in cross version upgrade
   testing
   - increase default PGCTLTIMEOUT to 180s
   - improve "safe" environment set, including all in the build_env
   configuration settings
   - on script timeout, don't just fail but send the result to the server
   (Note: the timeout mechanism doesn't work on Windows, and has been disabled
   there)
   - set the default timeout to 4 hours.
   - remove redundant TestDecoding module
   - add a module for running "make dist"
   - improve detection of failures when running with meson
   - add README files to the set ignored by the sample trigger_exclude
   setting.

The release can be downloaded from

https://github.com/PGBuildFarm/client-code/releases/tag/REL_18
<https://www.blogger.com/#> or

https://buildfarm.postgresql.org/downloads <https://www.blogger.com/#>

Upgrading is highly recommended.

cheers

andrew

---

From: Alexander Lakhin <[email-masked]>
Date: Sat, 23 Nov 2024 07:00:00 +0300

Hello,

02.11.2024 09:14, Andrew Dunstan wrpte:
> In addition to numerous minor tweaks and bug fixes, the following changes are made:
>
>   * many improvements in the collection of log files
>   * accommodate change in data checksum default in cross version upgrade testing
>   * increase default PGCTLTIMEOUT to 180s
>   * improve "safe" environment set, including all in the build_env configuration settings
>   * on script timeout, don't just fail but send the result to the server (Note: the timeout mechanism doesn't work on
>     Windows, and has been disabled there)
>   * set the default timeout to 4 hours.
>

It looks like this timeout should be increased at least on avocet (which
tests CLOBBER_CACHE_ALWAYS).

Just after upgrading, it failed on REL_13_STABLE, REL_12_STABLE (I think
other branches to follow) with timeouts:
https://buildfarm.postgresql.org/cgi-bin/show_log.pl?nm=avocet&dt=2024-11-22%2016%3A11%3A23
https://buildfarm.postgresql.org/cgi-bin/show_log.pl?nm=avocet&dt=2024-11-22%2020%3A11%3A49

(On previous runs, this animal used buildfarm client REL_16.)

Best regards,
Alexander

---

From: Alexander Lakhin <[email-masked]>
Date: Thu, 28 Nov 2024 10:00:00 +0300

Hello,

> https://buildfarm.postgresql.org/cgi-bin/show_log.pl?nm=avocet&dt=2024-11-22%2020%3A11%3A49

Now that wait_timeout changed from undefined to 0 in $Script_Config,
tests are going green on avocet.

Thank you!

Best regards,
Alexander