Subject: hake failing on pgsql-Git kinda "random"

From: Olaf Bohlen <[email-masked]>
Date: Mon, 29 Jun 2026 15:06:32 +0200

Hi,

I'm running the hake animal and after a server loss in April, everything should go smooth again. But now I have the problem that at random times hake failes in pgsql-Git. It works for days, and then out of the blue it stops.

I have the following in my crontab:

$ crontab -l | egrep -v "^#"                     
15 3,10,16,21 * * * ( cd /export/home/elmer/c20x && PATH=/usr/gnu/bin:$PATH ./run_branches.pl --run-all --verbose >/export/home/elmer/c20x/cron.out 2>&1 )

and the cron.out says:

$ cat cron.out                                             
Mon Jun 29 10:15:02 2026: buildfarm run for hake:REL_14_STABLE starting
hake:REL_14_STABLE [10:15:03] checking out source ...
Missing checked out branch bf_REL_14_STABLE:
fatal: not a git repository (or any of the parent directories): .git
hake:REL_14_STABLE [10:15:10] failed at stage pgsql-Git
Mon Jun 29 10:15:10 2026: buildfarm run for hake:REL_15_STABLE starting
hake:REL_15_STABLE [10:15:10] checking out source ...
Missing checked out branch bf_REL_15_STABLE:
fatal: not a git repository (or any of the parent directories): .git
hake:REL_15_STABLE [10:15:13] failed at stage pgsql-Git
Mon Jun 29 10:15:13 2026: buildfarm run for hake:REL_16_STABLE starting
hake:REL_16_STABLE [10:15:13] checking out source ...
Missing checked out branch bf_REL_16_STABLE:
fatal: not a git repository (or any of the parent directories): .git
hake:REL_16_STABLE [10:15:16] failed at stage pgsql-Git
Mon Jun 29 10:15:16 2026: buildfarm run for hake:REL_17_STABLE starting
hake:REL_17_STABLE [10:15:16] checking out source ...
Missing checked out branch bf_REL_17_STABLE:
fatal: not a git repository (or any of the parent directories): .git
hake:REL_17_STABLE [10:15:19] failed at stage pgsql-Git
Mon Jun 29 10:15:19 2026: buildfarm run for hake:REL_18_STABLE starting
hake:REL_18_STABLE [10:15:19] checking out source ...
Missing checked out branch bf_REL_18_STABLE:
fatal: not a git repository (or any of the parent directories): .git
hake:REL_18_STABLE [10:15:21] failed at stage pgsql-Git
Mon Jun 29 10:15:22 2026: buildfarm run for hake:HEAD starting
hake:HEAD          [10:15:22] checking out source ...
Missing checked out branch bf_HEAD:
fatal: not a git repository (or any of the parent directories): .git
hake:HEAD          [10:15:24] failed at stage pgsql-Git

Once I delete the buildroot directory it starts working again for some days.

Does anyone here has seen the same or an idea?

Best Regards,

Olaf

-- 
      ~       Olaf Bohlen - [email-masked]
      |~~     Het
     /|  \    Bruine
 ___/_|___\   Leven
   \__n____/# DGCN2

---

From: Mark Wong <[email-masked]>
Date: Mon, 29 Jun 2026 08:45:37 -0700

Hi!

> Does anyone here has seen the same or an idea?

I get that a lot on a number of the VM's I use with POWER and ARM.
Andrew Dunstan has suggested I set "use_vpath => true".  I think that
has helped...

Regards,
Mark

---

From: Andrew Dunstan <[email-masked]>
Date: Mon, 29 Jun 2026 12:22:18 -0400

> Andrew Dunstan has suggested I set "use_vpath => true".  I think that

Yes, that should help things. There also a patch not yet released that 
tries to avoid moving the .git directory and use git archive instead. 
See 
<https://github.com/PGBuildFarm/client-code/commit/2199960efbeaf60ce17a6f2ec28826f96eb621a8>

It's probably time for me to make a new release.

cheers

andrew

--
Andrew Dunstan
EDB:https://www.enterprisedb.com

---

From: Olaf Bohlen <[email-masked]>
Date: Mon, 29 Jun 2026 19:02:11 +0200

> Am 29.06.2026 um 17:45 schrieb Mark Wong <[email-masked]>:
> 
> Hi!
> 

Thanks a lot Mark (and also Andrew, I just reply once :)) I have changed that setting and now hope for stable builds :)

Best Regards,