Subject: [Pgbuildfarm-members] new build members

From: Daniel Black <[email-masked]>
Date: Mon, 5 Sep 2016 16:08:09 +1000

Hi,

I've configured a bunch of builds to add to the build farm. The list is:

I've done the registration process however this is the list in case I
missed something.

 xlc,ppc64le,ubuntu-16.04
 clang,ppc64le,fedora-23
 clang-3.8,ppc64le,fedora-23
 clang-3.9,x86_64,ubuntu-16.04
 gcc-6,x86_64,fedora-23
 gcc-6,x86_64,ubuntu-16.04
 at9.0,ppc64le,ubuntu-16.04
 gcc,ppc64le,debian-8.4
 gcc,x86_64,debian-8.4
 at10.0-rc1,ppc64le,debian-8.4
 gcc,ppc64le,fedora-23
 gcc,ppc64le,ubuntu-16.04
 clang,x86_64,debian-8.4
 at9.0,ppc64le,debian-8.4
 clang-4.0,x86_64,debian-8.4
 clang,ppc64le,debian-8.4
 gcc,x86_64,ubuntu-16.04
 gcc,x86_64,fedora-23
 gcc-6,ppc64le,fedora-23
 clang-4.0,x86_64,ubuntu-16.04
 clang-3.9,x86_64,debian-8.4
 clang,x86_64,fedora-23
 clang-3.8,x86_64,debian-8.4
 at10.0-rc1,ppc64le,ubuntu-16.04
 clang,ppc64le,ubuntu-16.04
 gcc-6,ppc64le,debian-8.4
 clang-3.8,x86_64,fedora-23
 gcc-6,ppc64le,ubuntu-16.04
 gcc-6,x86_64,debian-8.4
 clang,x86_64,ubuntu-16.04

---

From: Tom Lane <[email-masked]>
Date: Wed, 07 Sep 2016 22:12:09 -0400

> I've configured a bunch of builds to add to the build farm. The list is:

Hi Daniel!  Thanks for bringing all those new critters online.
However, may I suggest that the ccache+clang ones would be a lot more
useful if you added this to their configuration:

    build_env =>{

+        # needed to make ccache play nice with clang
+        CCACHE_CPP2 => '1',

Lack of this option is what's causing a lot of those useless warnings
(it has to do with clang being fed preprocessor output, which triggers
some of its more dubious warning heuristics).  I think this has become
the default behavior as of ccache 3.3, but in older versions you gotta
ask for it.

As an example of the importance of this,
http://buildfarm.postgresql.org/cgi-bin/show_stage_log.pl?nm=devario&dt=2016-09-08%2000%3A44%3A53&stg=make
contains something north of 1000 warnings, most of which are entirely
bogus.  Makes it hard to see if there are any that are meaningful.

			regards, tom lane

---

From: Andrew Dunstan <[email-masked]>
Date: Thu, 8 Sep 2016 09:18:38 -0400

> bogus.  Makes it hard to see if there are any that are meaningful.

As of ccache version 3.3.1 this is apparently the default - see 
<https://ccache.samba.org/manual.html>

I guess I should put it in the sample config file to cater for older 
versions (e.g. my Fedora machine has 3.2.3 where it is apparently not 
the default).

cheers

andrew