Subject: status of POSTGRES

From: Mike Stonebraker <[email-masked]>
Date: Wed, 17 Nov 1993 10:32:49 -0800

At the current time POSTGRES is a reasonably mature research
project, having been in existence since 1986.  Moreover, most
of the research ideas have been implemented, and there is
now even a commercial version of the system.

Governement research contracts are appropriate for
"proof of concept" prototypes, but are not designed
to provide long-term support for mature software.

As a result, the POSTGRES group is focused on finishing
the implementation of sets and making the current
code line as robust as possible.  There will be one
more major release of the system (Version 5) probably
first quarter next year.

After that POSTGRES, Version 5 will join its
predecessor, the public domain version of INGRES,
in the never-never land of archived software.

The Berkeley research team will go on to building 
a novel distributed DBMS, called Mariposa.  For
a peek at the goals of this system, check out our paper in 
the 1994 IEEE Data Engineering Conference or get the
tech report from anonymous ftp to toe.berkeley.edu

/Mike Stonebraker

---

From: Chris Flatters <[email-masked]>
Date: Wed, 17 Nov 1993 19:12:03 GMT

> tech report from anonymous ftp to toe.berkeley.edu

Is this the project that was denoted POSTGRES II in memo UCB/URL M91/49
(Managing Persistent Objects in a Multi-Level Store)?

	Chris Flatters
	[email-masked]

---

From: Mike Stonebraker <[email-masked]>
Date: Wed, 17 Nov 1993 14:57:56 -0800

The current goals of Mariposa are a substantial superset of the
the system, called POSTGRES II, in  memo UCB/ERL M91/49.  Check
out Sequoia Technical Report 93/31 entitled "Mariposa: A New 
Architecture for Distributed Data"

/mike stonebraker