Subject: Process for Creating Translations

From: Shruti B Iyer <[email-masked]>
Date: Thu, 01 Jun 2017 15:40:14 +0000

Hi Hackers,

In the patches we sent recently, we added text to the User Interface. We
know that calling getText translates it but currently we don't have
translations for any of the new text.

Is there a process for getting these text translated to other languages?

Thanks,
Shruti & Joao

---

From: Dave Page <[email-masked]>
Date: Thu, 1 Jun 2017 18:05:31 +0100

Hi

> Is there a process for getting these text translated to other languages?

I periodically update the translation templates, and then put a shout
out to the translators. I try to minimise that though - I don't want
to be pinging them every other commit for obvious reasons.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Matthew Kleiman <[email-masked]>
Date: Fri, 2 Jun 2017 10:47:48 -0400

> to be pinging them every other commit for obvious reasons.

Thanks for the response, Dave. To clarify, we should continue to wrap
English text in the get_text function and you will be able to generate a
list of newly needed translations periodically? I just want to understand
whether we need to keep track of all the new phrases from each story we
complete.

Thanks,
Matt

---

From: Dave Page <[email-masked]>
Date: Fri, 2 Jun 2017 16:19:04 +0100

Right, you don't need to do anything except wrap strings in the appropriate macros/functions.

EnterpriseDB UK:http://www.enterprisedb.com
The Enterprise PostgreSQL Company

On 2 Jun 2017, at 15:47, Matthew Kleiman <[email-masked]> wrote:

> Thanks for the response, Dave. To clarify, we should continue to wrap English text in the get_text function and you will be able to generate a list of newly needed translations periodically? I just want to understand whether we need to keep track of all the new phrases from each story we complete.
> 
> Thanks,
> Matt
>