Subject: Saved SQL queries will not execute

From: Sandy Haas <[email-masked]>
Date: Fri, 16 Jun 2023 10:17:52 -0400

Good morning,

I’m hoping someone can help me with a problem I seem to be having when
trying to run saved queries on my new Windows 11 PC.

When I open a saved query, and execute it, sometimes it works, but most
times it does not.  I’m having to copy the query and paste it into a new
query tab and execute it that way.  Then, if I change a variable in that
query, I have to again copy it, and paste it into yet another query tab, to
get it to execute.

I recently got a new PC, Windows 11, and am using version 7.3.

I’ve scoured the web and the PGAdmin documentation, and the only thing I’ve
found referencing issues, is to check that auto commit is on, and it is.

I did install it to my D drive, but I notice that the Database File is
located on my C drive.  Could this possibly be the issue?

Any help is greatly appreciated.

Sincerely,

Sandy Haas

Logistics/Data Management

Special Projects

[email-masked]

423-468-1634 (O)

423-413-7362 (C)

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 20 Jun 2023 17:59:17 +0530

Hi Sandy,

What is the error when it does not work? Can you share screenshot or
pgAdmin logs as well please?

On Sat, Jun 17, 2023 at 12:11 AM Sandy Haas <[email-masked]> wrote:

> I’ve scoured the web and the PGAdmin documentation, and the only thing
> I’ve found referencing issues, is to check that auto commit is on, and it
> is.
>
>
>

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Architect | *enterprisedb.com*
<https://www.enterprisedb.com/>
"Don't Complain about Heat, Plant a TREE"

---

From: Sandy Haas <[email-masked]>
Date: Wed, 21 Jun 2023 09:52:16 -0400

Attached is the log file for the following example of what is happening.

I open the query tool once I’m connected to my database.

[image: A screenshot of a computer Description automatically generated with
medium confidence]

I open my saved query from a folder in my dropbox and update my parameters
and click execute.

[image: A screenshot of a computer screen Description automatically
generated with low confidence]

Then I change my parameters, click save, and execute, and nothing updates.
I have to copy my query to a new query window for it to actually update the
records.

[image: A screenshot of a computer Description automatically generated with
medium confidence]

These are my settings.

[image: A screenshot of a computer Description automatically generated with
medium confidence]

thank you,

~sandy

*From:* Aditya Toshniwal <[email-masked]>
*Sent:* Tuesday, June 20, 2023 8:29 AM
*To:* Sandy Haas <[email-masked]>
*Cc:* [email-masked]
*Subject:* Re: Saved SQL queries will not execute

Hi Sandy,

Good morning,

Sincerely,

Sandy Haas

Special Projects

[email-masked]

423-468-1634 (O)

423-413-7362 (C)

-- 

Thanks,

Aditya Toshniwal

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 21 Jun 2023 19:55:48 +0530

Hi Sandy,

Can you check if auto complete of key press is enabled in Preferences Query
Tool?
If enabled, please try disabling it and open new query tool.

On Wed, Jun 21, 2023, 19:22 Sandy Haas <[email-masked]> wrote:

> [image: A screenshot of a computer Description automatically generated
> with medium confidence]
>
>
>
> Then I change my parameters, click save, and execute, and nothing
> updates.  I have to copy my query to a new query window for it to actually
> update the records.
>
> [image: A screenshot of a computer Description automatically generated
> with medium confidence]
>
>
>
>
>
> These are my settings.
>
> [image: A screenshot of a computer Description automatically generated
> with medium confidence]
>
>
>
>
>
> thank you,
>
> ~sandy
>
>
>

---

From: Sandy Haas <[email-masked]>
Date: Fri, 4 Aug 2023 18:39:47 -0400

That seems to have fixed it.  Thank you!!!

thank you,

~sandy

*From:* Aditya Toshniwal <[email-masked]>
*Sent:* Wednesday, June 21, 2023 10:26 AM
*To:* Sandy Haas <[email-masked]>
*Cc:* pgadmin-hackers <[email-masked]>
*Subject:* Re: Saved SQL queries will not execute

Hi Sandy,

These are my settings.

thank you,

~sandy

Hi Sandy,

Good morning,

Sincerely,

Sandy Haas

Special Projects

[email-masked]

423-468-1634 (O)

423-413-7362 (C)

-- 

Thanks,

Aditya Toshniwal