Subject: Build failed in Jenkins: pgadmin4-master-python33 #517

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 13 Mar 2018 12:27:23 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/517/display/redirect?page=changes>

Changes:

[Dave Page] Fix template path generation for Windows. Fixes #3139

------------------------------------------
[...truncated 724.77 KB...]
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ViewsUpdateTestCase (Update materialized view under schema node)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ViewsAddTestCase (Add materialized view under schema node)
		SynonymAddTestCase (Default Node URL)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		TestSSLConnection (Test for SSL connection)
		PackageAddTestCase (Fetch Package Node URL)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		ViewsGetTestCase (Get materialized view under schema node)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsAddTestCase (Add resource groups)

EDB Postgres AS 9.4:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500)
	3 tests skipped:
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing range partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)

EDB Postgres AS 9.5:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500)
	3 tests skipped:
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing range partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)

EDB Postgres AS 9.2:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500)
	15 tests skipped:
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing range partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		ViewsUpdateTestCase (Update materialized view under schema node)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ViewsAddTestCase (Add materialized view under schema node)
		ViewsGetTestCase (Get materialized view under schema node)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)

PostgreSQL 9.6:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500)
	15 tests skipped:
		SynonymDeleteTestCase (Fetch synonym Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing range partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		TestSSLConnection (Test for SSL connection)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsAddTestCase (Add resource groups)

PostgreSQL 9.5:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500)
	15 tests skipped:
		SynonymDeleteTestCase (Fetch synonym Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing range partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		TestSSLConnection (Test for SSL connection)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsAddTestCase (Add resource groups)
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/web/regression/regression.log>

PostgreSQL 9.4:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500)
	15 tests skipped:
		SynonymDeleteTestCase (Fetch synonym Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing range partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		TestSSLConnection (Test for SSL connection)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsAddTestCase (Add resource groups)

======================================================================

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 13 Mar 2018 13:52:27 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/518/display/redirect?page=changes>