Subject: Build failed in Jenkins: pgadmin4-master-python36 #501

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 14:11:46 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/501/display/redirect?page=changes>

Changes:

[Dave Page] Ensure all messages are retrieved from the server in the Query Tool.

------------------------------------------
[...truncated 605.34 KB...]
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		PackageAddTestCase (Fetch Package Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		SynonymAddTestCase (Default Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 9.4:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		PackageAddTestCase (Fetch Package Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		SynonymAddTestCase (Default Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 9.5:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		PackageAddTestCase (Fetch Package Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		SynonymAddTestCase (Default Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 9.6:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		PackageAddTestCase (Fetch Package Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		SynonymAddTestCase (Default Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 10:

	274 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	13 tests skipped:
		PackageAddTestCase (Fetch Package Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		SynonymAddTestCase (Default Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

EDB Postgres AS 9.2:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		ViewsAddTestCase (Add materialized view under schema node)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		ViewsGetTestCase (Get materialized view under schema node)
		ViewsUpdateTestCase (Update materialized view under schema node)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

EDB Postgres AS 9.3:

	280 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	7 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)

EDB Postgres AS 9.4:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/ws/web/regression/regression.log>

EDB Postgres AS 9.5:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)

EDB Postgres AS 9.6:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)

======================================================================

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 16:12:37 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/502/display/redirect?page=changes>

Changes:

[Dave Page] Update Jasmine to v3. Fixes #3182

[Dave Page] Insert rows correctly when a table has OIDs and a Primary Key in

[...truncated 611.65 KB...]

PostgreSQL 9.4:

	276 tests passed
	1 test failed:

PostgreSQL 9.5:

	276 tests passed
	1 test failed:

PostgreSQL 9.6:

	276 tests passed
	1 test failed:

PostgreSQL 10:

	278 tests passed
	1 test failed:

EDB Postgres AS 9.2:

	276 tests passed
	1 test failed:

EDB Postgres AS 9.3:

	284 tests passed
	1 test failed:

EDB Postgres AS 9.4:

	288 tests passed
	1 test failed:

EDB Postgres AS 9.5:

	288 tests passed
	1 test failed:

EDB Postgres AS 9.6:

	288 tests passed
	1 test failed:

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 16:49:37 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/503/display/redirect?page=changes>

Changes:

[Dave Page] Allow admins to disable the use of Gravatar if they choose. Fixes #3037

[...truncated 611.66 KB...]

PostgreSQL 9.4:

	276 tests passed
	1 test failed:

PostgreSQL 9.5:

	276 tests passed
	1 test failed:

PostgreSQL 9.6:

	276 tests passed
	1 test failed:

PostgreSQL 10:

	278 tests passed
	1 test failed:

EDB Postgres AS 9.2:

	276 tests passed
	1 test failed:

EDB Postgres AS 9.3:

	284 tests passed
	1 test failed:

EDB Postgres AS 9.4:

	288 tests passed
	1 test failed:

EDB Postgres AS 9.5:

	288 tests passed
	1 test failed:

EDB Postgres AS 9.6:

	288 tests passed
	1 test failed:

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 17:21:31 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python36/504/display/redirect?page=changes>

Changes:

[Dave Page] Make the poll query test a little more robust.

[...truncated 610.70 KB...]

PostgreSQL 9.4:

	276 tests passed
	1 test failed:

PostgreSQL 9.5:

	276 tests passed
	1 test failed:

PostgreSQL 9.6:

	276 tests passed
	1 test failed:

PostgreSQL 10:

	278 tests passed
	1 test failed:

EDB Postgres AS 9.2:

	276 tests passed
	1 test failed:

EDB Postgres AS 9.3:

	284 tests passed
	1 test failed:

EDB Postgres AS 9.4:

	288 tests passed
	1 test failed:

EDB Postgres AS 9.5:

	288 tests passed
	1 test failed:

EDB Postgres AS 9.6:

	288 tests passed
	1 test failed: