Subject: Build failed in Jenkins: pgadmin4-master-python37 #119

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 22 Jan 2019 12:32:11 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python37/119/display/redirect?page=changes>

Changes:

[akshay.joshi] Proper SQL should be generated when create domain of type interval with

------------------------------------------
[...truncated 959.56 KB...]
		PgAgentPutStepTestCase (Update step with kind, description, code and error,
					Update step with connection type and string)
		PgAgentStatsTestCase (Check the stats of pgAgent job)
		TestSSLConnection (Test for SSL connection)
		BackupCreateJobTest (When backup object with default options,
					When backup object with format directory,
					When backup the object with option sections to all data,
					When backup the object with option only_data,
					When backup the object with option only_schema,
					When backup the object with option - format plain and dns_owner,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option - Do not save comments,,
					When backup the object with option - all queries,
					When backup the object with option - load via partition root,
					When backup the object with option - all queries and format custom,
					When backup the object with option - miscellaneous,
					When backup the object with format tar,
					When backup the server,
					When backup the server with option only_data,
					When backup the server with option only_schema,
					When backup the server with option - Do not save privilege, tablespace, unlogged table data,
					When backup the server with option - Do not save comments,,
					When backup the server with option - all queries,
					When backup the server with option - miscellaneous,
					When backup the server with encoding,
					When backup globals)
		TestUtilityCheckRouteCase (Check utility path route for backup utility,
					Check utility path route for import export utility,
					Check utility path route for maintenance utility,
					Check utility path route for restore utility)
		BackupJobTest (When backup the object with the default options)
		MaintenanceJobTest (When maintenance the object with the default options)
		MaintenanceCreateJobTest (When maintenance object with default options,
					When maintenance object with VACUUM FULL,
					When maintenance object with the ANALYZE,
					When maintenance the object with the REINDEX,
					When maintenance the object with the CLUSTER)
		RestoreJobTest (When restore the object with the default options)
		RestoreCreateJobTest (When restore object with default options,
					When restore object with format directory,
					When restore object with the sections options,
					When restore the object with Type of objects,
					When restore object with option - Do not save,
					When restore object with option - Do not save comments,
					When restore object with option - Queries,
					When restore object with option - Disbale,
					When restore object with option - Miscellaneous)

EDB Postgres AS 9.5:

	422 tests passed
	1 test failed:
		DomainReverseEngineeredSQLTestCase (Domain Reverse Engineered SQL with char,
					Domain Reverse Engineered SQL with Length, Precision and Default,
					Domain Reverse Engineered SQL with Length)
	21 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions,
					Create Hash partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		PgAgentAddTestCase (Add pgAgent job)
		PgAgentDeleteTestCase (Delete pgAgent job)
		PgAgentPutTestCase (Put pgAgent job)
		PgAgentAddScheduleTestCase (Create schedule with exception in pgAgent job)
		PgAgentAddStepTestCase (Create step for pgAgent job)
		PgAgentDeleteScheduleTestCase (Delete pgAgent Schedule)
		PgAgentDeleteStepTestCase (Delete pgAgent Step)
		PgAgentGetTestCase (Get pgAgent job)
		PgAgentPutScheduleTestCase (Update schedule with start and end time,
					Update schedule with repeat,
					Update schedule add exception,
					Update schedule change exception date and time,
					Update schedule delete exception)
		PgAgentPutStepTestCase (Update step with kind, description, code and error,
					Update step with connection type and string)
		PgAgentStatsTestCase (Check the stats of pgAgent job)
		TestSSLConnection (Test for SSL connection)
		BackupCreateJobTest (When backup object with default options,
					When backup object with format directory,
					When backup the object with option sections to all data,
					When backup the object with option only_data,
					When backup the object with option only_schema,
					When backup the object with option - format plain and dns_owner,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option - Do not save comments,,
					When backup the object with option - all queries,
					When backup the object with option - load via partition root,
					When backup the object with option - all queries and format custom,
					When backup the object with option - miscellaneous,
					When backup the object with format tar,
					When backup the server,
					When backup the server with option only_data,
					When backup the server with option only_schema,
					When backup the server with option - Do not save privilege, tablespace, unlogged table data,
					When backup the server with option - Do not save comments,,
					When backup the server with option - all queries,
					When backup the server with option - miscellaneous,
					When backup the server with encoding,
					When backup globals)
		TestUtilityCheckRouteCase (Check utility path route for backup utility,
					Check utility path route for import export utility,
					Check utility path route for maintenance utility,
					Check utility path route for restore utility)
		BackupJobTest (When backup the object with the default options)
		MaintenanceJobTest (When maintenance the object with the default options)
		MaintenanceCreateJobTest (When maintenance object with default options,
					When maintenance object with VACUUM FULL,
					When maintenance object with the ANALYZE,
					When maintenance the object with the REINDEX,
					When maintenance the object with the CLUSTER)
		RestoreJobTest (When restore the object with the default options)
		RestoreCreateJobTest (When restore object with default options,
					When restore object with format directory,
					When restore object with the sections options,
					When restore the object with Type of objects,
					When restore object with option - Do not save,
					When restore object with option - Do not save comments,
					When restore object with option - Queries,
					When restore object with option - Disbale,
					When restore object with option - Miscellaneous)

EDB Postgres AS 9.6:

	422 tests passed
	1 test failed:
		DomainReverseEngineeredSQLTestCase (Domain Reverse Engineered SQL with char,
					Domain Reverse Engineered SQL with Length, Precision and Default,
					Domain Reverse Engineered SQL with Length)
	21 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions,
					Create Hash partitioned table with 2 partitions)
		TableUpdateTestCase (Create partitions of existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing range partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table)
		PgAgentAddTestCase (Add pgAgent job)
		PgAgentDeleteTestCase (Delete pgAgent job)
		PgAgentPutTestCase (Put pgAgent job)
		PgAgentAddScheduleTestCase (Create schedule with exception in pgAgent job)
		PgAgentAddStepTestCase (Create step for pgAgent job)
		PgAgentDeleteScheduleTestCase (Delete pgAgent Schedule)
		PgAgentDeleteStepTestCase (Delete pgAgent Step)
		PgAgentGetTestCase (Get pgAgent job)
		PgAgentPutScheduleTestCase (Update schedule with start and end time,
					Update schedule with repeat,
					Update schedule add exception,
					Update schedule change exception date and time,
					Update schedule delete exception)
		PgAgentPutStepTestCase (Update step with kind, description, code and error,
					Update step with connection type and string)
		PgAgentStatsTestCase (Check the stats of pgAgent job)
		TestSSLConnection (Test for SSL connection)
		BackupCreateJobTest (When backup object with default options,
					When backup object with format directory,
					When backup the object with option sections to all data,
					When backup the object with option only_data,
					When backup the object with option only_schema,
					When backup the object with option - format plain and dns_owner,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option - Do not save comments,,
					When backup the object with option - all queries,
					When backup the object with option - load via partition root,
					When backup the object with option - all queries and format custom,
					When backup the object with option - miscellaneous,
					When backup the object with format tar,
					When backup the server,
					When backup the server with option only_data,
					When backup the server with option only_schema,
					When backup the server with option - Do not save privilege, tablespace, unlogged table data,
					When backup the server with option - Do not save comments,,
					When backup the server with option - all queries,
					When backup the server with option - miscellaneous,
					When backup the server with encoding,
					When backup globals)
		TestUtilityCheckRouteCase (Check utility path route for backup utility,
					Check utility path route for import export utility,
					Check utility path route for maintenance utility,
					Check utility path route for restore utility)
		BackupJobTest (When backup the object with the default options)
		MaintenanceJobTest (When maintenance the object with the default options)
		MaintenanceCreateJobTest (When maintenance object with default options,
					When maintenance object with VACUUM FULL,
					When maintenance object with the ANALYZE,
					When maintenance the object with the REINDEX,
					When maintenance the object with the CLUSTER)
		RestoreJobTest (When restore the object with the default options)
		RestoreCreateJobTest (When restore object with default options,
					When restore object with format directory,
					When restore object with the sections options,
					When restore the object with Type of objects,
					When restore object with option - Do not save,
					When restore object with option - Do not save comments,
					When restore object with option - Queries,
					When restore object with option - Disbale,
					When restore object with option - Miscellaneous)
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python37/ws/web/regression/regression.log>

======================================================================

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure
Not sending mail to unregistered user [email-masked]

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 22 Jan 2019 13:46:40 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python37/120/display/redirect?page=changes>