Subject: Build failed in Jenkins: pgadmin4-master-python33 #661

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Mon, 18 Jun 2018 01:33:48 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/661/display/redirect?page=changes>

Changes:

[Dave Page] Delete the venv folder prior to upgrade. Fixes #3384

------------------------------------------
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
[EnvInject] - Loading node environment variables.
Building in workspace <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url git://git.postgresql.org/git/pgadmin4.git # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
Fetching upstream changes from git://git.postgresql.org/git/pgadmin4.git
 > git --version # timeout=10
 > git fetch --tags --progress git://git.postgresql.org/git/pgadmin4.git +refs/heads/*:refs/remotes/origin/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 5f51c39e6f8d6570914c4afdc2291abca2cb737f (origin/master)
Commit message: "Delete the venv folder prior to upgrade. Fixes #3384"
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 5f51c39e6f8d6570914c4afdc2291abca2cb737f
 > git rev-list ba8829b64ff6c75aebd823743e8833ab0b531a4f # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
PYTHON_VERSION=3.3

[EnvInject] - Variables injected successfully.
[pgadmin4-master-python33] $ /bin/sh -xe /tmp/jenkins248602795526589024.sh
+ <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/ci/ci_runner.sh>
EXECUTING: Create pgAdmin config

EXECUTING: Python tests

Creating Python 3.3 virtual environment...

Using base prefix '/usr/local/python-3.3'
New python executable in <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/bin/python3>
Also creating executable in <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/bin/python>
Installing setuptools, pip...done.
Running virtualenv with interpreter /usr/local/python-3.3/bin/python3
DEPRECATION: Python 3.3 supported has been deprecated and support for it will be dropped in the future. Please upgrade your Python.
Collecting wheel==0.29.0
  Using cached https://files.pythonhosted.org/packages/8a/e9/8468cd68b582b06ef554be0b96b59f59779627131aad48f8a5bce4b13450/wheel-0.29.0-py2.py3-none-any.whl
Installing collected packages: wheel
Successfully installed wheel-0.29.0
DEPRECATION: Python 3.3 supported has been deprecated and support for it will be dropped in the future. Please upgrade your Python.
Ignoring backports.csv: markers 'python_version <= "2.7"' don't match your environment
Ignoring importlib: markers 'python_version <= "2.7"' don't match your environment
Ignoring psycopg2: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-Script: markers 'python_version < "2.7"' don't match your environment
Ignoring ordereddict: markers 'python_version < "2.7"' don't match your environment
Ignoring python-dateutil: markers 'python_version < "2.7"' don't match your environment
Ignoring SQLAlchemy: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-Security: markers 'python_version < "2.7"' don't match your environment
Ignoring Flask-BabelEx: markers 'python_version < "2.7"' don't match your environment
Collecting blinker==1.4 (from -r requirements.txt (line 6))
Collecting extras==1.0.0 (from -r requirements.txt (line 7))
  Using cached https://files.pythonhosted.org/packages/03/e9/e915af1f97914cd0bc021e125fd1bfd4106de614a275e4b6866dd9a209ac/extras-1.0.0-py2.py3-none-any.whl
Collecting fixtures==3.0.0 (from -r requirements.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/a8/28/7eed6bf76792f418029a18d5b2ace87ce7562927cdd00f1cefe481cd148f/fixtures-3.0.0-py2.py3-none-any.whl
Collecting Flask==0.12.2 (from -r requirements.txt (line 9))
  Using cached https://files.pythonhosted.org/packages/77/32/e3597cb19ffffe724ad4bf0beca4153419918e7fa4ba6a34b04ee4da3371/Flask-0.12.2-py2.py3-none-any.whl
Collecting Flask-Gravatar==0.5.0 (from -r requirements.txt (line 10))
  Using cached https://files.pythonhosted.org/packages/58/4a/b20260e8d383d0037f2791dd8a3f3ea729ca9f02d7638677a34a236a8702/Flask_Gravatar-0.5.0-py2.py3-none-any.whl
Collecting Flask-Login==0.3.2 (from -r requirements.txt (line 11))
Collecting Flask-Mail==0.9.1 (from -r requirements.txt (line 12))
Collecting Flask-Migrate==2.1.1 (from -r requirements.txt (line 13))
  Using cached https://files.pythonhosted.org/packages/c6/06/053630cb5fe3974c7d60c2d3f3907bae6ff86beb8720bd4fcf53c45c6702/Flask_Migrate-2.1.1-py2.py3-none-any.whl
Collecting Flask-Principal==0.4.0 (from -r requirements.txt (line 14))
Collecting Flask-SQLAlchemy==2.3.2 (from -r requirements.txt (line 15))
  Using cached https://files.pythonhosted.org/packages/a1/44/294fb7f6bf49cc7224417cd0637018db9fee0729b4fe166e43e2bbb1f1c8/Flask_SQLAlchemy-2.3.2-py2.py3-none-any.whl
Collecting Flask-WTF==0.14.2 (from -r requirements.txt (line 16))
  Using cached https://files.pythonhosted.org/packages/60/3a/58c629472d10539ae5167dc7c1fecfa95dd7d0b7864623931e3776438a24/Flask_WTF-0.14.2-py2.py3-none-any.whl
Collecting html5lib==1.0.1 (from -r requirements.txt (line 17))
  Using cached https://files.pythonhosted.org/packages/a5/62/bbd2be0e7943ec8504b517e62bab011b4946e1258842bc159e5dfde15b96/html5lib-1.0.1-py2.py3-none-any.whl
Collecting linecache2==1.0.0 (from -r requirements.txt (line 18))
  Using cached https://files.pythonhosted.org/packages/c7/a3/c5da2a44c85bfbb6eebcfc1dde24933f8704441b98fdde6528f4831757a6/linecache2-1.0.0-py2.py3-none-any.whl
Collecting passlib==1.7.1 (from -r requirements.txt (line 19))
  Using cached https://files.pythonhosted.org/packages/ee/a7/d6d238d927df355d4e4e000670342ca4705a72f0bf694027cf67d9bcf5af/passlib-1.7.1-py2.py3-none-any.whl
Collecting pbr==3.1.1 (from -r requirements.txt (line 20))
  Using cached https://files.pythonhosted.org/packages/0c/5d/b077dbf309993d52c1d71e6bf6fe443a8029ea215135ebbe0b1b10e7aefc/pbr-3.1.1-py2.py3-none-any.whl
Collecting pycrypto>=2.6.1 (from -r requirements.txt (line 21))
Collecting pyrsistent==0.14.2 (from -r requirements.txt (line 22))
Collecting python-mimeparse==1.6.0 (from -r requirements.txt (line 23))
  Using cached https://files.pythonhosted.org/packages/26/2e/03bce213a9bf02a2750dcb04e761785e9c763fc11071edc4b447eacbb842/python_mimeparse-1.6.0-py2.py3-none-any.whl
Collecting pytz==2018.3 (from -r requirements.txt (line 24))
  Using cached https://files.pythonhosted.org/packages/3c/80/32e98784a8647880dedf1f6bf8e2c91b195fe18fdecc6767dcf5104598d6/pytz-2018.3-py2.py3-none-any.whl
Collecting simplejson==3.13.2 (from -r requirements.txt (line 25))
Collecting six>=1.11.0 (from -r requirements.txt (line 26))
  Using cached https://files.pythonhosted.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl
Collecting speaklater==1.3 (from -r requirements.txt (line 27))
Collecting sqlparse==0.2.4 (from -r requirements.txt (line 28))
  Using cached https://files.pythonhosted.org/packages/65/85/20bdd72f4537cf2c4d5d005368d502b2f464ede22982e724a82c86268eda/sqlparse-0.2.4-py2.py3-none-any.whl
Collecting WTForms==2.1 (from -r requirements.txt (line 29))
Collecting Flask-Paranoid==0.2.0 (from -r requirements.txt (line 30))
  Using cached https://files.pythonhosted.org/packages/0e/14/359033a218c5403872e11ff7267e6c638c0279067fa932d93653188f4052/Flask_Paranoid-0.2.0-py2.py3-none-any.whl
Collecting psycopg2>=2.7.4 (from -r requirements.txt (line 35))
  Downloading https://files.pythonhosted.org/packages/b2/c1/7bf6c464e903ffc4f3f5907c389e5a4199666bf57f6cd6bf46c17912a1f9/psycopg2-2.7.5.tar.gz (426kB)
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/psycopg2.egg-info
    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
    writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
    writing pip-egg-info/psycopg2.egg-info/PKG-INFO
    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
    
    Error: pg_config executable not found.
    
    pg_config is required to build psycopg2 from source.  Please add the directory
    containing pg_config to the $PATH or specify the full executable path with the
    option:
    
        python setup.py build_ext --pg-config /path/to/pg_config build ...
    
    or with the pg_config option in 'setup.cfg'.
    
    If you prefer to avoid building psycopg2 from source, please install the PyPI
    'psycopg2-binary' package instead.
    
    For further information please check the 'doc/src/install.rst' file (also at
    <http://initd.org/psycopg/docs/install.html>).

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-_cbwgx/psycopg2/
ERROR: Failed to install the application requirements.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Mon, 18 Jun 2018 04:43:15 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/662/display/redirect?page=changes>

Changes:

[Ashesh Vashi] Flask 1.0.2 does not allow a dot (.) in the view_func name, which we use

Cleaning workspace
Resetting working tree
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision f2cef3836421d733df9260edb22b9db4bf19a3b9 (origin/master)
Commit message: "Flask 1.0.2 does not allow a dot (.) in the view_func name, which we use during generting the routes for the node."
 > git checkout -f f2cef3836421d733df9260edb22b9db4bf19a3b9
 > git rev-list 5f51c39e6f8d6570914c4afdc2291abca2cb737f # timeout=10

[EnvInject] - Variables injected successfully.
[pgadmin4-master-python33] $ /bin/sh -xe /tmp/jenkins6159280496175318164.sh
+ <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/ci/ci_runner.sh>
EXECUTING: Create pgAdmin config

EXECUTING: Python tests

  Using cached https://files.pythonhosted.org/packages/b2/c1/7bf6c464e903ffc4f3f5907c389e5a4199666bf57f6cd6bf46c17912a1f9/psycopg2-2.7.5.tar.gz

    

    

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-_9r4mt/psycopg2/

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Mon, 18 Jun 2018 16:07:42 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/663/display/redirect>

------------------------------------------
[...truncated 8.51 KB...]
  Cache entry deserialization failed, entry ignored
Collecting Flask-Paranoid==0.2.0 (from -r requirements.txt (line 30))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/0e/14/359033a218c5403872e11ff7267e6c638c0279067fa932d93653188f4052/Flask_Paranoid-0.2.0-py2.py3-none-any.whl
Collecting psycopg2>=2.7.4 (from -r requirements.txt (line 35))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/b2/c1/7bf6c464e903ffc4f3f5907c389e5a4199666bf57f6cd6bf46c17912a1f9/psycopg2-2.7.5.tar.gz
Collecting python-dateutil>=2.7.1 (from -r requirements.txt (line 36))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/cf/f5/af2b09c957ace60dcfac112b669c45c8c97e32f94aa8b56da4c6d1682825/python_dateutil-2.7.3-py2.py3-none-any.whl
Collecting htmlmin==0.1.12 (from -r requirements.txt (line 37))
  Cache entry deserialization failed, entry ignored
Collecting Flask-HTMLmin==1.3.2 (from -r requirements.txt (line 38))
  Cache entry deserialization failed, entry ignored
Collecting SQLAlchemy>=1.2.5 (from -r requirements.txt (line 39))
  Cache entry deserialization failed, entry ignored
Collecting Flask-Security>=3.0.0 (from -r requirements.txt (line 40))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/88/47/4908a5040120768ff4fb2465c7eeafeb9239c27d2919bd67c4ccc1b43e14/Flask_Security-3.0.0-py2.py3-none-any.whl
Collecting sshtunnel>=0.1.3 (from -r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
Collecting testtools>=0.9.22 (from fixtures==3.0.0->-r requirements.txt (line 8))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/87/74/a4d55da28d7bba6d6f49430f22a62afd8472cb24a63fa61daef80d3e821b/testtools-2.3.0-py2.py3-none-any.whl
Collecting Werkzeug>=0.7 (from Flask==0.12.2->-r requirements.txt (line 9))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/20/c4/12e3e56473e52375aa29c4764e70d1b8f3efa6682bef8d0aae04fe335243/Werkzeug-0.14.1-py2.py3-none-any.whl
Collecting Jinja2>=2.4 (from Flask==0.12.2->-r requirements.txt (line 9))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/7f/ff/ae64bacdfc95f27a016a7bed8e8686763ba4d277a78ca76f32659220a731/Jinja2-2.10-py2.py3-none-any.whl
Collecting itsdangerous>=0.21 (from Flask==0.12.2->-r requirements.txt (line 9))
  Cache entry deserialization failed, entry ignored
Collecting click>=2.0 (from Flask==0.12.2->-r requirements.txt (line 9))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/34/c1/8806f99713ddb993c5366c362b2f908f18269f8d792aff1abfd700775a77/click-6.7-py2.py3-none-any.whl
Collecting alembic>=0.6 (from Flask-Migrate==2.1.1->-r requirements.txt (line 13))
  Cache entry deserialization failed, entry ignored
Collecting webencodings (from html5lib==1.0.1->-r requirements.txt (line 17))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/f4/24/2a3e3df732393fed8b3ebf2ec078f05546de641fe1b667ee316ec1dcf3b7/webencodings-0.5.1-py2.py3-none-any.whl
Collecting Flask-BabelEx>=0.9.3 (from Flask-Security>=3.0.0->-r requirements.txt (line 40))
  Cache entry deserialization failed, entry ignored
Collecting paramiko>=1.15.2 (from sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/3e/db/cb7b6656e0e7387637ce850689084dc0b94b44df31cc52e5fc5c2c4fd2c1/paramiko-2.4.1-py2.py3-none-any.whl
Collecting unittest2>=1.0.0 (from testtools>=0.9.22->fixtures==3.0.0->-r requirements.txt (line 8))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/72/20/7f0f433060a962200b7272b8c12ba90ef5b903e218174301d0abfd523813/unittest2-1.1.0-py2.py3-none-any.whl
Collecting traceback2 (from testtools>=0.9.22->fixtures==3.0.0->-r requirements.txt (line 8))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/17/0a/6ac05a3723017a967193456a2efa0aa9ac4b51456891af1e2353bb9de21e/traceback2-1.4.0-py2.py3-none-any.whl
Collecting MarkupSafe>=0.23 (from Jinja2>=2.4->Flask==0.12.2->-r requirements.txt (line 9))
  Cache entry deserialization failed, entry ignored
Collecting Mako (from alembic>=0.6->Flask-Migrate==2.1.1->-r requirements.txt (line 13))
  Cache entry deserialization failed, entry ignored
Collecting python-editor>=0.3 (from alembic>=0.6->Flask-Migrate==2.1.1->-r requirements.txt (line 13))
  Cache entry deserialization failed, entry ignored
Collecting Babel>=1.0 (from Flask-BabelEx>=0.9.3->Flask-Security>=3.0.0->-r requirements.txt (line 40))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/94/03/14e68ad12e771a79cf96792f7158d68a7b3d8c7b2badf39e9ef1f65b57d6/Babel-2.5.3-py2.py3-none-any.whl
Collecting bcrypt>=3.1.3 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/eb/3b/5bf2027d4758bc57750919c8918226d39527980d781d367483a2b5c6c6b9/bcrypt-3.1.4-cp33-cp33m-manylinux1_x86_64.whl
Collecting pyasn1>=0.1.7 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/a0/70/2c27740f08e477499ce19eefe05dbcae6f19fdc49e9e82ce4768be0643b9/pyasn1-0.4.3-py2.py3-none-any.whl
Collecting pynacl>=1.0.1 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
Collecting cryptography>=1.5 (from paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
Collecting argparse (from unittest2>=1.0.0->testtools>=0.9.22->fixtures==3.0.0->-r requirements.txt (line 8))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Collecting cffi>=1.1 (from bcrypt>=3.1.3->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/11/01/61405d55140631801eb33d6bc37e5d622b27163102d5b93411da246b7bec/cffi-1.11.5-cp33-cp33m-manylinux1_x86_64.whl
Collecting idna>=2.1 (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/4b/2a/0276479a4b3caeb8a8c1af2f8e4355746a97fab05a372e4a2c6a6b876165/idna-2.7-py2.py3-none-any.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=1.5->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting pycparser (from cffi>=1.1->bcrypt>=3.1.3->paramiko>=1.15.2->sshtunnel>=0.1.3->-r requirements.txt (line 41))
  Cache entry deserialization failed, entry ignored
Building wheels for collected packages: psycopg2
  Running setup.py bdist_wheel for psycopg2: started
  Running setup.py bdist_wheel for psycopg2: finished with status 'error'
  Complete output from command <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/bin/python3> -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-b8e694/psycopg2/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/pip-wheel-b45jjk --python-tag cp33:
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build/lib.linux-x86_64-3.3
  creating build/lib.linux-x86_64-3.3/psycopg2
  copying lib/pool.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/errorcodes.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/sql.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/extras.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/_ipaddress.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/_range.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/__init__.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/extensions.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/psycopg1.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/tz.py -> build/lib.linux-x86_64-3.3/psycopg2
  copying lib/_json.py -> build/lib.linux-x86_64-3.3/psycopg2
  creating build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_async_keyword.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_quote.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_lobject.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_green.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_connection.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_sql.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_errcodes.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_bug_gc.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_cancel.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/dbapi20_tpc.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_fast_executemany.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/__init__.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_dates.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_bugX000.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/testconfig.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_async.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_copy.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_ipaddress.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_extras_dictcursor.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_psycopg2_dbapi20.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_types_basic.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_transaction.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_types_extras.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_replication.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_notify.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_module.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_cursor.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/testutils.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/test_with.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  copying tests/dbapi20.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
  Skipping implicit fixer: buffer
  Skipping implicit fixer: idioms
  Skipping implicit fixer: set_literal
  Skipping implicit fixer: ws_comma
  running build_ext
  building 'psycopg2._psycopg' extension
  creating build/temp.linux-x86_64-3.3
  creating build/temp.linux-x86_64-3.3/psycopg
  gcc -pthread -Wno-unused-result -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -DPSYCOPG_DEFAULT_PYDATETIME=1 -DPSYCOPG_VERSION=2.7.5 (dt dec pq3 ext lo64) -DPG_VERSION_NUM=100000 -DHAVE_LO64=1 -I/usr/local/python-3.3/include/python3.3m -I. -I/usr/pgsql-10/include -I/usr/pgsql-10/include/server -c psycopg/psycopgmodule.c -o build/temp.linux-x86_64-3.3/psycopg/psycopgmodule.o -Wdeclaration-after-statement
  In file included from psycopg/psycopgmodule.c:27:0:
  ./psycopg/psycopg.h:35:22: fatal error: libpq-fe.h: No such file or directory
   #include <libpq-fe.h>
                        ^
  compilation terminated.
  
  It appears you are missing some prerequisite to build the package from source.
  
  You may install a binary package by installing 'psycopg2-binary' from PyPI.
  If you want to install psycopg2 from source, please install the packages
  required for the build and try again.

  error: command 'gcc' failed with exit status 1
  
  ----------------------------------------
  Failed building wheel for psycopg2
  Running setup.py clean for psycopg2
Failed to build psycopg2
Installing collected packages: blinker, extras, six, pbr, linecache2, traceback2, argparse, unittest2, python-mimeparse, testtools, fixtures, Werkzeug, MarkupSafe, Jinja2, itsdangerous, click, Flask, Flask-Gravatar, Flask-Login, Flask-Mail, SQLAlchemy, Flask-SQLAlchemy, Mako, python-dateutil, python-editor, alembic, Flask-Migrate, Flask-Principal, WTForms, Flask-WTF, webencodings, html5lib, passlib, pycrypto, pyrsistent, pytz, simplejson, speaklater, sqlparse, Flask-Paranoid, psycopg2, htmlmin, Flask-HTMLmin, Babel, Flask-BabelEx, Flask-Security, pycparser, cffi, bcrypt, pyasn1, pynacl, idna, asn1crypto, cryptography, paramiko, sshtunnel
  Running setup.py install for psycopg2: started
    Running setup.py install for psycopg2: finished with status 'error'
    Complete output from command <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/bin/python3> -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-b8e694/psycopg2/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-qg5zqc/install-record.txt --single-version-externally-managed --compile --install-headers <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/include/site/python3.3/psycopg2>:
    running install
    running build
    running build_py
    creating build
    creating build/lib.linux-x86_64-3.3
    creating build/lib.linux-x86_64-3.3/psycopg2
    copying lib/pool.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/errorcodes.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/sql.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/extras.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/_ipaddress.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/_range.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/__init__.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/extensions.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/psycopg1.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/tz.py -> build/lib.linux-x86_64-3.3/psycopg2
    copying lib/_json.py -> build/lib.linux-x86_64-3.3/psycopg2
    creating build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_async_keyword.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_quote.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_lobject.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_green.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_connection.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_sql.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_errcodes.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_bug_gc.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_cancel.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/dbapi20_tpc.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_fast_executemany.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/__init__.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_dates.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_bugX000.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/testconfig.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_async.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_copy.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_ipaddress.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_extras_dictcursor.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_psycopg2_dbapi20.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_types_basic.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_transaction.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_types_extras.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_replication.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_notify.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_module.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_cursor.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/testutils.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/test_with.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    copying tests/dbapi20.py -> build/lib.linux-x86_64-3.3/psycopg2/tests
    Skipping implicit fixer: buffer
    Skipping implicit fixer: idioms
    Skipping implicit fixer: set_literal
    Skipping implicit fixer: ws_comma
    running build_ext
    building 'psycopg2._psycopg' extension
    creating build/temp.linux-x86_64-3.3
    creating build/temp.linux-x86_64-3.3/psycopg
    gcc -pthread -Wno-unused-result -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -DPSYCOPG_DEFAULT_PYDATETIME=1 -DPSYCOPG_VERSION=2.7.5 (dt dec pq3 ext lo64) -DPG_VERSION_NUM=100000 -DHAVE_LO64=1 -I/usr/local/python-3.3/include/python3.3m -I. -I/usr/pgsql-10/include -I/usr/pgsql-10/include/server -c psycopg/psycopgmodule.c -o build/temp.linux-x86_64-3.3/psycopg/psycopgmodule.o -Wdeclaration-after-statement
    In file included from psycopg/psycopgmodule.c:27:0:
    ./psycopg/psycopg.h:35:22: fatal error: libpq-fe.h: No such file or directory
     #include <libpq-fe.h>
                          ^
    compilation terminated.
    
    It appears you are missing some prerequisite to build the package from source.
    
    You may install a binary package by installing 'psycopg2-binary' from PyPI.
    If you want to install psycopg2 from source, please install the packages
    required for the build and try again.

    error: command 'gcc' failed with exit status 1
    
Command "<https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/bin/python3> -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-b8e694/psycopg2/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-qg5zqc/install-record.txt --single-version-externally-managed --compile --install-headers <https://jenkins.pgadmin.org/job/pgadmin4-master-python33/ws/pgadmin-venv/include/site/python3.3/psycopg2"> failed with error code 1 in /tmp/pip-install-b8e694/psycopg2/