Subject: Build failed in Jenkins: pgadmin4-master-python35 #511

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 13:45:26 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python35/511/display/redirect?page=changes>

Changes:

[Dave Page] Ensure all messages are retrieved from the server in the Query Tool.

------------------------------------------
[...truncated 605.33 KB...]
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageAddTestCase (Fetch Package Node URL)

PostgreSQL 9.4:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageAddTestCase (Fetch Package Node URL)

EDB Postgres AS 9.6:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TestSSLConnection (Test for SSL connection)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)

EDB Postgres AS 9.4:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TestSSLConnection (Test for SSL connection)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)

EDB Postgres AS 9.3:

	280 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	7 tests skipped:
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsAddTestCase (Add resource groups)
		TestSSLConnection (Test for SSL connection)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		ResourceGroupsPutTestCase (Put resource groups)

PostgreSQL 9.3:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageAddTestCase (Fetch Package Node URL)

PostgreSQL 10:

	274 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	13 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageAddTestCase (Fetch Package Node URL)

PostgreSQL 9.2:

	265 tests passed
	0 tests failed
	23 tests skipped:
		ViewsUpdateTestCase (Update materialized view under schema node)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageAddTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		SynonymAddTestCase (Default Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		TestSSLConnection (Test for SSL connection)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		ViewsGetTestCase (Get materialized view under schema node)
		ViewsAddTestCase (Add materialized view under schema node)

EDB Postgres AS 9.2:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		ViewsDeleteTestCase (Delete materialized view under schema node)
		ViewsUpdateTestCase (Update materialized view under schema node)
		ResourceGroupsAddTestCase (Add resource groups)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		ViewsGetTestCase (Get materialized view under schema node)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		ViewsAddTestCase (Add materialized view under schema node)
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python35/ws/web/regression/regression.log>

PostgreSQL 9.5:

	272 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	15 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		PackageAddTestCase (Fetch Package Node URL)

======================================================================

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 16:33:35 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python35/512/display/redirect?page=changes>

Changes:

[Dave Page] Update Jasmine to v3. Fixes #3182

[Dave Page] Insert rows correctly when a table has OIDs and a Primary Key in

[...truncated 611.77 KB...]

EDB Postgres AS 9.2:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing range partitioned table)

EDB Postgres AS 9.3:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	7 tests skipped:
		ResourceGroupsAddTestCase (Add resource groups)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table)

EDB Postgres AS 9.4:

	288 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 9.4:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing range partitioned table)

PostgreSQL 9.3:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing range partitioned table)

EDB Postgres AS 9.5:

	288 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table)
		TestSSLConnection (Test for SSL connection)

EDB Postgres AS 9.6:

	288 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Create partitions of existing list partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 9.2:

	269 tests passed
	0 tests failed
	23 tests skipped:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing range partitioned table)

PostgreSQL 9.6:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing range partitioned table)

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Wed, 7 Mar 2018 17:05:33 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python35/513/display/redirect?page=changes>

Changes:

[Dave Page] Allow admins to disable the use of Gravatar if they choose. Fixes #3037

[Dave Page] Make the poll query test a little more robust.

------------------------------------------
[...truncated 610.75 KB...]
		PackageDeleteTestCase (Fetch Package Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsPutTestCase (Put resource groups)
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymAddTestCase (Default Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		SynonymDeleteTestCase (Fetch synonym Node URL)

PostgreSQL 9.5:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table)

EDB Postgres AS 9.3:

	284 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	7 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		ResourceGroupsAddTestCase (Add resource groups)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsPutTestCase (Put resource groups)
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)

EDB Postgres AS 9.6:

	288 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 10:

	278 tests passed
	1 test failed:

EDB Postgres AS 9.4:

	288 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		TestSSLConnection (Test for SSL connection)

EDB Postgres AS 9.5:

	288 tests passed
	1 test failed:
		TestPollQueryTool (When query tool polling returns messages with result data-set)
	3 tests skipped:
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Attach partition to existing range partitioned table,
					Detach partition from existing list partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Create partitions of existing range partitioned table)
		TestSSLConnection (Test for SSL connection)

PostgreSQL 9.4:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table)

EDB Postgres AS 9.2:

	276 tests passed
	1 test failed:
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table)

PostgreSQL 9.2:

	269 tests passed
	0 tests failed
	23 tests skipped:
		TableUpdateTestCase (Attach partition to existing list partitioned table,
					Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table)