Subject: Build failed in Jenkins: pgadmin4-master-python26 #790

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Fri, 15 Jun 2018 11:00:49 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/790/display/redirect?page=changes>

Changes:

[Dave Page] Add Python API tests for execution of external utilities such as

------------------------------------------
[...truncated 834.16 KB...]
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		PgAgentAddTestCase (Add pgAgent job)
		PgAgentPutTestCase (Put pgAgent job)
		BackupCreateJobTest (When backup the object with option sections to all data,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option only_data,
					When backup the server,
					When backup globals,
					When backup the object with option - miscellaneous,
					When backup the object with option - all queries,
					When backup the object with option - format plain and dns_owner,
					When backup object with default options,
					When backup the object with option - all queries and format custom,
					When backup the object with format tar,
					When backup the object with option only_schema)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		BackupJobTest (When backup the object with the default options)
		RestoreCreateJobTest (When restore object with option - Disbale,
					When restore the object with Type of objects,
					When restore object with option - Miscellaneous,
					When restore object with option - Do not save,
					When restore object with default options,
					When restore object with option - Queries,
					When restore object with the sections options)
		RestoreJobTest (When restore the object with the default options)
		PgAgentGetTestCase (Get pgAgent job)
		PgAgentDeleteTestCase (Delete pgAgent job)

EDB Postgres AS 9.6:

	348 tests passed
	1 test failed:
		BatchProcessTest (When restore server,
					When backup object,
					When maintained server,
					When backup server,
					When backup globals)
	14 tests skipped:
		MaintenanceJobTest (When maintenance the object with the default options)
		MaintenanceCreateJobTest (When maintenance the object with the CLUSTER,
					When maintenance object with VACUUM FULL,
					When maintenance object with the ANALYZE,
					When maintenance the object with the REINDEX,
					When maintenance object with default options)
		TestSSLConnection (Test for SSL connection)
		PgAgentStatsTestCase (Check the stats of pgAgent job)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		PgAgentAddTestCase (Add pgAgent job)
		PgAgentPutTestCase (Put pgAgent job)
		BackupCreateJobTest (When backup the object with option sections to all data,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option only_data,
					When backup the server,
					When backup globals,
					When backup the object with option - miscellaneous,
					When backup the object with option - all queries,
					When backup the object with option - format plain and dns_owner,
					When backup object with default options,
					When backup the object with option - all queries and format custom,
					When backup the object with format tar,
					When backup the object with option only_schema)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		BackupJobTest (When backup the object with the default options)
		RestoreCreateJobTest (When restore object with option - Disbale,
					When restore the object with Type of objects,
					When restore object with option - Miscellaneous,
					When restore object with option - Do not save,
					When restore object with default options,
					When restore object with option - Queries,
					When restore object with the sections options)
		RestoreJobTest (When restore the object with the default options)
		PgAgentGetTestCase (Get pgAgent job)
		PgAgentDeleteTestCase (Delete pgAgent job)

EDB Postgres AS 9.2:

	336 tests passed
	1 test failed:
		BatchProcessTest (When restore server,
					When backup object,
					When maintained server,
					When backup server,
					When backup globals)
	26 tests skipped:
		TestSSLConnection (Test for SSL connection)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		RestoreJobTest (When restore the object with the default options)
		ViewsGetTestCase (Get materialized view under schema node)
		PgAgentPutTestCase (Put pgAgent job)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		ViewsAddTestCase (Add materialized view under schema node)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		MaintenanceJobTest (When maintenance the object with the default options)
		MaintenanceCreateJobTest (When maintenance the object with the CLUSTER,
					When maintenance object with VACUUM FULL,
					When maintenance object with the ANALYZE,
					When maintenance the object with the REINDEX,
					When maintenance object with default options)
		PgAgentStatsTestCase (Check the stats of pgAgent job)
		PgAgentAddTestCase (Add pgAgent job)
		ResourceGroupsAddTestCase (Add resource groups)
		BackupCreateJobTest (When backup the object with option sections to all data,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option only_data,
					When backup the server,
					When backup globals,
					When backup the object with option - miscellaneous,
					When backup the object with option - all queries,
					When backup the object with option - format plain and dns_owner,
					When backup object with default options,
					When backup the object with option - all queries and format custom,
					When backup the object with format tar,
					When backup the object with option only_schema)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		BackupJobTest (When backup the object with the default options)
		RestoreCreateJobTest (When restore object with option - Disbale,
					When restore the object with Type of objects,
					When restore object with option - Miscellaneous,
					When restore object with option - Do not save,
					When restore object with default options,
					When restore object with option - Queries,
					When restore object with the sections options)
		ResourceGroupsPutTestCase (Put resource groups)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		PgAgentGetTestCase (Get pgAgent job)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		PgAgentDeleteTestCase (Delete pgAgent job)
		ViewsUpdateTestCase (Update materialized view under schema node)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)

EDB Postgres AS 9.3:

	344 tests passed
	1 test failed:
		BatchProcessTest (When restore server,
					When backup object,
					When maintained server,
					When backup server,
					When backup globals)
	18 tests skipped:
		MaintenanceJobTest (When maintenance the object with the default options)
		MaintenanceCreateJobTest (When maintenance the object with the CLUSTER,
					When maintenance object with VACUUM FULL,
					When maintenance object with the ANALYZE,
					When maintenance the object with the REINDEX,
					When maintenance object with default options)
		TestSSLConnection (Test for SSL connection)
		PgAgentStatsTestCase (Check the stats of pgAgent job)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		PgAgentAddTestCase (Add pgAgent job)
		BackupCreateJobTest (When backup the object with option sections to all data,
					When backup the object with option - Do not save privilege, tablespace, unlogged table data,
					When backup the object with option only_data,
					When backup the server,
					When backup globals,
					When backup the object with option - miscellaneous,
					When backup the object with option - all queries,
					When backup the object with option - format plain and dns_owner,
					When backup object with default options,
					When backup the object with option - all queries and format custom,
					When backup the object with format tar,
					When backup the object with option only_schema)
		PgAgentPutTestCase (Put pgAgent job)
		ResourceGroupsAddTestCase (Add resource groups)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		BackupJobTest (When backup the object with the default options)
		RestoreCreateJobTest (When restore object with option - Disbale,
					When restore the object with Type of objects,
					When restore object with option - Miscellaneous,
					When restore object with option - Do not save,
					When restore object with default options,
					When restore object with option - Queries,
					When restore object with the sections options)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsGetTestCase (Get resource groups)
		PgAgentGetTestCase (Get pgAgent job)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		PgAgentDeleteTestCase (Delete pgAgent job)
		RestoreJobTest (When restore the object with the default options)

======================================================================

NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/regression/regression.log>

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Fri, 15 Jun 2018 11:59:23 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/791/display/redirect?page=changes>

Changes:

[Dave Page] Fix external utilities to run with Python 2.6.

[...truncated 887.35 KB...]

EDB Postgres AS 9.6:

	348 tests passed
	1 test failed:

EDB Postgres AS 9.2:

	336 tests passed
	1 test failed:

EDB Postgres AS 9.3:

	344 tests passed
	1 test failed:

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Fri, 15 Jun 2018 14:37:08 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/792/display/redirect?page=changes>