Subject: pgAdmin4 2.1 on apt.postgresql.org

From: Christoph Berg <[email-masked]>
Date: Thu, 25 Jan 2018 15:20:50 +0100

pgAdmin 4 (https://www.pgadmin.org/) is now also available via the
Debian and Ubuntu repository https://apt.postgresql.org/. The
previously not yet packaged Python modules have all been converted to
proper Debian packages by credativ.

Supported Debian releases are stretch and jessie, as well as the
development branches buster and sid. Supported Ubuntu releases are
xenial and the to-be-released-in-April bionic.

There are two package flavors:
* pgadmin4: GUI (desktop) application
* pgadmin4-apache2: WSGI (web) application

pgAdmin 4 has not yet been uploaded to Debian unstable; while the
required JavaScript libraries are all open source, many are have not
yet been packaged as proper Debian packaged, which is a prerequisite
for uploading pgAdmin itself. credativ is working on fixing this for
the Debian buster release.

Christoph
-- 
Senior Berater, Tel.: +49 2166 9901 187
credativ GmbH, HRB Mönchengladbach 12080, USt-ID-Nummer: DE204566209
Trompeterallee 108, 41189 Mönchengladbach
Geschäftsführung: Dr. Michael Meskes, Jörg Folz, Sascha Heuer
pgp fingerprint: 5C48 FE61 57F4 9179 5970  87C6 4C5A 6BAB 12D2 A7AE

---

From: Dave Page <[email-masked]>
Date: Fri, 26 Jan 2018 16:34:18 +0000

For those that may not watch -announce....

---------- Forwarded message ----------
From: Christoph Berg <[email-masked]>
Date: Thu, Jan 25, 2018 at 2:20 PM
Subject: pgAdmin4 2.1 on apt.postgresql.org
To: PostgreSQL Announce <[email-masked]>

Christoph

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Johann Spies <[email-masked]>
Date: Mon, 29 Jan 2018 09:50:03 +0200

> proper Debian packages by credativ.

Thank you for this.

Regards
Johann

-- 
Johann Spies                            Telefoon: 021-808 4699
Databestuurder /  Data manager		Faks: 021-883 3691

Sentrum vir Navorsing oor Evaluasie, Wetenskap en Tegnologie
Centre for Research on Evaluation, Science and Technology 
Universiteit Stellenbosch.

The integrity and confidentiality of this e-mail is governed by these terms / Die integriteit en vertroulikheid van hierdie e-pos word deur die volgende bepalings gereël. http://www.sun.ac.za/emaildisclaimer

---

From: Christoph Berg <[email-masked]>
Date: Wed, 31 Jan 2018 10:59:12 +0100

Re: [email-masked] 2018-01-30 <CAMXa=[email-masked]>
> Hello,
> 
> 
> I have not find any documentation about. I've installed on Ubuntu pgadmin4
> using apt-get install but it doesn't start. It says: "The application
> server could not be contacted."
> 
> 
> Are there steps between the apt-get and the run command to do?

Hi,

the stretch and xenial GUI packages seem to be buggy, I'm
investigating. Will report back later.

Christoph

---

From: Christoph Berg <[email-masked]>
Date: Wed, 31 Jan 2018 12:48:38 +0100

Re: Dave Page 2018-01-26 <CA+OCxoy77QbBLotBt1n2XL=[email-masked]>
> Supported Debian releases are stretch and jessie, as well as the

Sorry this was a typo. Only "stretch" is supported, plus the
development branches.

Christoph

---

From: Dave Page <[email-masked]>
Date: Wed, 31 Jan 2018 13:52:35 +0000

> > xenial and the to-be-released-in-April bionic.

Thanks Christoph. I've updated the text on the website to read:

DEBs for Debian Stretch and Ubuntu Xenial and later are available from the
PostgreSQL apt repository.

Please let me know if you want to change that at all.

---

From: Christoph Berg <[email-masked]>
Date: Wed, 31 Jan 2018 21:43:31 +0100

Hi,

thanks for the reports, the pgadmin4.deb GUI package now works.

The problem was that PYTHONPATH was not set properly, which I didn't
notice in my tests because I had a ~/.config/pgadmin/pgadmin4.conf
locally which papered over the problem. Sorry for that - we don't have
regression tests in GUI deb packages yet...

Christoph

---

From: Christoph Berg <[email-masked]>
Date: Thu, 1 Feb 2018 09:05:33 +0100

Re: Dave Page 2018-01-31 <[email-masked]>
> Please let me know if you want to change that at all.

That's fine, thanks. Sorry for getting the list wrong in the first
place...

Christoph

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 1 Feb 2018 07:02:50 -0200

Thank You.

It really worked.

Sds,

Alan Carvalho Galante, D.Sc.
Analista de Sistemas

---

From: Christoph Berg <[email-masked]>
Date: Thu, 1 Mar 2018 18:07:39 +0100

Re: Wim Bertels 2018-03-01 <[email-masked]>
> Hallo Christoph,
> 
> on debian stable i now get:
> 
> $ pgadmin4 
> Python path:  "/usr/lib/python3/dist-packages" 
> Python Home:  ""
> Webapp path:  "/usr/share/pgadmin4/web/pgAdmin4.py"
> /usr/lib/python3/dist-packages/flask_migrate/__init__.py:4: ExtDeprecationWarning: Importing flask.ext.script is deprecated, use flask_script instead.
>   from flask.ext.script import Manager
> [0301/152904:ERROR:nss_util.cc(839)] After loading Root Certs, loaded==false: NSS error code: -8018
> nouveau: kernel rejected pushbuf: Bestand of map bestaat niet
> nouveau: ch8: krec 0 pushes 0 bufs 2 relocs 0
> nouveau: ch8: buf 00000000 00000002 00000004 00000004 00000000
> nouveau: ch8: buf 00000001 00000006 00000004 00000000 00000004
> Segmentatiefout

Hi Wim,

the error here is somewhere in the (nouveau) graphics stack, I don't
think I can do anything on the packaging side about it, as pgadmin4 is
likely not to blame. Not sure what we could do to help you.

Christoph