Subject: Build failed in Jenkins: pgadmin4-master-python34 #510

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 13 Mar 2018 12:32:49 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python34/510/display/redirect?page=changes>

Changes:

[Dave Page] Fix template path generation for Windows. Fixes #3139

------------------------------------------
[...truncated 726.23 KB...]
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)

EDB Postgres AS 9.3:

	286 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	7 tests skipped:
		ResourceGroupsPutTestCase (Put resource groups)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsGetTestCase (Get resource groups)

PostgreSQL 10:

	280 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	13 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		PackageAddTestCase (Fetch Package Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsAddTestCase (Add resource groups)
		SynonymPutTestCase (Fetch synonym Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)

PostgreSQL 9.5:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	15 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		PackageAddTestCase (Fetch Package Node URL)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)
		PackagePutTestCase (Fetch Package Node URL)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsGetTestCase (Get resource groups)

EDB Postgres AS 9.6:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	3 tests skipped:
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)
NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python34/ws/web/regression/regression.log>

PostgreSQL 9.3:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	15 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		PackageAddTestCase (Fetch Package Node URL)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)
		PackagePutTestCase (Fetch Package Node URL)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsGetTestCase (Get resource groups)

EDB Postgres AS 9.5:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	3 tests skipped:
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)

PostgreSQL 9.4:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404)
	15 tests skipped:
		SynonymAddTestCase (Default Node URL)
		PackageGetTestCase (Fetch Package Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymGetTestCase (Fetch synonym Node URL)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		PackageAddTestCase (Fetch Package Node URL)
		TableAddTestCase (Create List partitioned table with 2 partitions,
					Create Range partitioned table with 2 partitions)
		PackagePutTestCase (Fetch Package Node URL)
		TableUpdateTestCase (Attach partition to existing range partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Create partitions of existing list partitioned table,
					Detach partition from existing list partitioned table,
					Attach partition to existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		PackageDeleteTestCase (Fetch Package Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsAddTestCase (Add resource groups)
		ResourceGroupsGetTestCase (Get resource groups)

======================================================================

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 13 Mar 2018 13:31:35 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python34/511/display/redirect?page=changes>