Subject: disable create server

From: Pavy Manuel <[email-masked]>
Date: Thu, 26 Mar 2020 22:26:27 +0000

Hello,

I'm new in the pgadmin list.
I try to deploy pgadmin4 on my company but I want to manage the connections (server in pgadmin) the users can create.
So, I've found the line 84 of pgadmin/dashboard/templates/dashboard/welcome_dashboard.html to disable the link :
<a href="#" onclick="pgAdmin.Dashboard.add_new_server()">

, but I don't find how to disable the context menu in the right of the dashboard (each try has no impact on the application, perhaps caused by some cache or something like that).

Can someone help me please ? Is there any other way to do what I want ?

Thanks,

Manuel Pavy

---

From: Khushboo Vashi <[email-masked]>
Date: Fri, 27 Mar 2020 09:54:36 +0530

Hi,

On Fri, Mar 27, 2020 at 3:56 AM Pavy Manuel <[email-masked]> wrote:

> I try to deploy pgadmin4 on my company but I want to manage the
> connections (server in pgadmin) the users can create.
> So, I've found the line 84 of
> pgadmin/dashboard/templates/dashboard/welcome_dashboard.html to disable the
> link :
> , but I don't find how to disable the context menu in the right of the
> dashboard (each try has no impact on the application, perhaps caused by
> some cache or something like that).
>
> I didn't get the idea of stopping users to create servers. If any user has
database access (may be limited) then he should be able to create it and
manage it as pgAdmin *just connects* the database with the given details in
the server dialog.

Thanks,
Khushboo

Thanks,

---

From: Dave Page <[email-masked]>
Date: Fri, 27 Mar 2020 10:31:37 +0000

On Fri, Mar 27, 2020 at 4:24 AM Khushboo Vashi <
[email-masked]> wrote:

>> I didn't get the idea of stopping users to create servers. If any user
> has database access (may be limited) then he should be able to create it
> and manage it as pgAdmin *just connects* the database with the given
> details in the server dialog.
>

It seems like a reasonable request to me - for example, to stop students
adding random servers to a shared instance of pgAdmin that they're only
supposed to be using for coursework.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 27 Mar 2020 16:04:01 +0530

On Fri, Mar 27, 2020 at 4:01 PM Dave Page <[email-masked]> wrote:

>> pgAdmin saves server list per user.
You may need to keep that in mind.

> supposed to be using for coursework.
Agreed.

-- Thanks, Ashesh

---

From: Pavy Manuel <[email-masked]>
Date: Fri, 27 Mar 2020 12:41:55 +0000

Thank you all.

Yes I’m aware of that

It seems like a reasonable request to me - for example, to stop students adding random servers to a shared instance of pgAdmin that they're only supposed to be using for coursework.
Agreed.

My need is different : I deploy pgadmin4 in an ansible role which deploy the following (inside the [ ] ) :
User  ---->  [ Apache --->  pgadmin ----> pgbouncer ]  ----->  postgresql backend
And I have a script for adding a server for a specific user which create a pool and add the server tuple in the sqlite3 db.
The benefit is :
- I can serialize the connections (some users open many, many tabs)
- users who do not close their connections are not a problem (thanks to the pgbouncer timeout)
- I can reserve some connection to the production chain
- I can monitor the pool

Since yesterday, I’ve found a (ugly) solution : in the ./pgadmin/static/js/generated/browser_nodes.js, I deactivate the Server action.

But the pretty way should be to create a dedicated profile (in addition of administrator and user).

Manuel Pavy

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 30 Mar 2020 09:05:58 +0530

Hi,

On Fri, Mar 27, 2020 at 6:11 PM Pavy Manuel <[email-masked]> wrote:

> And I have a script for adding a server for a specific user which create a
> pool and add the server tuple in the sqlite3 db.
>
> The benefit is :
>
> Since yesterday, I’ve found a (ugly) solution : in the
> ./pgadmin/static/js/generated/browser_nodes.js, I deactivate the Server
> action.
>
>
>
Please create a feature request @
https://redmine.postgresql.org/projects/pgadmin4 .

Thanks,
Khushboo

---

From: Pavy Manuel <[email-masked]>
Date: Mon, 30 Mar 2020 09:05:21 +0000

Hello,

But the pretty way should be to create a dedicated profile (in addition of administrator and user).
Please create a feature request @ https://redmine.postgresql.org/projects/pgadmin4

Done : https://redmine.postgresql.org/issues/5301

Manuel Pavy

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 30 Mar 2020 14:36:53 +0530

On Mon, Mar 30, 2020 at 2:35 PM Pavy Manuel <[email-masked]> wrote:

> https://redmine.postgresql.org/projects/pgadmin4
>
>
>
Thanks.