Subject: There is an error when checking the major version of servers in schema diff

From: "Huang, Jun" <[email-masked]>
Date: Sun, 17 Jan 2021 12:58:32 +0000

Hi,

The function get_round_val() outputs the wrong value when major version is before 10.
For example,
   Source server version: 90500
   Target server version: 90502
Or
   Source server version: 90502
   Target server version: 90602

The attached patch shows the changes.
--
Thanks && regards
HuangJ

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 18 Jan 2021 16:40:58 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*