Subject: pgAdmin III commit: As per commit:600daf650bd5e50e664c4ece2e53e95446390

From: Ashesh Vashi <[email-masked]>
Date: Mon, 12 Oct 2015 02:33:34 +0000

As per commit:600daf650bd5e50e664c4ece2e53e95446390b6d, we now use
pg_get_function_result(..) function to identify the return type of the
function, hence - we don't need to add SETOF keyword explicitly, when a
function returns set of records.

Branch
------
master

Details
-------
http://git.postgresql.org/gitweb?p=pgadmin3.git;a=commitdiff;h=9d7596dc552cf9315d4aa83eafe19db1acf7e531

Modified Files
--------------
pgadmin/schema/pgFunction.cpp |    2 --
1 file changed, 2 deletions(-)

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Nikolai Zhubr <[email-masked]>
Date: Tue, 05 Jan 2016 14:01:49 +0300

Hi all,

Running 1.22-rc1 now I observe that this commit has apparently still not 
solved the issue in at least one place. That is:

- "RETURNS SETOF record" is correctly displayed in SQL panel now.

- "RETURNS SETOF SETOF record" is still erroneously displayed under SQL 
tab within the properties window (effectively preventing set-returning 
function to be changed in any way through the properties window).

Thank you,
Nikolai

---

From: Dave Page <[email-masked]>
Date: Tue, 5 Jan 2016 11:17:08 +0000

Neel, can you look at this please?

Thanks.

On Tue, Jan 5, 2016 at 11:01 AM, Nikolai Zhubr <[email-masked]> wrote:
> - "RETURNS SETOF SETOF record" is still erroneously displayed under SQL tab
> within the properties window (effectively preventing set-returning function
> to be changed in any way through the properties window).
>
>
> Thank you,
> Nikolai
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Neel Patel <[email-masked]>
Date: Tue, 5 Jan 2016 17:08:08 +0530

Hi Dave,

Sure, I will look into this issue.

Thanks,
Neel Patel

On Tue, Jan 5, 2016 at 4:47 PM, Dave Page <[email-masked]> wrote:

> tab

---

From: Neel Patel <[email-masked]>
Date: Tue, 5 Jan 2016 17:54:06 +0530

Hi,

Please find attached patch file with below fix.
 - Return value of the function will be displayed as "SETOF record" instead
of "SETOF SETOF record" under SQL tab within properties window.

Let me know for any comments.

Thanks,
Neel Patel

---

From: Dave Page <[email-masked]>
Date: Wed, 6 Jan 2016 09:59:13 +0000

Thanks. Ashesh - can you review/commit please?

---

From: Nikolai Zhubr <[email-masked]>
Date: Thu, 07 Jan 2016 15:43:50 +0300

Hello all,

05.01.2016 15:24, Neel Patel:
>   - Return value of the function will be displayed as "SETOF record"
> instead of "SETOF SETOF record" under SQL tab within properties window.
>

Confirmed OK.
Please commit.

Thank you,
Nikolai

---

From: Ashesh Vashi <[email-masked]>
Date: Thu, 7 Jan 2016 18:24:30 +0530

>> Let me know for any comments.
Done.
Thanks.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Nikolai Zhubr <[email-masked]>
Date: Thu, 07 Jan 2016 16:07:56 +0300

Hello all,

Would it also go to REL-1_22_0_PATCHES (so as to be included in the 
upcoming release)?

Thank you,
Nikolai

07.01.2016 15:54, Ashesh Vashi:
[...]

---

From: Ashesh Vashi <[email-masked]>
Date: Thu, 7 Jan 2016 18:39:47 +0530

> Would it also go to REL-1_22_0_PATCHES (so as to be included in the
Yes.

--

Thanks & Regards,

Ashesh Vashi

---

From: Dave Page <[email-masked]>
Date: Thu, 7 Jan 2016 13:10:13 +0000

The upcoming release was cut on Monday, so it definitely won't make
that. 1.22.1 will be the next possible release.

On Thu, Jan 7, 2016 at 1:07 PM, Nikolai Zhubr <[email-masked]> wrote:
> Hello all,
>
> Would it also go to REL-1_22_0_PATCHES (so as to be included in the upcoming
> release)?
>
>
> Thank you,
> Nikolai
>