Subject: Is there a mistake in line 22 of Make.bat?

From: "Huang, Jun" <[email-masked]>
Date: Thu, 14 Jan 2021 01:20:30 +0000

Hi,

The following code is line 22 of Make.bat:
	if "%Platform%" == "X86" (

I tried `echo %Platform%` in VS2017 x86 native Tools Command Prompt, the result is "x86"(not "X86").
If it's a mistake, the attached patch adds the changes.

Regrads,
Huang

---

From: Dave Page <[email-masked]>
Date: Thu, 14 Jan 2021 09:14:43 +0000

Hi

> If it's a mistake, the attached patch adds the changes.

Hmm, on the 32bit build VM I get this:

C:\Program Files (x86)\Microsoft Visual C++ Build Tools>echo %Platform%
X86

C:\Program Files (x86)\Microsoft Visual C++ Build Tools>

Which explains why everything works in the production builds. Note that
that system is VS 2015 though, but the 64 bit builds are VS 2017 iirc.

Given that 32 bit Windows builds will be dropped soon, I'm inclined to
leave this as-is for now.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

---

From: "Huang, Jun" <[email-masked]>
Date: Fri, 15 Jan 2021 00:44:14 +0000

Thanks for your answer.

--
Thanks & Regards
HuangJ

From: Dave Page <[email-masked]>
Sent: Thursday, January 14, 2021 5:15 PM
To: Huang, Jun/黄 军 <[email-masked]>
Cc: [email-masked]
Subject: Re: Is there a mistake in line 22 of Make.bat?

Hi

On Thu, Jan 14, 2021 at 1:20 AM Huang, Jun <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Which explains why everything works in the production builds. Note that that system is VS 2015 though, but the 64 bit builds are VS 2017 iirc.

Given that 32 bit Windows builds will be dropped soon, I'm inclined to leave this as-is for now.