Subject: Build failed in Jenkins: pgadmin4-master-python26 #243

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Fri, 26 May 2017 15:21:49 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/243/display/redirect?page=changes>

Changes:

[Dave Page] Add feature tests to ensure that data types are properly rendered in the

[Dave Page] Pass the database ID to the query tool when using the Script options.

[Dave Page] Ensure the last placeholder is included when generating UPDATE scripts

[Dave Page] Order columns in multi-column pkeys correctly. Fixes #2417

------------------------------------------
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
[EnvInject] - Loading node environment variables.
Building in workspace <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url git://git.postgresql.org/git/pgadmin4.git # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
Fetching upstream changes from git://git.postgresql.org/git/pgadmin4.git
 > git --version # timeout=10
 > git fetch --tags --progress git://git.postgresql.org/git/pgadmin4.git +refs/heads/*:refs/remotes/origin/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision dba64e77f133c332c339421e3a4844639ea6767e (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f dba64e77f133c332c339421e3a4844639ea6767e
 > git rev-list 2f097cd016b305ca997a9a32c27b2586486fad61 # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
PYTHON_VERSION=2.6

[EnvInject] - Variables injected successfully.
[pgadmin4-master-python26] $ /bin/sh -xe /tmp/hudson3729791605364204408.sh
+ <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/ci/ci_runner.sh>
EXECUTING: Create pgAdmin config

EXECUTING: Python tests

Starting virtual frame buffer...

Creating Python 2.6 virtual environment...

New python executable in <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/bin/python>
Installing setuptools, pip, wheel...done.
Running virtualenv with interpreter /usr/local/python-2.6/bin/python
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting Babel==2.3.4 (from -r requirements.txt (line 4))
  Using cached Babel-2.3.4-py2.py3-none-any.whl
Collecting beautifulsoup4==4.4.1 (from -r requirements.txt (line 5))
  Using cached beautifulsoup4-4.4.1-py2-none-any.whl
Collecting blinker==1.3 (from -r requirements.txt (line 6))
Collecting click==6.6 (from -r requirements.txt (line 7))
  Using cached click-6.6-py2.py3-none-any.whl
Collecting extras==0.0.3 (from -r requirements.txt (line 8))
Collecting fixtures==2.0.0 (from -r requirements.txt (line 9))
  Using cached fixtures-2.0.0-py2.py3-none-any.whl
Collecting Flask==0.11.1 (from -r requirements.txt (line 10))
  Using cached Flask-0.11.1-py2.py3-none-any.whl
Collecting Flask-Babel==0.11.1 (from -r requirements.txt (line 11))
Collecting Flask-Gravatar==0.4.2 (from -r requirements.txt (line 12))
  Using cached Flask_Gravatar-0.4.2-py2.py3-none-any.whl
Collecting Flask-HTMLmin==1.2 (from -r requirements.txt (line 13))
Collecting Flask-Login==0.3.2 (from -r requirements.txt (line 14))
Collecting Flask-Mail==0.9.1 (from -r requirements.txt (line 15))
Collecting Flask-Migrate==2.0.3 (from -r requirements.txt (line 16))
Collecting Flask-Principal==0.4.0 (from -r requirements.txt (line 17))
Collecting Flask-Security==1.7.5 (from -r requirements.txt (line 18))
Collecting Flask-SQLAlchemy==2.1 (from -r requirements.txt (line 19))
Collecting Flask-WTF==0.12 (from -r requirements.txt (line 20))
  Using cached Flask_WTF-0.12-py2-none-any.whl
Collecting html5lib==1.0b3 (from -r requirements.txt (line 21))
Collecting importlib==1.0.3 (from -r requirements.txt (line 22))
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Collecting itsdangerous==0.24 (from -r requirements.txt (line 23))
Collecting Jinja2==2.7.3 (from -r requirements.txt (line 24))
Collecting linecache2==1.0.0 (from -r requirements.txt (line 25))
  Using cached linecache2-1.0.0-py2.py3-none-any.whl
Collecting MarkupSafe==0.23 (from -r requirements.txt (line 26))
Collecting ordereddict (from -r requirements.txt (line 27))
Collecting passlib==1.6.2 (from -r requirements.txt (line 28))
Collecting pbr==1.9.1 (from -r requirements.txt (line 29))
  Using cached pbr-1.9.1-py2.py3-none-any.whl
Collecting psycopg2>=2.7.1 (from -r requirements.txt (line 30))
  Using cached psycopg2-2.7.1-cp26-cp26m-manylinux1_x86_64.whl
Collecting pycrypto==2.6.1 (from -r requirements.txt (line 31))
Collecting pyrsistent==0.11.13 (from -r requirements.txt (line 32))
Collecting python-dateutil==2.5.0 (from -r requirements.txt (line 33))
  Using cached python_dateutil-2.5.0-py2.py3-none-any.whl
Collecting python-mimeparse==1.5.1 (from -r requirements.txt (line 34))
Collecting pytz==2014.10 (from -r requirements.txt (line 35))
  Using cached pytz-2014.10-py2.py3-none-any.whl
Collecting simplejson==3.6.5 (from -r requirements.txt (line 36))
Requirement already satisfied: six>=1.9.0 in ./pgadmin-venv/lib/python2.6/site-packages (from -r requirements.txt (line 37))
Collecting speaklater==1.3 (from -r requirements.txt (line 38))
Collecting SQLAlchemy==1.0.14 (from -r requirements.txt (line 39))
Collecting sqlparse==0.1.19 (from -r requirements.txt (line 40))
Collecting Werkzeug==0.9.6 (from -r requirements.txt (line 41))
Collecting WTForms==2.0.2 (from -r requirements.txt (line 42))
  Using cached WTForms-2.0.2-py2.py3-none-any.whl
Collecting backports.csv==1.0.4 (from -r requirements.txt (line 43))
  Using cached backports.csv-1.0.4-py2.py3-none-any.whl
Collecting testtools>=0.9.22 (from fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached testtools-2.3.0-py2.py3-none-any.whl
Collecting htmlmin (from Flask-HTMLmin==1.2->-r requirements.txt (line 13))
Collecting Flask-Script>=0.6 (from Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting alembic>=0.6 (from Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting unittest2>=1.0.0 (from testtools>=0.9.22->fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached unittest2-1.1.0-py2.py3-none-any.whl
Collecting traceback2 (from testtools>=0.9.22->fixtures==2.0.0->-r requirements.txt (line 9))
  Using cached traceback2-1.4.0-py2.py3-none-any.whl
Collecting Mako (from alembic>=0.6->Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Collecting python-editor>=0.3 (from alembic>=0.6->Flask-Migrate==2.0.3->-r requirements.txt (line 16))
Requirement already satisfied: argparse in ./pgadmin-venv/lib/python2.6/site-packages (from unittest2>=1.0.0->testtools>=0.9.22->fixtures==2.0.0->-r requirements.txt (line 9))
Installing collected packages: pytz, Babel, beautifulsoup4, blinker, click, extras, python-mimeparse, linecache2, traceback2, unittest2, pbr, testtools, fixtures, MarkupSafe, Jinja2, Werkzeug, itsdangerous, Flask, Flask-Babel, Flask-Gravatar, htmlmin, Flask-HTMLmin, Flask-Login, Flask-Mail, Flask-Script, python-dateutil, SQLAlchemy, Mako, python-editor, alembic, Flask-SQLAlchemy, Flask-Migrate, Flask-Principal, passlib, ordereddict, WTForms, Flask-WTF, Flask-Security, html5lib, importlib, psycopg2, pycrypto, pyrsistent, simplejson, speaklater, sqlparse, backports.csv
Successfully installed Babel-2.3.4 Flask-0.11.1 Flask-Babel-0.11.1 Flask-Gravatar-0.4.2 Flask-HTMLmin-1.2 Flask-Login-0.3.2 Flask-Mail-0.9.1 Flask-Migrate-2.0.3 Flask-Principal-0.4.0 Flask-SQLAlchemy-2.1 Flask-Script-2.0.5 Flask-Security-1.7.5 Flask-WTF-0.12 Jinja2-2.7.3 Mako-1.0.6 MarkupSafe-0.23 SQLAlchemy-1.0.14 WTForms-2.0.2 Werkzeug-0.9.6 alembic-0.9.2 backports.csv-1.0.4 beautifulsoup4-4.4.1 blinker-1.3 click-6.6 extras-0.0.3 fixtures-2.0.0 html5lib-1.0b3 htmlmin-0.1.10 importlib-1.0.3 itsdangerous-0.24 linecache2-1.0.0 ordereddict-1.1 passlib-1.6.2 pbr-1.9.1 psycopg2-2.7.1 pycrypto-2.6.1 pyrsistent-0.11.13 python-dateutil-2.5.0 python-editor-1.0.3 python-mimeparse-1.5.1 pytz-2014.10 simplejson-3.6.5 speaklater-1.3 sqlparse-0.1.19 testtools-2.3.0 traceback2-1.4.0 unittest2-1.1.0
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/req/req_file.py>:150: UserWarning: Disabling all use of wheels due to the use of --build-options / --global-options / --install-options.
  cmdoptions.check_install_build_global(options, opts)
Collecting pyperclip~=1.5.27 (from -r web/regression/requirements.txt (line 1))
  Using cached pyperclip-1.5.27.zip
Collecting selenium==3.3.1 (from -r web/regression/requirements.txt (line 2))
  Using cached selenium-3.3.1.tar.gz
Collecting testscenarios==0.5.0 (from -r web/regression/requirements.txt (line 3))
  Using cached testscenarios-0.5.0.tar.gz
Collecting testtools==2.0.0 (from -r web/regression/requirements.txt (line 4))
  Using cached testtools-2.0.0.tar.gz
Requirement already satisfied: traceback2==1.4.0 in ./pgadmin-venv/lib/python2.6/site-packages (from -r web/regression/requirements.txt (line 5))
Requirement already satisfied: unittest2==1.1.0 in ./pgadmin-venv/lib/python2.6/site-packages (from -r web/regression/requirements.txt (line 6))
Collecting chromedriver_installer==0.0.6 (from -r web/regression/requirements.txt (line 9))
  Using cached chromedriver_installer-0.0.6.tar.gz
Requirement already satisfied: pbr>=0.11 in ./pgadmin-venv/lib/python2.6/site-packages (from testscenarios==0.5.0->-r web/regression/requirements.txt (line 3))
Requirement already satisfied: extras in ./pgadmin-venv/lib/python2.6/site-packages (from testtools==2.0.0->-r web/regression/requirements.txt (line 4))
Requirement already satisfied: fixtures>=1.3.0 in ./pgadmin-venv/lib/python2.6/site-packages (from testtools==2.0.0->-r web/regression/requirements.txt (line 4))
Requirement already satisfied: pyrsistent in ./pgadmin-venv/lib/python2.6/site-packages (from testtools==2.0.0->-r web/regression/requirements.txt (line 4))
Requirement already satisfied: python-mimeparse in ./pgadmin-venv/lib/python2.6/site-packages (from testtools==2.0.0->-r web/regression/requirements.txt (line 4))
Requirement already satisfied: linecache2 in ./pgadmin-venv/lib/python2.6/site-packages (from traceback2==1.4.0->-r web/regression/requirements.txt (line 5))
Requirement already satisfied: six>=1.4 in ./pgadmin-venv/lib/python2.6/site-packages (from unittest2==1.1.0->-r web/regression/requirements.txt (line 6))
Requirement already satisfied: argparse in ./pgadmin-venv/lib/python2.6/site-packages (from unittest2==1.1.0->-r web/regression/requirements.txt (line 6))
Skipping bdist_wheel for pyperclip, due to binaries being disabled for it.
Skipping bdist_wheel for selenium, due to binaries being disabled for it.
Skipping bdist_wheel for testscenarios, due to binaries being disabled for it.
Skipping bdist_wheel for testtools, due to binaries being disabled for it.
Skipping bdist_wheel for chromedriver-installer, due to binaries being disabled for it.
Installing collected packages: pyperclip, selenium, testtools, testscenarios, chromedriver-installer
  Running setup.py install for pyperclip: started
    Running setup.py install for pyperclip: finished with status 'done'
  Running setup.py install for selenium: started
    Running setup.py install for selenium: finished with status 'done'
  Found existing installation: testtools 2.3.0
    Uninstalling testtools-2.3.0:
      Successfully uninstalled testtools-2.3.0
  Running setup.py install for testtools: started
    Running setup.py install for testtools: finished with status 'done'
  Running setup.py install for testscenarios: started
    Running setup.py install for testscenarios: finished with status 'done'
  Running setup.py install for chromedriver-installer: started
    Running setup.py install for chromedriver-installer: finished with status 'done'
Successfully installed chromedriver-installer-0.0.6 pyperclip-1.5.27 selenium-3.3.1 testscenarios-0.5.0 testtools-2.0.0
Running regression tests...

<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/flask_security/forms.py>:67: DeprecationWarning: Required is going away in WTForms 3.0, use DataRequired
  email_required = Required(message='EMAIL_NOT_PROVIDED')
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/flask_security/forms.py>:69: DeprecationWarning: Required is going away in WTForms 3.0, use DataRequired
  password_required = Required(message='PASSWORD_NOT_PROVIDED')
pgAdmin 4 - Application Initialisation
======================================

NOTE: Configuring authentication for DESKTOP mode.
Traceback (most recent call last):
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/regression/runtests.py",> line 93, in <module>
    app = create_app()
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/pgadmin/__init__.py",> line 439, in create_app
    app.register_blueprint(module)
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/flask/app.py",> line 65, in wrapper_func
    return f(self, *args, **kwargs)
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/flask/app.py",> line 968, in register_blueprint
    blueprint.register(self, options, first_registration)
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/pgadmin/utils/__init__.py",> line 57, in register
    self.submodules = list(app.find_submodules(self.import_name))
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/pgadmin/__init__.py",> line 64, in find_submodules
    module = import_module(module_name)
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/importlib/__init__.py",> line 37, in import_module
    __import__(name)
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/pgadmin/tools/datagrid/__init__.py",> line 21, in <module>
    from pgadmin.tools.sqleditor.command import *
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/pgadmin/tools/sqleditor/__init__.py",> line 20, in <module>
    from pgadmin.tools.sqleditor.command import QueryToolCommand
  File "<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/pgadmin/tools/sqleditor/command.py",> line 13, in <module>
    from collections import OrderedDict
ImportError: cannot import name OrderedDict
ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Process leaked file descriptors. See http://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build for more information
Build step 'Execute shell' marked build as failure

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Fri, 26 May 2017 16:22:34 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/244/display/redirect?page=changes>

Changes:

[Dave Page] Allow creation of ENUM types with no members. Fixes #2426

Cleaning workspace
Resetting working tree
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 2c9af4784e1423779c3f4a91a867d6408105ddff (origin/master)
 > git checkout -f 2c9af4784e1423779c3f4a91a867d6408105ddff
 > git rev-list dba64e77f133c332c339421e3a4844639ea6767e # timeout=10

[EnvInject] - Variables injected successfully.
[pgadmin4-master-python26] $ /bin/sh -xe /tmp/hudson6866098322083753559.sh
+ <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/ci/ci_runner.sh>
EXECUTING: Create pgAdmin config

EXECUTING: Python tests