Subject: Build failed in Jenkins: pgadmin4-master-python26 #647

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 13 Mar 2018 12:16:21 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/647/display/redirect?page=changes>

Changes:

[Dave Page] Fix template path generation for Windows. Fixes #3139

------------------------------------------
[...truncated 754.48 KB...]
		PackagePutTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymAddTestCase (Default Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)

PostgreSQL 9.2:

	270 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	23 tests skipped:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		ViewsGetTestCase (Get materialized view under schema node)
		SynonymDeleteTestCase (Fetch synonym Node URL)
		PackagePutTestCase (Fetch Package Node URL)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		SynonymAddTestCase (Default Node URL)
		ViewsAddTestCase (Add materialized view under schema node)
		PackageGetTestCase (Fetch Package Node URL)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		SynonymGetTestCase (Fetch synonym Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsAddTestCase (Add resource groups)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		ViewsUpdateTestCase (Update materialized view under schema node)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)

PostgreSQL 10:

	280 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	13 tests skipped:
		SynonymDeleteTestCase (Fetch synonym Node URL)
		SynonymGetTestCase (Fetch synonym Node URL)
		PackageDeleteTestCase (Fetch Package Node URL)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsAddTestCase (Add resource groups)
		PackagePutTestCase (Fetch Package Node URL)
		SynonymPutTestCase (Fetch synonym Node URL)
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		SynonymAddTestCase (Default Node URL)
		PackageAddTestCase (Fetch Package Node URL)
		PackageGetTestCase (Fetch Package Node URL)

EDB Postgres AS 9.4:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	3 tests skipped:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)

EDB Postgres AS 9.5:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	3 tests skipped:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)

EDB Postgres AS 9.6:

	290 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	3 tests skipped:
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		TestSSLConnection (Test for SSL connection)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)

EDB Postgres AS 9.2:

	278 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	15 tests skipped:
		ResourceGroupsAddTestCase (Add resource groups)
		EventTriggerDeleteTestCase (Fetch Event Trigger Node URL)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		ViewsGetTestCase (Get materialized view under schema node)
		TestSSLConnection (Test for SSL connection)
		ViewsDeleteTestCase (Delete materialized view under schema node)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)
		ResourceGroupsPutTestCase (Put resource groups)
		EventTriggerPutTestCase (Fetch Event Trigger Node URL)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		EventTriggerAddTestCase (Fetch Event Trigger Node URL)
		ViewsAddTestCase (Add materialized view under schema node)
		ViewsUpdateTestCase (Update materialized view under schema node)
		EventTriggerGetTestCase (Fetch Event Trigger Node URL)

EDB Postgres AS 9.3:

	286 tests passed
	1 test failed:
		TestExternalTablesView (#nodes When retrieving the nodes and an error happens while executing the query, it return an internal server error and status 500,
					#properties When retrieving the properties of a external table and the table exists, it return the properties and status 200,
					#nodes When retrieving the information about 1 external table and the table exists, it return external node information and status 200,
					#node When retrieving the information about 1 external table and an error happens while executing the query, it return an internal server error and status 500,
					#nodes When retrieving the nodes and the database has 2 external tables, it return 2 child nodes and status 200,
					#node When retrieving the information about 1 external table and table does not exist, it return an error message and status 404,
					#nodes When retrieving the nodes and the database does not have external tables, it return no child nodes and status 200)
	7 tests skipped:
		ResourceGroupsPutTestCase (Put resource groups)
		ResourceGroupsDeleteTestCase (Delete resource groups)
		TableUpdateTestCase (Detach partition from existing list partitioned table,
					Create partitions of existing range partitioned table,
					Detach partition from existing range partitioned table,
					Attach partition to existing range partitioned table,
					Attach partition to existing list partitioned table,
					Create partitions of existing list partitioned table)
		ResourceGroupsGetTestCase (Get resource groups)
		TestSSLConnection (Test for SSL connection)
		ResourceGroupsAddTestCase (Add resource groups)
		TableAddTestCase (Create Range partitioned table with 2 partitions,
					Create List partitioned table with 2 partitions)

======================================================================

NOTE: Configuring authentication for DESKTOP mode.
pgAdmin 4 - Application Initialisation
======================================

Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Executing and polling with: 2 NOTICES WITH DATASET
Executing and polling with: 1000 NOTICES WITH DATASET
Executing and polling with: NO NOTICE WITH DATASET
Please check output in file: <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/web/regression/regression.log>

ERROR: Error detected when running the Python tests.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

---

From: pgAdmin 4 Jenkins <[email-masked]>
Date: Tue, 13 Mar 2018 13:21:05 +0000 (UTC)

See <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/648/display/redirect?page=changes>