Subject: Control for displaying "auto vacuum" fields into grid

From: Surinder Kumar <[email-masked]>
Date: Fri, 18 Mar 2016 16:07:36 +0530

Hi,

PFA control for displaying auto vacuum fields into grid. This control is
common for
Materialized View Node and Table Node.

*Usage:*

{
  id: 'vacuum_table', label: '{{ _("Vacuum Table") }}',
  model: VacuumTableModel, editable: false, type: 'collection',
  canEdit: true, group: '{{ _("Table") }}',
  mode: ['edit', 'create'], url: 'get_vacuum_defaults',
  control: Backform.VacuumCollectionControl.extend({
    grid_columns :[
      {
        name: 'label', label: '{{ _("Label") }}',
        cell: 'string', editable: false
      },
      {
        name: 'value', label: '{{ _("Value") }}',
        cellFunction: cellFunction, editable: function(m) {
          if(m.handler.has('autovacuum_enabled')) {
            return m.handler.get('autovacuum_enabled');
          }
          return !m.handler.isNew();
        }
      },
      {
        name: 'setting', label: '{{ _("Default value") }}',
        cellFunction: cellFunction, editable: false
      }
    ]
  }),

When using this control, provide following parameters in schema:
*1. model*
2. *url - *to fetch default values for auto vacuum fields.
3. *grid columns - *Name of the columns to display in the grid.

Please review the patch.

Thanks
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 18 Mar 2016 15:28:14 +0000

On Fri, Mar 18, 2016 at 10:37 AM, Surinder Kumar
<[email-masked]> wrote:
> Usage:
> 1. model
> 2. url - to fetch default values for auto vacuum fields.
> 3. grid columns - Name of the columns to display in the grid.
>
>
> Please review the patch.

It's hard to review this without being able to test. Do you have a
simple test case?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 23 Mar 2016 21:34:31 +0530

Hi,

> It's hard to review this without being able to test. Do you have a

I have submitted patch for materialized view which is using this control.
so you can test it in materialized view.

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 25 Mar 2016 16:50:47 +0530

Hi Surinder,

Can you please move all genereic logic & sql at schema level so that we can use it in table node as well?
Currently it’s materialized view node centric only.

Regards,
Murtuza

> On 23-Mar-2016, at 9:34 pm, Surinder Kumar <[email-masked]> wrote:
> 
> Hi,
> 
> 
> On Fri, Mar 18, 2016 at 8:58 PM, Dave Page <[email-masked] <mailto:[email-masked]>> wrote:
> <[email-masked] <mailto:[email-masked]>> wrote:
> > Hi,
> >
> I have submitted patch for materialized view which is using this control. so you can test it in materialized view.
> 
> --
> Dave Page
> Blog: http://pgsnake.blogspot.com <http://pgsnake.blogspot.com/>
> Twitter: @pgsnake
> 
> EnterpriseDB UK: http://www.enterprisedb.com <http://www.enterprisedb.com/>

---

From: Surinder Kumar <[email-masked]>
Date: Fri, 25 Mar 2016 17:18:28 +0530

Ok, I will do.

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 7 Apr 2016 16:07:15 +0530

Hi,

Please find updated patch, I have moved everything at schema level and
tweak some code as well, so that we can use it in Table/View node.

Regards,
Murtuza

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 7 Apr 2016 16:19:32 +0530

Hi,

Rebase patch and sent again.

Regrds,
Murtuza

---

From: Surinder Kumar <[email-masked]>
Date: Mon, 11 Apr 2016 16:46:56 +0530

Hi,

I have made few minor changes in this patch to make it to work with
Materialized View.

PFA patch with following changes:
1. Fixed typo issue for url parameter.
2. Check for 'hastoasttable' attribute in Disabled property of field
"toast_autovaccum" in VacuumSettingsSchema.
3. Use Simplejson library instead of json.

On Thu, Apr 7, 2016 at 4:19 PM, Murtuza Zabuawala <
[email-masked]> wrote:

>>> I have submitted patch for materialized view which is using this
>>> control. so you can test it in materialized view.
>>>
>>>>
>>>> --
>>>> Dave Page