Subject: Quick search for menu items & help articles

From: Pramod Ahire <[email-masked]>
Date: Thu, 14 Jan 2021 16:54:05 +0530

Hi Team, 

Please find the attached designs & patch that contains complete functionality except below to do for quick search.

To Do: 

Unit test cases are not that sufficient to cover complete code, but will be working in background to cover up those one
In pgadmin, for disabled menu items we need to add info that will describe why menu has disabled & how it will be enabled. Either another way to enable all of them & show respective reason in popup that menu is disabled for. 

Please do let me know if I missed anything or suggestion of yours.

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

---

From: Dave Page <[email-masked]>
Date: Thu, 14 Jan 2021 16:55:54 +0000

Hi

On Thu, Jan 14, 2021 at 4:48 PM Pramod Ahire <[email-masked]>
wrote:

> Hi Team,
>
>
>
> Please find the attached designs & patch that contains complete
> functionality except below to do for quick search.
>
>
>
> To Do:
>
>
>
>    - Unit test cases are not that sufficient to cover complete code, but
>    will be working in background to cover up those one
>    - In pgadmin, for disabled menu items we need to add info that will
>    describe why menu has disabled & how it will be enabled. Either another way
>    to enable all of them & show respective reason in popup that menu is
>    disabled for.
>
>
>

Looks very good. I haven't done an extensive code review/test, but two
things spring to mind immediately:

1) I think the search box should be the top item on the Help menu. I do not
think it should be on the far end of the menu bar, as it looks too much
like it will search for data (think of search on a website).

2) Do we need another loading icon? Surely there's one in the source tree
already that we can use?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 15 Jan 2021 12:14:42 +0530

Hi Pramod

Following are the review comments:

   - linter issue "Undefined variable $black"
   - In Desktop mode remove the separator beside the search icon.

On Thu, Jan 14, 2021 at 10:18 PM Pramod Ahire <[email-masked]>
wrote:

> *Pramod Ahire*
> *Software Engineer*
> [image:
> https://lh4.googleusercontent.com/U1erEuyI_d0xEUA0CrKjwx9aWQ52HNCxc38dMsLP-ZrLgfVNrhsrNobxlmeOdb1kMPtrrxcUwEHZgbGJC4R0qR4r1sBZa_z9R8ihFRaP2Hr_Wnhq6HcIQHe1ZoviDPwUkTdzNcg]
>
>
>
> C: +91-020-66449600/601
>
> D: +91-9028697679
>
> *edbpostgres.com <http://edbpostgres.com>*
>
>
>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pramod Ahire <[email-masked]>
Date: Fri, 15 Jan 2021 12:53:24 +0530

Hi Dave,

Thank you for comments ! I had described points below. Please do let me know if anything missing.

From: Dave Page <[email-masked]>
Date: Thursday, 14 January 2021 at 10:26 PM
To: Pramod Ahire <[email-masked]>
Cc: pgadmin-hackers <[email-masked]>
Subject: Re: Quick search for menu items & help articles

Hi

On Thu, Jan 14, 2021 at 4:48 PM Pramod Ahire <[email-masked]> wrote:

Hi Team, 

To Do: 

Looks very good. I haven't done an extensive code review/test, but two things spring to mind immediately:

1) I think the search box should be the top item on the Help menu. I do not think it should be on the far end of the menu bar, as it looks too much like it will search for data (think of search on a website).

- As we are showing menu items as well in search results, it can be redundant for end user & increase duplications of menu items. Please advise your thoughts on this.

2) Do we need another loading icon? Surely there's one in the source tree already that we can use? 

- As we are loading help articles count in background, so I have added background loading icon to show near to count of results. Our existing icon is of blue & white circle combination, which will be more useful to show foreground loading.

Please do let me know your valuable inputs on this. 

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

---

From: Pramod Ahire <[email-masked]>
Date: Fri, 15 Jan 2021 12:54:02 +0530

Hi Akshay,

Thanks for your quick review ! Made changes as per your comments & attached patch with this email.

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

From: Akshay Joshi <[email-masked]>
Date: Friday, 15 January 2021 at 12:14 PM
To: Pramod Ahire <[email-masked]>
Cc: pgadmin-hackers <[email-masked]>
Subject: Re: Quick search for menu items & help articles

Hi Pramod

linter issue "Undefined variable $black"
In Desktop mode remove the separator beside the search icon.

On Thu, Jan 14, 2021 at 10:18 PM Pramod Ahire <[email-masked]> wrote:

Hi Team, 

To Do: 

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

-- 

Thanks & Regards

Akshay Joshi

pgAdmin Hacker | Principal Software Architect

EDB Postgres

Mobile: +91 976-788-8246

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Jan 2021 09:16:22 +0000

Hi

On Fri, Jan 15, 2021 at 7:23 AM Pramod Ahire <[email-masked]>
wrote:

> *From: *Dave Page <[email-masked]>
> *Date: *Thursday, 14 January 2021 at 10:26 PM
> *To: *Pramod Ahire <[email-masked]>
> *Cc: *pgadmin-hackers <[email-masked]>
> *Subject: *Re: Quick search for menu items & help articles
>
>
>
> Hi
>
>
>
> 1) I think the search box should be the top item on the Help menu. I do
> not think it should be on the far end of the menu bar, as it looks too much
> - As we are showing menu items as well in search results, it can be
> redundant for end user & increase duplications of menu items. Please advise
> your thoughts on this.
>

The search box could be on the Help menu, with results shown in a sub-menu
under it.

Another more simple option would be to move the search icon to be directly
after the Help menu (which would hint that it's related to the menus), but
I'm also concerned about the number of items on the top menu - we're
getting to the point that 'common' window sizes would show the hamburger
menu by default.

> - As we are loading help articles count in background, so I have added
> background loading icon to show near to count of results. Our existing icon
> is of blue & white circle combination, which will be more useful to show
> foreground loading.
>

Hmm, OK.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 15 Jan 2021 15:13:07 +0530

Hi Dave

On Fri, Jan 15, 2021 at 2:46 PM Dave Page <[email-masked]> wrote:

> Hi
>
> On Fri, Jan 15, 2021 at 7:23 AM Pramod Ahire <
> [email-masked]> wrote:
>
>> Hi Dave,
>>
>>
>>

    I personally feel we should not add the search box on the Help menu, it
should be kept separate with a placeholder indicating what is it for. We
can move the search icon after the Help menu.

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Jan 2021 09:45:06 +0000

On Fri, Jan 15, 2021 at 9:43 AM Akshay Joshi <[email-masked]>
wrote:

>>>    - Unit test cases are not that sufficient to cover complete code,
>>>    but will be working in background to cover up those one
>> The search box could be on the Help menu, with results shown in a
>> sub-menu under it.
>>
>> Another more simple option would be to move the search icon to be
>> directly after the Help menu (which would hint that it's related to the
>> menus), but I'm also concerned about the number of items on the top menu -
>> we're getting to the point that 'common' window sizes would show the
>> hamburger menu by default.
>>
>
>     I personally feel we should not add the search box on the Help menu,
> it should be kept separate with a placeholder indicating what is it for. We

What is your reasoning? It is, after all, specifically designed to help
people.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 15 Jan 2021 15:34:08 +0530

On Fri, Jan 15, 2021 at 3:15 PM Dave Page <[email-masked]> wrote:

>
>
> On Fri, Jan 15, 2021 at 9:43 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Dave
>>

    OK, I have seen a couple of applications where the search box is inside
the Help menu, agree with your point.

---

From: Pramod Ahire <[email-masked]>
Date: Wed, 20 Jan 2021 16:19:03 +0530

Hi Team,

As per inputs from you all, made changes & attached patch with this email.

Kindly please have a review & do let me know if missed anything.

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

From: Akshay Joshi <[email-masked]>
Date: Friday, 15 January 2021 at 3:34 PM
To: Dave Page <[email-masked]>
Cc: Pramod Ahire <[email-masked]>, pgadmin-hackers <[email-masked]>
Subject: Re: Quick search for menu items & help articles

 

On Fri, Jan 15, 2021 at 9:43 AM Akshay Joshi <[email-masked]> wrote:

Hi Dave

Hi

On Fri, Jan 15, 2021 at 7:23 AM Pramod Ahire <[email-masked]> wrote:

Hi Dave,

Hi

Hi Team, 

To Do: 

The search box could be on the Help menu, with results shown in a sub-menu under it.

Another more simple option would be to move the search icon to be directly after the Help menu (which would hint that it's related to the menus), but I'm also concerned about the number of items on the top menu - we're getting to the point that 'common' window sizes would show the hamburger menu by default.

    I personally feel we should not add the search box on the Help menu, it should be kept separate with a placeholder indicating what is it for. We can move the search icon after the Help menu.

What is your reasoning? It is, after all, specifically designed to help people.

    OK, I have seen a couple of applications where the search box is inside the Help menu, agree with your point. 

Hmm, OK.

 

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

---

From: Pramod Ahire <[email-masked]>
Date: Wed, 20 Jan 2021 16:36:38 +0530

Hi Team,

Sorry for the inconvenience, kindly please discard previous email.

Please review patch attached to this email. 

Changes as below :

 1. Added complete quick search menu to help dropdown
 2. Added message to each disabled menu item to describe why it can be disabled

 3. Info icon design to menu items results if disabled
 4. Standard/dark/high contrast theme supports

NOTE: “Initial backend search mechanism patch by: Murtuza Zabuawala”

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

From: Pramod Ahire <[email-masked]>
Date: Wednesday, 20 January 2021 at 4:19 PM
To: Akshay Joshi <[email-masked]>, Dave Page <[email-masked]>
Cc: pgadmin-hackers <[email-masked]>
Subject: Re: Quick search for menu items & help articles

Hi Team,

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

 

Hi Dave

Hi

Hi Dave,

Hi

Hi Team, 

To Do: 

 

Hmm, OK.

 

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 25 Jan 2021 15:53:20 +0530

Hi Pramod

The patch is not applied, maybe you need to rebase and send the patch again.

On Wed, Jan 20, 2021 at 4:36 PM Pramod Ahire <[email-masked]>
wrote:

> *From: *Pramod Ahire <[email-masked]>
> *Date: *Wednesday, 20 January 2021 at 4:19 PM
> *To: *Akshay Joshi <[email-masked]>, Dave Page <
> [email-masked]>
> *From: *Akshay Joshi <[email-masked]>
> *Date: *Friday, 15 January 2021 at 3:34 PM
> *To: *Dave Page <[email-masked]>
> *Cc: *Pramod Ahire <[email-masked]>, pgadmin-hackers <
> [email-masked]>
>     OK, I have seen a couple of applications where the search box is
> inside the Help menu, agree with your point.
>
>
>
>
>
>
>

---

From: Pramod Ahire <[email-masked]>
Date: Mon, 01 Feb 2021 13:32:33 +0530

Hi Akshay,

Please find the rebased patch as attached with this email.

Please do let me know if need anything else.

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

From: Akshay Joshi <[email-masked]>
Date: Monday, 25 January 2021 at 3:53 PM
To: Pramod Ahire <[email-masked]>
Cc: Dave Page <[email-masked]>, pgadmin-hackers <[email-masked]>
Subject: Re: Quick search for menu items & help articles

Hi Pramod

On Wed, Jan 20, 2021 at 4:36 PM Pramod Ahire <[email-masked]> wrote:

Hi Team,

Changes as below :

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

Hi Team,

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

 

Hi Dave

Hi

Hi Dave,

Hi

Hi Team, 

To Do: 

 

Hmm, OK.

 

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 2 Feb 2021 14:48:42 +0530

Thanks, patch applied with some string modifications.

On Mon, Feb 1, 2021 at 1:32 PM Pramod Ahire <[email-masked]>
wrote:

> *Date: *Monday, 25 January 2021 at 3:53 PM
> *Cc: *Dave Page <[email-masked]>, pgadmin-hackers <

---

From: Pramod Ahire <[email-masked]>
Date: Wed, 03 Feb 2021 11:26:53 +0530

Hi Akshay,

As reported jasmine test case failure for quick search, had fixed issue & attached here in email.

Kindly also find below updates in the patch:

 1. Jasmine test cases fixed

 2. Added missing messages for disabled menu items
 3. Removed single quotes from ‘data_disabled’ -> data_disabled

Please review & do let me know if missed anything.

Thanks!

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

Date: Tuesday, 2 February 2021 at 2:48 PM

On Mon, Feb 1, 2021 at 1:32 PM Pramod Ahire <[email-masked]> wrote:

Hi Akshay,

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

Hi Pramod

Hi Team,

Changes as below :

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

Hi Team,

Thanks !

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

 

Hi Dave

Hi

Hi Dave,

Hi

Hi Team, 

To Do: 

 

Hmm, OK.

 

Pramod Ahire

Software Engineer

C: +91-020-66449600/601

D: +91-9028697679

edbpostgres.com

 

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Dave Page

 

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

-- 

Thanks & Regards

Akshay Joshi

EDB Postgres

Mobile: +91 976-788-8246

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 3 Feb 2021 11:53:49 +0530

Hello,

> Thanks, patch applied with some string modifications.

Co-author name is missing from the commit message,

The feature is implemented in two parts,
Frontend: Pramod
Backend: Murtuza (As mentioned by Pramod in the previous email)

Thanks,
Murtuza

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 3 Feb 2021 12:59:46 +0530

Thanks, patch applied.

On Wed, Feb 3, 2021 at 11:27 AM Pramod Ahire <[email-masked]>
wrote:

> *Date: *Tuesday, 2 February 2021 at 2:48 PM