Subject: PATCH: To fix Timestamps displaying with time as 00:00 (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 14 Jul 2016 11:30:55 +0530

Hi,

PFA patch to fix the issue in timestamp datatype(s) displaying with time as
00:00
(RM#1437)

The issue was with backgrid datetime cell which do not fully support ISO-8601
datetime format.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Jul 2016 12:01:07 +0100

Hi

On Thu, Jul 14, 2016 at 7:00 AM, Murtuza Zabuawala
<[email-masked]> wrote:
> The issue was with backgrid datetime cell which do not fully support
> ISO-8601 datetime format.

Thanks - this worked, except for the 'interval' type, I've committed
the patch without that change; please submit another fixing that
remaining issue.

e.g. select '1 month'::interval

displays: 00:00:00

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 18 Jul 2016 12:04:14 +0530

Hi Dave,

Please find patch to fix the issue for interval type casting.

Regards,
Murtuza

---

From: Dave Page <[email-masked]>
Date: Mon, 18 Jul 2016 09:42:23 +0100

Thanks - applied.