Subject: Re: [pgAdmin 4 - Bug #1292] ERROR: template database "!@#$%^&*()_+{}|:"<>?=-\\][';/.," does not exist message throws if template database contain special charterers

From: Sanket Mehta <[email-masked]>
Date: Mon, 20 Jun 2016 19:26:52 +0530

Hi,

PFA the revised patch to resolve this issue which consists the change in
control formatter.

Regards,
Sanket Mehta
Sr Software engineer
Enterprisedb

On Mon, Jun 13, 2016 at 3:12 PM, <[email-masked]> wrote:

> Issue #1292 has been updated by Dave Page.
>
>    - *Target version* deleted (*1.0 Beta 1*)
>
> ------------------------------
> Bug #1292: ERROR: template database "!@#$%^&*()_+{}|:"<>?=-\\][';/.," does
> not exist message throws if template database contain special charterers
> <https://redmine.postgresql.org/issues/1292#change-2631>
>
>    - Author: Fahar Abbas
>    - Status: In Progress
>    - Priority: Normal
>    - Assignee: Sanket Mehta
>    - Category:
>    - Target version:
>
> Commit ID:
> -----------
> commit 954163b4957c1dce89c0632d009b845cbe90faf4
>
> Browser version:
> ----------------
> Firefox 45.0.2
>
> Python version:
> ----------------
> 3.5.1+
>
> Platforms:
> All
>
> ERROR: template database "!@#$%^&*()_+{}|:"<>?=-\\][';/.," does not exist
> message throws if user try to create database with template database that
> name contain special charterers.
>
> Please note that this issue is not reproducible in other template
> databases that name is simple one.
>
> Please note that this is not reproduce in pgAdmin3.
>
> Steps:
>
> 1. Install pgAdmin4 on Ubuntu 16.04
> 2. Install PG-9.6-beta 1 installer
> 3. Expand database node
> 4. give it's name !#$%^&*()_+{}|:"<>?=-\][';/.,
> 5. Database created successfully
> 6. Again create new database and give it's name abcd
> 7. Click on definition tab
> 8. select template database !#$%^&*()_+{}|:"<>?=-\][';/.,
> 9. Click on Save button
> Files Screen Shot 2016-06-02 at 10.25.34 am.png
> <https://redmine.postgresql.org/attachments/download/1197/Screen%20Shot%202016-06-02%20at%2010.25.34%20am.png>
> (1020 KB)
> Screen Shot 2016-06-02 at 10.26.01 am.png
> <https://redmine.postgresql.org/attachments/download/1198/Screen%20Shot%202016-06-02%20at%2010.26.01%20am.png>
> (1.03 MB)
> ------------------------------
>
> You have received this notification because you have either subscribed to
> it, or are involved in it.
> To change your notification preferences, please click here:
> https://redmine.postgresql.org/my/account
>
diff --git a/web/pgadmin/static/js/backform.pgadmin.js b/web/pgadmin/static/js/backform.pgadmin.js
index c33289c..4466c1c 100644
--- a/web/pgadmin/static/js/backform.pgadmin.js
+++ b/web/pgadmin/static/js/backform.pgadmin.js
@@ -1787,7 +1787,7 @@
   var Select2Formatter = function() {};
   _.extend(Select2Formatter.prototype, {
     fromRaw: function(rawData, model) {
-      return JSON.stringify(_.escape(rawData));
+      return JSON.parse(JSON.stringify(_.escape(rawData)));
     },
     toRaw: function(formattedData, model) {
       return formattedData;

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Mon, 20 Jun 2016 16:04:32 +0100

Thanks, patch applied.

On Mon, Jun 20, 2016 at 2:56 PM, Sanket Mehta
<[email-masked]> wrote:
>> Target version deleted (1.0 Beta 1)
>>
>> ________________________________
>>
>> Author: Fahar Abbas
>> Status: In Progress
>> Priority: Normal
>> Assignee: Sanket Mehta
>> Category:
>> Target version:
>> Files Screen Shot 2016-06-02 at 10.25.34 am.png (1020 KB)
>> Screen Shot 2016-06-02 at 10.26.01 am.png (1.03 MB)
>> ________________________________
>>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 24 Jun 2016 16:54:30 +0530

Hi,

PFA patch to fix the issue RM#1292.

Earlier patch was not handling spaces properly.
e.g- If user creates any objects which has spaces in its name then it fails
to parse it next time user select it.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Fri, 24 Jun 2016 14:10:43 +0100

Thanks, applied.

---

From: Harshal Dhumal <[email-masked]>
Date: Tue, 5 Jul 2016 12:42:13 +0530

Hi,

This patch has caused another new issue (or regression).

Issue: Select2 control does not work in multi-select mode.

Node affected due to this are Primary key, unique key, and all other node
where we have used select2 control in multi-select mode.

Commit id:   4267545e08cb28b8c4574bb7a5da0322ef7728d2

-- 
*Harshal Dhumal*
*Software Engineer*

EnterpriseDB India: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

On Fri, Jun 24, 2016 at 4:54 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> e.g- If user creates any objects which has spaces in its name then it
> fails to parse it next time user select it.
>
>
>
> --
> Regards,
> Murtuza Zabuawala

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 5 Jul 2016 12:43:11 +0530

Can you please look into it?
On Jul 5, 2016 12:42, "Harshal Dhumal" <[email-masked]>