Subject: RM-4320: Rename tab

From: Nikhil Mohite <[email-masked]>
Date: Thu, 15 Oct 2020 14:59:21 +0530

Hi Team,

Regarding the RM-4230 <https://redmine.postgresql.org/issues/4230> rename
tab: implementation approach.

1. We can add the "Rename Panel" option on the panel right-click where we
show other options like "Remove Panel".
2. Clicking on the "Rename panel" option, a dialog box will open to take
user input for panel title and the entered value will get set as panel
title.

Questions:
1. Do we need any different icons for the rename panel option? (just resued
edit icon for demo).
2. Should we update the tooltip of that renamed panel with user-entered
value?
3. Should we allow the user to add placeholders for the panel title from
the Rename panel dialog? (We have added placeholders for Query tool and
View/Edit Data in preferences to customization in the tab title.)

Any suggestions or anything I have missed in this please let me know.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Oct 2020 10:45:39 +0100

Hi

On Thu, Oct 15, 2020 at 10:29 AM Nikhil Mohite <
[email-masked]> wrote:

> 1. Do we need any different icons for the rename panel option? (just
> resued edit icon for demo).
>

I think that's fine.

> 2. Should we update the tooltip of that renamed panel with user-entered

Yes please.

> View/Edit Data in preferences to customization in the tab title.)

Yes please.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com