Subject: Is requirements.txt up2date?

From: Devrim Gündüz <[email-masked]>
Date: Wed, 05 Jun 2019 12:59:42 +0100

Hi,

I recently hit by some missing or not up2date Python modules while
building/installing pgAdmin4.

Recent one is Werkzeug, and I also hit an issue with blinker. Both of these do
not appear in requirements.txt. Are we sure that this list is up2date?

Cheers,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Dave Page <[email-masked]>
Date: Wed, 5 Jun 2019 13:02:23 +0100

Hi

> not appear in requirements.txt. Are we sure that this list is up2date?

Yes. They're indirect dependencies, so don't appear in the list we
maintain. Not sure about Blinker, but Werkzeug will be defined in the
requirements.txt file for Flask.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 11 Jun 2019 02:13:55 +0300

Hi,

> requirements.txt file for Flask.

Ack, thanks!

Cheers,