Subject: [pgAdmin4][Patch]: RM 3702 - pgAdmin dashboard showing the oid for the user-defined tables and table names for the catalog tables in locks monitoring window

From: Khushboo Vashi <[email-masked]>
Date: Fri, 4 Jan 2019 14:48:43 +0530

Hi,

Please find the attached patch to fix RM #3702 - pgAdmin dashboard showing
the oid for the user-defined tables and table names for the catalog tables
in locks monitoring window.

Dashboard > Server Activity > Locks - shows the table oid in the 'Target
relation' column instead of table name.

The attached patch fixes this issue for the database level but not for the
server level.  The reason for this is, at the server level we fetch the
data from the pg_locks with the maintenance database, so it can not fetch
the pg_class relation for the other database tables (relation::regclass).

Please find the attached screen-shots for the issue and the fix and let me
know if there is any other way to fix this.

Thanks,
Khushboo

---

From: Dave Page <[email-masked]>
Date: Fri, 4 Jan 2019 14:45:40 +0000

Thanks, patch applied.

On Fri, Jan 4, 2019 at 11:53 AM Khushboo Vashi
<[email-masked]> wrote:
>
> Hi,
>
> Please find the attached patch to fix RM #3702 - pgAdmin dashboard showing the oid for the user-defined tables and table names for the catalog tables in locks monitoring window.
>
> Dashboard > Server Activity > Locks - shows the table oid in the 'Target relation' column instead of table name.
>
> The attached patch fixes this issue for the database level but not for the server level.  The reason for this is, at the server level we fetch the data from the pg_locks with the maintenance database, so it can not fetch the pg_class relation for the other database tables (relation::regclass).
>
> Please find the attached screen-shots for the issue and the fix and let me know if there is any other way to fix this.
>
> Thanks,
> Khushboo
>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company