Subject: PATCH: Dialogue control buttons should be consistent (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 6 Jan 2017 19:12:13 +0530

Hi,

PFA patch to fix the issue where  some dialogue control buttons were not
consistent with others dialogs.
RM#1364

Patch fixes,
1) Preferences: Close, Maximise, Pin
- Removed Pin button

2) Wizards: Close
- Added Maximise button, which is can used with 'show_header_maximize_btn'
option.

3) Properties: Close
- N/A, As this is custom wcDocker panel not alertify dialog.

4) User manager: Maximise
- We can't have close button in User Manager as data validation was main
requirement, If user clicks on right top close button while having dirty
data in dialog then we can't stop alertify dialog from closing even with
confirm prompt hence we have removed the button.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Sun, 8 Jan 2017 10:35:49 +0000

Thanks, patch applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company