Subject: [pgAdmin4][Patch]: SQL Help Fix

From: Khushboo Vashi <[email-masked]>
Date: Fri, 15 Apr 2016 18:40:13 +0530

Hi,

The SQL Help Tab does not load the Help page on the Google Chrome (version:
39.0) browser.

Please find the attached patch for the same.

Thanks,
Khushboo
diff --git a/web/pgadmin/browser/templates/browser/js/node.js b/web/pgadmin/browser/templates/browser/js/node.js
index 331d818..d38eee7 100644
--- a/web/pgadmin/browser/templates/browser/js/node.js
+++ b/web/pgadmin/browser/templates/browser/js/node.js
@@ -731,7 +731,7 @@ function($, _, S, pgAdmin, Menu, Backbone, Alertify, pgBrowser, Backform) {
           minor = Math.floor(server.version / 100) - (major * 100)
 
           url = url.replace('$VERSION$', major + '.' + minor)
-          if (!url.endsWith('/')) {
+          if (!S(url).endsWith('/')) {
             url = url + '/'
           }
           if (that.sqlCreateHelp == '' && that.sqlAlterHelp != '') {

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Apr 2016 14:27:28 +0100

Thanks, committed.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company