Subject: [pgAdmin 4 UI bug] unable to add foreign keys through the UI

From: Michael Meerschaert <[email-masked]>
Date: Sat, 23 Jul 2016 11:04:14 -0700

Hi,

I'm sorry if there is an official bugzilla or something for reporting bugs,
but from the comments here
<http://pgsnake.blogspot.com/2016/04/pgadmin-4-elephant-nears-finish-line.html>
it
seems like this is the preferred way to report issues.

---

From: Dave Page <[email-masked]>
Date: Mon, 25 Jul 2016 09:16:04 +0100

Hi

Thanks - please log this here:
https://redmine.postgresql.org/projects/pgadmin4/issues/new (if you do
it rather than me, you'll get emailed when there are updates).

Cheers, Dave.

On Sat, Jul 23, 2016 at 7:04 PM, Michael Meerschaert
<[email-masked]> wrote:
> but from the comments here it seems like this is the preferred way to report
> issues.
>
> From the Create - Table dialog, I am unable to add foreign keys. Here's step
> by step what i'm trying to do:
>
>  Click Constraints > Foreign Key and click Add
>  A row appears where i can click edit, trash or enter a name, I also see a
> red banner at the bottom saying "Please Specify Columns for foreign key
> The columns field is greyed out, so I click the edit icon (If i enter a
> name, it populates to the name field under general)
> Click Columns
> Select the local column
> select the references table
>
> As a side note, if there is only 1 other table in the schema, the
> "references" drop down will default to it, but you cannot select a column
> from "referencing" from the default dropdown option. You must first change
> the "references" option, which is impossible if there is only 1 table. Also,
> even if there are multiple tables, and the references table is correct, you
> still have to change it to another option then change it back to get the
> columns in the "referencing" dropdown to show up. This bug has a workaround,
> but still feels like a bug.
>
> select the column for "Referencing"
> click add
> nothing happens, the red banner that says please specify columns for foreign
> key is still there.
>
> I can just execute raw SQL to add the constraints, and the UI picks up on
> the fact that the constraints are there, but I'm still unable to add new FKs
> through the UI. Also, when I click edit on an existing FK, all the options
> on the columns and Action tabs are greyed out.
>
> I'm running windows 10 64-bit.
>
>
> --
> -Mike

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers