Subject: [pgAdmin4][Patch]: RM1627 - Objects are not visible after creation until press refresh button

From: Surinder Kumar <[email-masked]>
Date: Mon, 19 Sep 2016 20:53:52 +0530

Hi

Please find patch with following fixes:

1) Newly added server-group not listing in tree view.

2) On creating a first node for collection node with no child. the created
node doesn't show up under its respective parent node.
- to add a node to child under its parent node. its parent node attribute
must be set 'inode: true' but it always gets false for inode that doesn't
add the node.

Ashesh - Can you please review it?

Thanks
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Mon, 19 Sep 2016 17:19:48 +0100

Hi

> Ashesh - Can you please review it?

I tested this by adding a sequence to a database and schema that
didn't previously contain any. The node was not added, and in the
Javascript console I get:

browser.js:1108 Failed to append

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Tue, 20 Sep 2016 14:52:53 +0530

> browser.js:1108 Failed to append

​This issue is taken care in updated patch, Also properly handled the case
for 'server-group' not listing in tree view, thus removing
'addNodeWithNoParent' method from previous patch.
I have tested it for most of the nodes, it works.
Please find updated patch and review.

---

From: Dave Page <[email-masked]>
Date: Tue, 20 Sep 2016 11:18:31 +0100

On Tue, Sep 20, 2016 at 10:22 AM, Surinder Kumar
<[email-masked]> wrote:
> This issue is taken care in updated patch, Also properly handled the case

Works nicely - applied, thanks.