Subject: Re: PATCH: to fix jsonb type rendering in runtime (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 04 Jul 2016 09:26:33 +0530

Hi Dave,

I'm unable to reproduce the issue mentioned by you on my side, would you please provide console log/error ?

Regards,
Murtuza On 30-Jun-2016 6:26 PM, Dave Page <[email-masked]> wrote:
>
> Hi 
>
> On Thu, Jun 30, 2016 at 11:37 AM, Murtuza Zabuawala 
> <[email-masked]> wrote: 
> > Hi Dave, 
> > 
> > PFA updated patch. 
> > Tested with json/json[]/jsonb/jsonb[] (on browsers & runtime). 
>
> I can't add rows to a table with this patch applied: 
>
> 1) Create a table 
>
> create table test(id serial primary key, j json, jb jsonb, ja json[], 
> jba jsonb[]) 
>
> 2) Right-click the table in the treeview, and view the data 
>
> 3) Click the + button to add a new row 
>
> 4) The warning about moving to the last page of results is shown, but 
> clicking OK doesn't dismiss the dialogue. 
>
> If I remove the patch, everything works again. 
>
> -- 
> Dave Page 
> Blog: http://pgsnake.blogspot.com 
> Twitter: @pgsnake 
>
> EnterpriseDB UK: http://www.enterprisedb.com 
> The Enterprise PostgreSQL Company 

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Mon, 4 Jul 2016 10:07:27 +0100

Hi

> I'm unable to reproduce the issue mentioned by you on my side, would you please provide console log/error ?

Neither can I now - it seems to be working fine so I've committed the patch.

Sorry for the noise!