Subject: [pgAdmin4][Patch]: Busy icon not visible in Debugger and Query tool in Runtime environment

From: Surinder Kumar <[email-masked]>
Date: Fri, 8 Jul 2016 13:00:31 +0530

Hi

The spinner icon is not visible while executing query or running debugger
in Runtime environment specific to Ubuntu. This issue is related to RM#1186

To make it work, we need to explicitly set *-webkit-animation* property to
'none' for classes "sql-editor-busy-icon.fa-pulse" and ".debugger-container
fa-pulse".

'fa-pulse' class is responsible to spin the busy icon, but setting its*
-webkit-animation* property to none will not spin icon but icon and message
will be shown.

Please review

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 13 Jul 2016 12:32:14 +0100

Thanks, applied.

On Fri, Jul 8, 2016 at 8:30 AM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> The spinner icon is not visible while executing query or running debugger in
> Runtime environment specific to Ubuntu. This issue is related to RM#1186
>
> To make it work, we need to explicitly set -webkit-animation property to
> 'fa-pulse' class is responsible to spin the busy icon, but setting its
> -webkit-animation property to none will not spin icon but icon and message
> will be shown.
>
> Please review
>
> Thanks,
> Surinder Kumar
>
>
> --

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company