Subject: [pgAdmin4][Patch]: SYNONYM issue if use all special characters as name

From: Surinder Kumar <[email-masked]>
Date: Fri, 14 Oct 2016 19:48:06 +0530

Hi

*Issue:*
If synonym name contains special characters, the request url is be '404 not
found'.
i.e. It doesn't hit at 'sql' method of synonym.

*Solution:*
If URL has an identifier containing slash character '/' into the URI, then
set param type to path.
like /<path: int>.
Because if param name contains '/' in synonym name, it gets confused and
wrong route is formed.
Reference:- http://flask.pocoo.org/snippets/76/

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Sat, 15 Oct 2016 00:02:16 +0100

Thanks, patch applied.

On Friday, October 14, 2016, Surinder Kumar <[email-masked]>
wrote:

> Hi
>
> *Issue:*
> If synonym name contains special characters, the request url is be '404
> not found'.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company