Subject: PATCH: To fix adding/updating Security Labels in various nodes (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 19 Jul 2016 19:45:30 +0530

Hi,

PFA patch to fix the issue where user was not able to add/update/drop
security labels in various nodes.
(RM#1457)

Affected nodes with this patch,

TABLE               --> Fixed
COLUMN              --> Fixed
DATABASE            --> Fixed
DOMAIN              --> Fixed
ROLE                --> Fixed
SCHEMA              --> Fixed
SEQUENCE            --> Fixed
TYPE                --> Fixed
VIEW                --> Fixed
EVENT TRIGGER       --> Fixed
FOREIGN TABLE       --> Fixed
FUNCTION            --> Fixed
LANGUAGE            --> Fixed

Please review.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Thu, 21 Jul 2016 16:36:05 +0100

Hi

> security labels in various nodes.

Thanks, applied (with a minor fix to s/LABLE/LABEL/g)

It does need one minor tweak though - the provider field should be
optional; see https://www.postgresql.org/docs/9.4/static/sql-security-label.html.

Can you fix that when you get a minute please?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company