Subject: [pgAdmin4][Patch]: RM#1462- AJAX request do not get fired second time

From: Surinder Kumar <[email-masked]>
Date: Mon, 18 Jul 2016 13:04:34 +0530

Hi

Please find attached patch for the fix:
*Issue:*
This issue is regression of one of the flickering issue of RM#1242.
"Aside from displaying/hiding the spinner, panes should have their content
refreshed until and unless the new data differs from the previous, to
reduce flicker"

*Solution:*
Along with caching the node node, we should also keep track of the previous
node clicked.
Fetch new data iff previous node and current node clicked differs.

Please review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Mon, 18 Jul 2016 09:50:57 +0100

Hi

On Mon, Jul 18, 2016 at 8:34 AM, Surinder Kumar
<[email-masked]> wrote:
> Issue:
> refreshed until and unless the new data differs from the previous, to reduce
> flicker"
>
> Solution:

This doesn't fix the issue for me. My test case:

1) Select the SQL tab
2) Click a schema, and the SQL is displayed.
3) Click Schemas, and "-- No SQL could be generated for the selected
object." is displayed.
4) Click the same schema as in step 2 again, and "-- No SQL could be
generated for the selected object." remains displayed.

Note that clicking any other schema in step 4 works fine.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company